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Function Point Modeler Workbench

Introduction
Function Point Modeler is a new generation tool for Function Point Analysis to measure Software. It is a IFPUG
CPM conform tool, designed by Certified Function Point Specialists to meet all requirements in our daily work as
Function Point Specialists. It is the first product to combine Function Point Models with other Models and exchanges
Models over XMI-API (UseCase Model, Business Object Class Model and Data Model).

The Function Point Modeler is based on the most popular open source Eclipse platform. It can be run both as stand-
alone Application and as Plugin/Feature in Eclipse to interact with both the Eclipse platform and other UML-
Modeling Tools.

It supports the life-cycle of elementary processes and application systems and tracks its functional changes. Function
Point Modeler supports UML-Like Syntax, Different PDF reports and a lot of other features...

See the Function Point Modeler web site at www.functionpointmodeler.com for additional information.

Getting started

Function Point Analysis

Function point analysis is a standard method for measuring software development from the user's point of view.
Function point analysis measures software by quantifying the functionality the software provides to the user based
primarily on logical design.

Refer to IFPUG document Function Point Counting Practices Manual for additional information about the function
point analysis, or see the IFPUG web site at http://www.ifpug.org for additional information.

Introduction to Function Point Analysis

A function point is a unit of measurement to express the amount of business functionality an information system
provides to a user. The cost (in dollars or hours) of a single unit is calculated from past projects. Function points are
the units of measure used by the IFPUG Functional Size Measurement Method. The IFPUG FSM Method is an ISO
recognized software metric to size an information system based on the functionality that is perceived by the user of
the information system, independent of the technology used to implement the information system. The IFPUG FSM
Method (ISO/IEC 20926 Software Engineering - Function Point Counting Practices Manual) is one of five currently
recognized ISO standards for functionally sizing software.

Function points were defined in 1979 in A New Way of Looking at Tools by Allan Albrecht at IBM. The functional
user requirements of the software are identified and each one is categorized into one of five types: outputs, inquiries,
inputs, internal files, and external interfaces. Once the function is identified and categorized into a type, it is then
assessed for complexity and assigned a number of function points. Each of these functional user requirements maps
to an end-user business function, such as a data entry for an Input or a user query for an Inquiry. This distinction
is important because it tends to make the functions measured in function points map easily into user-oriented
requirements, but it also tends to hide internal functions (e.g. algorithms), which also require resources to implement.
Over the years there have been different approaches proposed to deal with this perceived weakness, however there
is no ISO recognized FSM Method that includes algorithmic complexity in the sizing result. The variations of the
Albrecht based IFPUG method designed to make up for this (and other weaknesses) include:

• Early and easy function points. Adjusts for problem and data complexity with two questions that yield a somewhat
subjective complexity measurement; simplifies measurement by eliminating the need to count data elements.

ditafileswww.functionpointmodeler.com
http://www.ifpug.org
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• Engineering function points. Elements (variable names) and operators (e.g., arithmetic, equality/inequality,
Boolean) are counted. This variation highlights computational function.The intent is similar to that of the operator/
operand-based Halstead Complexity Measures.

• Bang measure - Defines a function metric based on twelve primitive (simple) counts that affect or show Bang,
defined as "the measure of true function to be delivered as perceived by the user." Bang measure may be helpful
in evaluating a software unit's value in terms of how much useful function it provides, although there is little
evidence in the literature of such application. The use of Bang measure could apply when re-engineering (either
complete or piecewise) is being considered, as discussed in Maintenance of Operational Systems -An Overview.

• Feature points. Adds changes to improve applicability to systems with significant internal processing (e.g.,
operating systems, communications systems). This allows accounting for functions not readily perceivable by the
user, but essential for proper operation.

Objectives of Function Point Analysis

Most practitioners of Function Point Analysis (FPA) will probably agree that there are three main objectives within
the process of FPA:

• Measure software by quantifying the functionality requested by and provided to the customer.
• Measure software development and maintenance independently of technology used for implementation.
• Measure software development and maintenance consistently across all projects and organizations.

In working towards objectives 2 and 3 above, several organizations have created large repositories of FP counts that
cross projects, technologies, and organizations. These repositories can be an invaluable tool for your first estimation
efforts, because it lets you compare your project to similar projects that have been developed by other organizations
around the world.

What is a "Function Point"

One of the first questions we are always asked is a logical one: "What is a function point?" . Simply stated, function
points are a standard unit of measure that represent the functional size of a software application.

In the same way that a house is measured by the square feet it provides, the size of an application can be measured
by the number of function points it delivers to the users of the application. A good example is when we had build
our house two years ago. We worked with a very straightforward home builder and he basically said "You have
two choices here. First, how many square feet do you want to build? Second, what quality of materials do you want
to use?'' He continued "Let's say that you want to build a house that is 2,000 square feet. If you want to use cheap
materials we can build it for $80 per square feet. That's $160,000. If you want to go top of the line then you're looking
at more like $110 per square foot, and that's $220,000. What would you like?"

Don't read into this example that building a software application is like building a house. We all know that there are a
lot of other variables, and it's not quite this simple. But function points do get you a lot closer. For example, although
it's not like building a house, We're currently working on a Java software development project where we are building
a Swing-based application that runs on Windows and Mac computer platforms. We're building this application on a
fixed-price basis, at a rate of approximately $250/FP. So, is it like building a house? No. But can we bid projects on a
fixed-price basis now? Yes, we can. And we couldn't do that 18 months ago.

Important introductory FPA notes

There are several other important notes about the FPA process that need to be introduced at this time, so we're
including them here:

Measured from the user's perspective

The size of the application being measured is based on the user's view of the system. It is based on what the user
asked for, not what is delivered. It's based on the way the user interacts with the system, including the screens that the
user uses to enter input, and the reports the users receive as output. Finally, it's also based on their understanding of
the data that needs to be stored and processed by the system.
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Technology-independent

As mentioned in the objectives section, FPA is also technology-neutral. As a Certified Function Point Specialist
(CFPS) it does not matter to me what technology you are using to implement your application. It doesn't matter if it's
a Web application written in Java, PHP, ColdFusion, or .Net; or a client-server app written in Java, Delphi, VB; or
even an AS/400 RPG application. Just show me your screens and your data tables and I'll derive "number of function
points" from there.

Low cost

Adding FPA to your software development portfolio is also very easy. Historically, adding the process of counting
FPs to your development process results in a cost increase of only 1%.

Repeatable Studies

have shown that multiple function point counters can independently count the same application to within 10%
accuracy of each other. Repeatability is very important, because without it we could not begin to trust the data from
the hundreds of applications that are stored in repositories around the world.

Work well with use cases

This process works extremely well with use cases, and can even work with the concept of "stories" in Extreme
Programming.

Other useful information

Before we get into the practice of counting FPs, there are a few other background points you should also know:

Large user group

A large user group known as IFPUG ( http://www.ifpug.org ) is responsible for carrying the FP torch. IFPUG is
a non-profit, member-governed organization, consisting of over 1,200 members in 30 countries around the world.
As the time of this writing version 4.2 of the IFPUG specifications for counting FPs (referred to as the Counting
Practices Manual) has just been released.

ISO Standard

The "Unadjusted FP Count" of IFPUG v4.1 is now an ISO standard. In this paper you'll learn some of the basics of
performing an Unadjusted FP Count.

De-facto standard

In addition to being an ISO standard, FPs are used as the de facto standard for cost estimating applications like
Cocomo II, Construx Estimate, and other estimating packages.

Certified Function Point Specialist, or CFPS

A CFPS is a person who has passed the official IFPUG certification test. The CFPS designation must be renewed
every three years.

Counting Practices Manual, or CPM

The CPM is the official manual created and distributed by IFPUG . It details the official counting rules used by CFPS
practitioners. These rules help to keep counts consistent from one CFPS to another. Version 4.1 of this manual is over
300 pages in length.

FP data repositories

Because many companies have been using FP information for quite some time, there are several large repositories of
project data, where companies have combined FP counts along with other information, such as tools used, man hours,

http://www.ifpug.org
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and overall project cost. With accurate counts and other accurate data, you don't have to feel so along when making
those all-important project estimates.

A brief history

The following table shows a brief history of function points, beginning with the introduction of the concept by Alan
Albrecht in 1979.

• 1979 FPs introduced by Alan Albrecht
• 1984 First FP guidelines
• 1986 First IFPUG Board of Directors
• 1994 CPM Release 4.0
• 2003 ISO standard

The benefits of Function Point Analysis

Now that you have a little understanding of what FPA is, we can discuss the important things that they bring to your
overall software development process.

From our experience, we've found that with a small amount of experience, understanding the functional size of your
applications leads to a gold mine of other information that will help you run a successful software development
business, including:

• The ability to accurately estimate:

• project cost
• project duration
• project staffing size

• An understanding of other important metrics, such as:

• Project defect rate
• Cost per FP
• FP's per hour (what I refer to as "velocity")
• The productivity benefits of using new or different tools

As an example of what FPs can do for you, our company can now tackle projects on a fixed-price basis, whereas
in the last five years we've had only one other fixed price effort. This gives us a significant competitive advantage
against our competition, because most people think it's impossible to develop software on a fixed price basis.

Function Point Analysis Overview

In this section we'll provide a brief overview of the FP counting process, and then we'll dig more into the nitty-gritty
details of the process.

A simple five step counting process

To start at a high level, there are five steps in the process of counting FPs. They are:

• Determine the type of count.
• Identify the scope and boundary of the count.
• Determine the unadjusted FP count.
• Determine the Value Adjustment Factor.
• Calculate the Adjusted FP Count.

We'll introduce steps 1, 2, 4, and 5 during our sample count, because they are most easily introduced by using an
example. At this point we'll get into the heart of step 3 in our process, because this is where the actual FP counting
takes place. At this point FP practitioners look at a software application in terms of five standard functions.

Five standard "functions"

In counting FPs there are five standard "functions" that you count. The first two of these are called Data Functions,
and last three are called Transaction Functions. The names of these functions are listed below.
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• Data Functions:

• Internal logical files
• External interface files

• Transactional Functions:

• External Inputs
• External Outputs
• External Inquiries

Using this terminology, when a person that counts FPs looks at a software system, they see something like this:

 

 

These five functions will be discussed in greater depth in the sections that follow.

Details on the Five Data and Transactional Functions

This section provides more detailed information and definitions on the five Data and Transactional Functions. Before
getting into the details of the five functions there are several terms that you need to understand, because they'll be
used in each of the subsequent definitions. These are taken directly from the CPM.

Important terms and definitions used in describing the five functions

User identifiable

This term refers to defined requirements for processes and/or groups of data that are agreed upon, and understood by,
both the users and software developers.

Control information

This is data that influences and elementary process of the application being counted. It specifies what, when, or how
data is to be processed.
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Elementary process

An elementary process is the smallest unit of activity that is meaningful to the user. An elementary process must be
self-contained and leave the business of the application being counted in a consistent state.

Data Element Type, or DET

A data element type is a unique, user recognizable, non-repeated field. This definition applies to both analyses of data
functions and transactional functions.

Record Element Type, or RET

A record element type is a user recognizable subgroup of data elements within an Internal Logical File or External
Interface File.

Data Functions - Internal Logical Files (ILFs)

ILF stands for "Internal Logical File" . In our words, ILFs represent data that is stored and maintained within the
boundary of the application you are counting. When counting ILFs you are basically counting the data functions that
your application is being built to maintain.

The more precise IFPUG definition of an ILF is:

"An ILF is a user-identifiable group of logically related data or control information maintained within the boundary of
the application. The primary intent of an ILF is to hold data maintained through one or more elementary processes of
the application being counted."

Furthermore, for data or control information to be counted as an ILF, both of the following IFPUG counting rules
must also apply:

• The group of data or control information is logical and user identifiable.
• The group of data is maintained through an elementary process within the application boundary being counted.

Examples of ILFs Samples of things that *can* be ILFs include:

• Tables in a relational database.
• Flat files.
• Application control information, perhaps things like user preferences that are stored by the application.
• LDAP data stores.

This isn't to say that all these things are ILFs, just that they can be.

Function point counts resulting from ILFs

When you're counting ILFs you will constantly be referring to the two tables that follow. The purpose of the first
table is to help you determine whether the ILF you're currently looking at has a complexity level of Low (L), Average
(A), or High (H). You do this by going into the table knowing the number of DETs and number of RETs you have
counted in the ILF, and then finding the resulting Low, Average, or High value.

For instance, suppose I counted 5 DETs and 1 RET; that would be a Low complexity table. Conversely, if I had a
table with 21 DETs and 2 RETs, that would be an Average complexity table.

RETS Data Element Types (DETs)

1-19 20-50 51+

1 L L A

2 to 5 L A H

6 or more A H H

Now that you know whether the ILF under consideration has a complexity of Low, Average, or High, you'll come to
this next table and determine the number of FPs that should be counted for this ILF. A Low complexity ILF is worth 7
points, an Average ILF is worth 10 points, and a High is worth 15.
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Complexity Points

Low 7

Average 10

High 15

Data Functions - External Interface Files (EIFs)

EIF stands for "External Interface File" . In our words, EIFs represent the data that your application will use/
reference, but data that is not maintained by your application.

The official IFPUG definition of an EIF is:

"An external interface file (EIF) is a user identifiable group of logically related data or control information referenced
by the application, but maintained within the boundary of another application. The primary intent of an EIF is to
hold data referenced through one or more elementary processes within the boundary of the application counted. This
means an EIF counted for an application must be in an ILF in another application."

Again, think of this as data that your application needs and uses, but does not maintain.

Examples of things that can be EIFs are identical to the list for ILFs, but again, the big difference here is that EIFs are
not maintained by the application under consideration, but ILFs are.

Function point counts resulting from EIFs

Assigning an FP value to an EIF is the same as assigning one to an ILF. First, determine the number of DETs and
RETs in the EIF, then do a lookup in the following table to determine whether the EIF has a complexity of Low,
Average, or High.

Data Element Types (DETs)

RETS 1-19 20-50 51+

1 L L A

2 to 5 L A H

6 or more A H H

Then, once you know whether the EIF is considered Low, Average, or High, look in the following table for the
number of FPs to count for this particular EIF.

Value No. or Function
Points

Low 5

Average 7

High 10

You'll notice that the first two lookup tables are identical, but that more FPs are assigned to ILFs than EIFs. Here's
some homework for you: Can you guess why?

Transaction Functions - External Inputs (EI's)

EI stands for "External Input" . Here the official IFPUG definition of an EI is as follows:

An external input (EI) is an elementary process that processes data or control information that comes from outside the
application boundary. The primary intent of an EI is to maintain one or more ILFs and/or to alter the behavior of the
system.

Examples of EIs include:
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• Data entry by users.
• Data or file feeds by external applications.

Function point counts resulting from EI's

Allocating FPs to EIs is similar to the process we covered for ILFs and EIFs. However, in this case, instead of doing a
lookup based on DET's and RET's to determine a Low/Average/High complexity, the lookup is performed using DET
and FTR values. As you'll recall from the earlier definition, an FTR is a "file type referenced", so it can be either an
ILF or an EIF.

As an example, suppose that you have a process that has 5 DET's, and during the processing it references an EIF
named Users and an ILF named Process. You would go into the following table looking for the complexity of an EI
that has 5 DET's and 2 FTR's. As you'll see from the table below, this EI is considered an "Average" complexity EI.

FTR's Data Element Types (DET's)

1-4 5-15 16+

0-1 L L A

2 L A H

3 or more A H H

To carry our example forward, as you can see from the following table, an Average complexity EI is worth 4 FPs.

Complexity Points/Weight

Low 3

Average 4

High 6

Transaction Functions - External Outputs (EO's)

External Outputs are referred to as EO's. The IFPUG definition of an EO is as follows:

An external output (EO) is an elementary process that sends data or control information outside the application
boundary. The primary intent of an external output is to present information to a user through processing logic other
than, or in addition to, the retrieval of data or control information . The processing logic must contain at least one
mathematical formula or calculation, create derived data maintain one or more ILFs or alter the behavior of the
system.

EO examples include:

• Reports created by the application being counted, where the reports include derived information.

Function point counts resulting from EO's

Allocating FP's to EO's is very similar to the process for EI's. Again, you perform your lookup using DET's and
FTR's, with a resulting Low/Average/High complexity.

As an example, suppose that you have a process that you've identified as being an EO, and it has 10 DET's and
references two FTR's. You would go into the following table looking for the complexity of an EI that has 10 DET's
and 2 FTR's. As you'll see from the table below, this EO is considered an "Average" complexity EO.

FTR Data Element Types (DET)

1-5 6-19 20+

0-1 L L A

2-3 L A H
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FTR Data Element Types (DET)

4 or more A H H

To carry our example forward, using the table that follows, you'll see that an Average complexity EO has a value of 5
FPs.

Complexity Points/Weight

Low 4

Average 5

High 7

Transaction Functions - External Inquiries (EQ's)

The last transactional function is referred to as an EQ, or External Inquiry. The IFPUG definition of an EQ is as
follows:

An external inquiry (EQ) is an elementary process that sends data or control information outside the application
boundary. The primary intent of an external inquiry is to present information to a user through the retrieval of data or
control information from an ILF of EIF. The processing logic contains no mathematical formulas or calculations, and
creates no derived data. No ILF is maintained during the processing, nor is the behavior of the system altered.

Examples of EQs include:

• Reports created by the application being counted, where the report does not include any derived data.
• Other things known as "implied inquiries", which unfortunately, are a little out of scope for this paper.

Function point counts resulting from EQ's

Allocating an FP count to EQs is very similar to the process for EIs and EOs. Again, you perform your lookup using
DETs and FTRs, with a resulting Low/Average/High complexity.

As an example, suppose that you have a process that you've identified as being an EQ, and it has 20 DETs and
references 4 FTRs. You would go into the following table looking for the complexity of an EI that has 20 DETs and 4
FTRs. As you'll see from the table below, this EQ is considered a "High" complexity EQ.

FTRs Data Element Types (DETs)

1-5 6-19 20+

0-1 L L A

2-3 L A H

4 or more A H H

Carrying our EQ example forward, you'll find from the table below that a High complexity EQ is worth 6 FPs.

Complexity Points/Weight

Low 3

Average 4

High 6

Summary of Functions

Taken together, these two data functions (ILFs and EIFs) and three transactional functions (EIs, EOs, EQs) represent
the five functions that are counted in a FP count.
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A sample count

We will now explain the previously described theory using a practical example.

An introduction to our example

Okay, we've given you some background information and theory. The best thing to do now is to jump into the process
of counting a sample application.

To demonstrate how the FP process works, we're going to use a sample application that we will create. The
application is named "FPTracker", and as its name implies, it's a tool that you can use when you perform FP counts
on other applications. Of course this is an example application. We encourage you to use a major tool like "Function
Point Modeler" for your daily work. As output, it provides some convenient reports and an analysis of the data to help
keep you from making errors in your counts.

The FPTracker application consists of the following primary process areas:

• Project management, including creating, editing, and deleting projects.
• Entity management, including creating, editing, and deleting ILFs and EIFs.
• Process management, including creating, editing, and deleting EIs, EOs, and EQs.
• Process group management, which is a mechanism for grouping processes.
• Reporting, which includes several useful FP reports.

For the purposes of our example, we're only going to cover a subset of the application. In a few moments you'll learn
more about the FPTracker application by seeing the data it stores, the screens it offers, and two output reports it
provides.

The counting process

As a quick review, the five steps in the process of counting FPs are as follows:

• Determine the type of count.
• Identify the scope and boundary of the count.
• Determine the unadjusted FP count.
• Determine the Value Adjustment Factor.
• Calculate the Adjusted FP Count.

In our example we're going to follow these steps precisely.

Step 1: The type of count

The first step in our FPA process is determining the type of count for the application at hand. Function point counts
can be one of three different types:

Name Definition

Development Project FP
Count

Measures the functions provided to the users with the first installation of the software being
delivered.

Enhancement Project FP
Count

Measures the modifications to an existing application.

Application FP Count Measures the functionality provided to users in an existing application.

Because our FPTracker application already exists and is in production, the type of our count is an "Application FP
Count".

That's all we have to do for Step 1. Note that this does not have anything to do with assigning points at this time. We
are simply recording what type of project we are counting, because there are different summation rules at the end of
the count, and they vary depending on the type of count you are performing.

Step 2: Identify the scope and boundary of the count

The second step of the FPA process is identifying the scope and boundary of our count.
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The scope of this count will be defined by the data, screens, and reports that we're about to show you. You should not
make any assumptions about any behavior that may appear to be missing.

Regarding the boundary of this application, for our purposes FPTracker should be thought of as a simple, standalone
software application. Unlike a suite of applications like Microsoft Office, or a combination of applications that can be
found on an Intranet or Extranet site, the FPTracker is not tied to any other applications in any way.

It's also worth noting that the purpose of this particular count is to serve as a sample count for this paper. In the real
world the purpose of our counts vary, but typical examples include:

• Serving as the basis to determine the cost of this software application.
• Helping to determine the productivity rate of the development team on this project.
• Helping to determine the retail value of this software asset to the company.

Of course there could be any number of other reasons for pursuing a count like this, but this is a good list of the
typical reasons.

Step 3: Determine the unadjusted function point count

Although the first two steps are very important in setting the groundwork for your count, and specifying the scope of
your count, they are usually performed very quickly, and it is the third step that really takes the majority of the FPA
time, and is the heart of the count.

In this step we'll be counting the data functions and transactional functions that yield the unadjusted FP count. As
you've seen, to this point we haven't been dealing with any numbers, but we're now ready to start adding them up.

Step 3a: Determine the count resulting from ILF's

In the FPTracker application the data is stored in a series of relational database tables, so we'll use those as the basis
of our analysis. The following is a list of the database table names used in the FPTracker application:

1. Project
2. Entity
3. Process Group
4. Process
5. ProcessDETs
6. ProcessEntities

The full listing of the fields stored in each table are shown in the following tables. These tables provide each field
name, a field description, and indicator as to whether the field should be counted as a DET, and other notes/comments
regarding each field. The last row of each table provides a count of the total number of DETs in the corresponding
database table.

The "Project" database table

Field Description Count as a DET? Notes

project_id Sequential id, system-
assigned.

No This is a technical artifact. It
is not user-recognizable, and
therefore not counted.

project_name The name a user assigns to a
given project.

Yes  

project_type The type of project count. Yes  

description A description of the project. Yes  

Total DETs: 3   

The "Entity" database table
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Field Description Count as a DET? Notes

entity_id Sequential id, system-
assigned.

No System-generated sequence
number. Not user-
recognizable.

project_id Foreign key. Yes Do count a DET for pieces
of data that are required
by the user to establish a
relationship with another ILF
or EIF. Foreign keys usually
fit this definition.

name Name of the entity. Yes  

type Type of entity (ILF or EIF). Yes  

no. RETs Number of RETs in the
entity.

Yes  

no. DETs Number of DETs in the
entity.

Yes  

complexity Calculated complexity (Low,
Average, or High).

Yes  

Total DETs: 6   

The "Process" database table

Field Description Count as a DET? Notes

process_id Sequential id, system-
assigned.

No System-generated sequence
number. Not user-
recognizable.

pg_id Foreign key. Yes  

name Name of the process. Yes  

type Type of process (EI, EO, or
EQ).

Yes  

sort_order Order of appearance when
displayed.

Yes  

no. FTRs Number of FTRs. Yes  

no. DETs Number of DETs. Yes  

complexity Low, Average, or High. Yes  

description Description of the process. Yes  

Total DETs: 8   

The "Process Group" database table

Field Description Count as a DET? Notes

process group id Sequential id, system-
assigned.

No System-generated sequence
number. Not user-
recognizable.

project id Foreign key. Yes  
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Field Description Count as a DET? Notes

name Name of the process group. Yes  

Total DETs: 2   

The "ProcessDETs" database table

Field Description Count as a DET? Notes

id Sequential id, system-
assigned.

No System-generated sequence
number. Not user-
recognizable.

process_id Foreign key. Yes  

sequence Sort order, for display
purposes.

Yes  

description User-supplied description. Yes  

Total DETs: 4   

The "ProcessEntities" database table

Field Description Count as a DET? Notes

id Sequential id, system-
assigned.

No System-generated sequence
number. Not user-
recognizable.

process_id Foreign key. Yes  

entity_id Foreign key. Yes  

sequence Sort order, for display
purposes.

Yes  

Total DETs: 3   

We won't keep you guessing about these tables; the data they represent are all ILFs (and not EIFs) because they
are maintained within the boundary of the FPTracker application. That being said, you're about to see some of the
complexity of FP counting. 

In this particular application there is not a one-to-one relationship between the database tables and the way a user
would logically view this data being stored. As an FP counter, and also the primary user of this application :), we
think of the data logically being stored like this:

1. Project
2. Entity
3. Process Group
4. Process

a. ProcessDETs
b. ProcessEntities

In this case what I'm saying is that, as the user of this application, we think of the Process DETs and the Process
Entities as being logical subgroups of the overall Process data. Okay, you say, but what does that matter to me as an
FP counter? Let's look at how our counts would differ if we count the tables first as being separate, then second as
being logically merged.

First, if we think of the these six tables as separate ILFs, because of the number of DETs they contain, each table
would be considered to be a "Low" complexity table. Because each Low table is worth 7 FPs, the FP count for these
six tables would be 42 FPs (6x7=42).
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However, if we look at the tables from a "logical" perspective instead of the physical RDBMS layout, what we really
have are four logical groups. Because of their DET and RET counts, all four of the groups are considered "Low" in
complexity. So, in this case, the total count is 28 FPs (4x7=28).

Therefore, had we counted the physical implementation of the tables as opposed to a logical grouping, we would
have over-counted this portion of the application by 14 FPs, or 50%. This is a good example of where a physical
implementation differs from a correct, logical grouping for an FP count.

Total Count Due to ILFs

To tally up the FP count due to ILFs, I've identified four ILFs, with the number of RETs and number of DETs as
shown in the table below. The first three ILFs are very straightforward, and as discussed above, I believe that we have
one Process ILF with three RETs: (1) Process, (2) Process DETs, and (3) Process Entities. Using the ILF lookup table
shown earlier in Table 2, we see that each ILF is considered "Low" in complexity. Looking up Low Complexity ILFs
in Table 3, we see that a Low Complexity table is counted as seven FPs. This gives me the total of 28 FPs as a result
of ILFs. 

ILF No. RETs No. DETs Complexity Function Points

Project 1 3 Low 7

Entity 1 6 Low 7

Process Group 1 2 Low 7

Process 3 13 Low 7

Total: 28    

Step 3b: Determine the count resulting from EIF's

In this particular application there are no EIFs, so EIFs contribute zero FPs to the overall FP count.

However, in many applications there definitely are EIFs. Suppose, for example, that this application required the use
of a file named Users, and this file was maintained by another application, but was accessed by our application. In this
case the file would be counted as an EIF, using the EIF rules discussed earlier.

At this point we've finished counting data functions, and it's time to move on to transaction functions.

Step 3c: Determine the count resulting from EI's

To begin counting the transactional functions we first need to look at the user interface screens in the application.
Let's look at all of these screens first, then determine which of these are EI's, which are EO's, and finally which are
EQ's.

Screen shots from the application
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Figure 1: The "New Project" screen lets users create a new project.

 

 
Figure 2: This screen shows the Entities tab. From this location users can View, Add, Edit, and Delete entities.
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Figure 3: The "Add Entity" screen lets the user add new entities (ILFs and EIFs) to the project.

 

 
Figure 4: The "Edit Entity" screen lets the user edit entities in the project.

 

 
Figure 5: The "Delete Entity" screen asks the users to confirm their attempt to delete an entity in the application.
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Figure 6: This screen shows the Process Groups tab. From this screen users can Add, Edit, and Delete Process
Groups.

 

 
Figure 7: The "Add Process Group" screen lets the user add new process groups to the application.

 

 
Figure 8: The "Edit Process Group" lets the user assign a new name to a process group.
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Figure 9: This screen lets the user delete a selected process group.

 

 
Figure 10: This figure shows the Processes tab. From this location users can Add, Clone, Edit, and Delete processes.
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Figure 11: This screen lets the user define a new process. Note the "Description" tab.

 

 
Figure 12: This screen shows the details of the Comments/Description tab. Users can optionally enter information
here when creating a new Process.
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Figure 13: Users can use this screen to clone a Process in the application. They simply select an existing Process, then
select a Clone option that leads to this screen.

 

 
Figure 14: This screen shows a basic Unadjusted Function Point Count report.
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Figure 15: This figure shows a report provided by the application called the "ILF/EIF Report".

Now that we've seen the screens in the application we have to determine which of these correspond to EI's, which are
EO's, and which are EQ's. We'll do that in the next sections.

Brief process descriptions

Because you haven't seen this application before, it may be hard to understand the processes in this
application. Therefore, I'll provide a brief name and description of each process in this application.

Process Name Process Description

Create a Project This screen is displayed in Figure 1. This lets the user create a new project. Note that for
the purposes of this paper we are skipping other project-related processes, including the
ability to list, edit, delete, and clone projects.

Display Entity List The list is displayed in Figure 2. This is a list of every Entity that the user has identified for
the application they are counting.

Add Entity Shown in Figure 3, this dialog lets the user add a new Entity.

Edit Entity Shown in Figure 4, this dialog lets the user edit an existing Entity. This dialog appears
when the user highlights a row in the Entity List, then selects the Edit button. Alternatively,
they can double-click on the desired row.
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Process Name Process Description

Delete Entity Shown in Figure 5, this confirmation dialog is displayed when a user selects a row, then
presses the Delete button.

Display Process Group List This list is shown in Figure 6. This is a list of every Process Group the user has identified.

Add Process Group Shown in Figure 7, this dialog lets the user define a new Process Group.

Edit Process Group Shown in Figure 8, this dialog lets the user edit an existing Process Group.

Delete Process Group Shown in Figure 9, this confirmation dialog is displayed when a user selects a row in the
Process Group table, then presses the Delete button.

Display Process List The list is displayed in Figure 10. This is a list of every Process that the user has identified
for the application they are counting.

Add Process Shown in Figures 11 and 12, this dialog lets the user define a new Process.

Edit Process Although not shown, this dialog is identical to screens shown in Figures 11 and 12, other
than the title of the dialog. These screens let the user edit an existing Process.

Delete Process Although not shown, this confirmation dialog is displayed when a user selects a row, then
presses the Delete button. For the sake of our count, assume that it is a simple confirmation
dialog, similar to the dialog for deleting a Process Group.

Clone Process Shown in Figure 13, this dialog lets the user make a duplicate copy of a Process. This
makes it easy to create new processes which are very similar to an existing process.

Display UFPC Report Shown in Figure 14, this is a typical report that totals up the number of FPs in the
application you are recording. The report is displayed after the user selects the report type
from a drop-down list of reports in the Reports tab. The list of data shown in the drop-down
list is hard-coded into the application.

Display ILF/EIF Report Shown in Figure 15, this report shows the ILFs and EIFs (i.e., all the FTRs) in the
application, along with their associated number of DETs and RETs, as well as their
complexity level. It is selected from the same drop-down list as the UFPC Report.

There is a little more to this application than what is shown in these figures, but for the purposes of this paper, these
screens and descriptions define the application under consideration.

For our counting purposes, we will also assume that each data-entry screen can also result in one or more error
screens. For example, when a user is creating a new project, the system will display an error dialog if they do not
provide a project name, because this is a required field.

In the next section we'll classify each of these processes as an EI, EO, or EQ, and determine the FPs associated with
each process.

Function points resulting from EI's

The table below lists the External Inputs in the application. It also lists the number of DETs and FTRs for each
process, and the complexity that results from the number of DETs and FTRs. 

Process # DETs FTR Names # FTRs Resulting Complexity # FPs

Create Project 5 Project 1 Low 3

Add Entity 7 Project, Entity 2 Average 4

Edit Entity 7 Project, Entity 2 Average 4

Delete Entity 4 Project, Entity 2 Low 3

Add Process Group 3 Project, ProcessGroup 2 Low 3

Edit Process Group 3 Project, ProcessGroup 2 Low 3
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Process # DETs FTR Names # FTRs Resulting Complexity # FPs

Delete Process Group 4 Project, ProcessGroup 2 Low 3

Add Process 9 Project, Process,
ProcessGroup

3 High 6

Edit Process 9 Project, Process,
ProcessGroup

3 High 6

Delete Process 5 Project, Process,
ProcessGroup

3 High 6

Clone Process 3 Project, Process,
ProcessGroup

3 Average 4

    Total: 45

Step 3d: Determine the count resulting from EO's

According to the rules, we have only one EO, and that is the UFPC Report. This report is considered an EO, and
specifically not an EQ, because it contains derived data. More specifically, the complexity total column and the total
UFPC count at the bottom of the table are derived fields, and EQs specifically cannot contain derived fields like this.

This report is actually a very difficult report for me to get right, and that's exactly why I've included it here. It's
hard for me because of the rules surrounding duplicated fields in reports. Unfortunately, rather than get into all the
complexity of these rules, I'm just going to state that there are at least seven DETs in this report, and they are:

1. Title
2. Function type
3. Functional complexity
4. The complexity totals
5. The function type totals
6. The Unadjusted FP Count
7. A DET that is counted for the menu option to choose this report

Process DETs FTRs Resulting Complexity # FPs

UFPC Report 7 3 Average 5

   Total: 5

Because of the repeating fields this is a very difficult report for me. Fortunately, when we double-checked with a
colleague we both came up with an Average score for this EO, even though we differed on the fields slightly. That's
one of the nice things about using ranges like this; very rarely does a disagreement about the detailed rules actually
affect a count.

Step 3e: Determine the count resulting from EQ's

The table below lists the External Inquiries in the application. It also lists counts of the number of DETs and FTRs for
each process, and the complexity that results from the number of DETs and FTRs.

We begin with the ILF/EIF Report. Fortunately, it's a lot easier that the UFPC Report. It contains six DETs, including
the title, data function names, function type, number of RETs, number of DETs, and complexity. Looking at the
report, you can also see that it retrieves information from the Project and Entity ILFs, so there are two ILFs.

Implied Inquiries

The rest of the EQs in the table below are probably quite a surprise. We haven't introduced them yet, primarily
because they add a little complexity to the mix. Each of the last four processes in this table are referred to as "implied
inquiries". They are the almost hidden processes in an application that are easy to overlook. For instance, if you look
back at Figures 3, 7, and 11, you'll see that the application has built-in lists of Entities, Process Groups, and Processes.
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These are the tables (JTable's to be more specific) that are contain in the Entity, Process Group, and Process tabs,
respectively. Some type of query had to be performed to generate these lists, and those types of queries that result in
this "view list" operation often qualify as "implied inquiries".

The Process Group drop-down list on the Add/Edit Process dialog is another implied inquiry. It took some type of
query to generate that list, and again it is considered an implied inquiry.

While I'm covering this important topic rather quickly, it's important to note that other drop-down lists and tables
may not qualify as implied inquiries, especially when the data they contain is hard-coded in the application. You
also might not count the listing as an implied inquiry if the data could have been hard-coded. This is an introductory
tutorial, so that's all I'm going to say about this topic for now, other than the fact that we will refer you to the CPM for
more specific rules.

Process DETs FTRs Resulting Complexity # FPs

ILF/EIF Report 6 2 Average 4

Display List of Entities 5 2 Low 3

Display List of Process Groups 2 2 Low 3

Display List of Processes 7 3 Average 4

Implied Inquiry - Process Group ComboBox on
the Add/Edit Process Dialog

1 2 Low 3

   Total: 17

Now that we've finished counting the ILFs, EIFs, EIs, EOs, and EQs in the application, we add up each of the
individual counts to get a total unadjusted function point count for the application. This is shown in the table that
follows.

Function Type ComplexityMultiplier Line Item Sub-Total Section
Total

ILF 4 Low x 7 = 28  

 0 Average x 10 = 0  

 0 High x 15 = 0 28

     

EIF 0 Low x 5 = 0  

 0 Average x 7 = 0  

 0 High x 10 = 0 0

     

EI 5 Low x 3 = 15  

 3 Average x 4 = 12  

 3 High x 6 = 18 45

     

EQ 0 Low x 4 = 0  

 1 Average x 5 = 5  

 0 High x 7 = 0 5

     

EO 3 Low x 3 = 9  
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Function Type ComplexityMultiplier Line Item Sub-Total Section
Total

 2 Average x 4 = 8  

 0 High x 6 = 0 17

     

   Unadjusted Function Point
Count:

95

Step 4: Determine the Value Adjustment Factor (VAF)

In this step we'll look at something named the "Value Adjustment Factor", or VAF. But first, a warning about the
VAF.

A warning about the VAF

Before we tell you what the VAF is, let us first give you a warning about it: To the best of our knowledge, most users
don't use it.

We can't tell you much about the history of the VAF, but what we can tell from the conversations we've had with
many other users is that they don't use the VAF. This stems from at least two reasons that we can determine:

• Most users count function points to derive a number that they can plug into another piece of software to determine
a cost estimate. Those other software applications usually have their own equivalent of the VAF, and in fact,
instruct you to supply the "raw FP count". So, in this case, the VAF competes against these vendor tools.

• Some users don't feel that the GSCs are flexible enough. I tend to agree, and I think it's an easy argument. When
you look at the math below, you'll see that for two applications under consideration, if both start with the same
function point count - let's say 1,000 FPs - after adjustments the hardest application in the world would be
rated at 1,350 FPs, and the easiest possible application would be rated at 650 FPs when adjusted. Let's say the
hardest application in the world had to run on 10 different operating systems in 15 languages and be distributed
electronically to 1 million users, and the easiest would be written in Microsoft Access, run on Windows, and be
used by only one user, the author of the program. Do you really think the first application is only about twice as
hard to deliver as the second? No, I certainly don't, and this is why I don't use the VAF.

All that being said, we'll give you the quick VAF introduction so you can make a decision on your own. If nothing
else, we find it nice that someone has taken the time to come up with these 14 categories. It helps our thinking in
other areas.

VAF Introduction

Here are a few facts and definitions to get the ball rolling:

• The Value Adjustment Factor (VAF) consists of 14 "General System Characteristics", or GSCs.
• These GSCs represent characteristics of the application under consideration. Each is weighted on a scale from 0

(low) to 5 (high).
• When you sum up the values of these 14 GSCs you get a value named "Total Degree of Influence", or TDI. As

you can see from the math the TDI can vary from 0 (when all GSCs are low) to 35 (when all GSCs are high).

Before getting into the VAF formula, let us quickly list the 14 GSCs:

• Data Communication
• Distributed data processing
• Performance
• Heavily used configuration
• Transaction rate
• Online data entry
• End user efficiency
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• Online update
• Complex processing
• Reusability
• Installation ease
• Operational ease
• Multiple sites
• Facilitate change

Given this background information, you can see with the following formula:

VAF = (TDI*0.01) + 0.65

that the VAF can vary in range from 0.65 (when all GSCs are low) to 1.35 (when all GSCs are high). In the next
section you'll see that the VAF is applied directly to the FP count to determine the "Adjusted Function Point Count".

Step 5: Calculate the Adjusted Function Point Count

The final step in our five-step process is to determine the Adjusted Function Point Count. For initial application
counts such as ours, this is easily determined with the following equation:

Adjusted FP Count = Unadjusted FP Count * VAF

As you saw in the previous section, the VAF can vary from 0.65 to 1.35, so the VAF exerts an influence of +/- 35%
on the final Adjusted FP Count.

Since we're not going to come up with a value for the VAF in this paper, we also will not have a number for the
Adjusted FP Count. As you can see, however, this is very easy and straightforward.

The Value of Counting Function Points

Okay, we showed you the "how" of FP counting, but we'd like to return to the "why" of FP counting, because we
think motivation is a very important driver here. You need to asking yourself "Why should you add as much as 1% to
your overall software development effort?"

Our experience with FP counting has shown all of the benefits we mentioned earlier in this document. Once you have
a history of developing applications and you also have FP counts for all those applications, you can now add to your
software development arsenal these capabilities:

• The ability to accurately estimate:

• project cost
• project duration
• optimum project staffing size

• The ability to determine other important metrics, such as:

• Project defect rate
• Cost per FP
• FP's per hour (a productivity rate; We tend to refer to it as "Velocity", a term I like from Extreme

Programming)
• The productivity benefits of using new or different tools

So, the question to you is "What are these abilities worth to you?"

For us, the biggest benefit of FP counting means that a company can get into fixed-price software development
projects. When a prospect says "Can you do this project for $100,000?" we can run around the corner, scratch some
numbers on the back of an envelope, and give them a Yes or No answer. And while doing this we can be pretty well
assured that the company won't go bankrupt on this project.

Why is this important? Because we've never met a developer that likes to estimate programming work, and the bigger
the work, the worse is gets. we don't blame them; estimating is very hard, especially on larger projects. We've met a
lot of developers, and some always estimate low, some always estimate high, and others go both high and low. As a
manager, We'd much rather have some cold statistics that we can rely on in times like this, even if it's just as a point
of comparison.
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An example of how this works

As an example of how this works, we're going to walk through the process that we followed recently. This involves
two small phases of development on one project. On this project, the developers, project managers, users, technology,
and application all remained constant. We also followed a relatively formal process, beginning with a requirements
phase, which led into development, testing, and final delivery of a portion of an application.

A first measurement

In our case we were able to start with one project that we were already developing. The project itself was small,
but it was a distributed Java Swing application with an embedded database that runs on Windows, Mac, and Linux
platforms, so even though the application itself was small, the degree of complexity here was very high.

The first thing we did was to finish the requirements documentation and initial prototypes for our application. Once
we had this information, which included a simple, logical view of the database requirements, we were able to count
the function points for this small project. We created what we thought was a fairly detailed requirements document,
and the count at this time was 400 FPs.

Skipping a few details here, let's just say that the next thing we did was to develop this project. When we called the
development "complete", we counted the number of FPs that were actually delivered to the users. This was 440 FPs,
or a growth from the requirements stage of 11%.

At this point we also had development time information. Two developers worked on this project for a total of 540
man-hours. This comes out to be 0.815 FPs/hour (440 FPs divided by 540 man-hours). Had our customer kept a good
record of time that users spent testing the application they also could have determined a metric of "Number of testing
hours per FP", but they did not. IMHO, we think this would benefit them in the future, but in our role, application
testing is not our responsibility, so we did not pursue this.

Although we spent 540 hours on this project, the real "calendar time" for delivery of the application was 10 weeks.
This was because of several periods of down time during the development process. Therefore this project was
delivered at the rate of 44 FPs per calendar week.

Depending on how you track cost information, you can also determine "Cost per FP". As we stated earlier, as an
independent software development firm, we now develop complex applications like this for about $250/FP.

Your second measurement

Because this is an ongoing project, we basically repeated the same steps on the next phase of our project. For
summary purposes, here are the steps we followed:

• Develop the requirements, including an understanding of the necessary data stores and screens to be developed.
• Count the FPs.
• Supplied an estimate of the project cost, assuming another 11% gain in functionality (scope creep) during

development.
• Develop the code.
• Track the amount of time people spend on the project during development and testing.
• Count the FPs again.
• Deliver useful project metrics, including:

• Number of developer hours.
• Number of testing hours.
• Average number of hours per FP.
• Elapsed calendar time, which yields something like "Number of calendar days per FP" or the converse

of "Number of FPs per calendar day". This occurs when there is down time in a project, or when your
development resources are not fully dedicated to the project at hand.

• Development cost per FP.
• Testing cost per FP.
• Overall cost per FP (including other time for management, documentation, etc.).
• The ratio of Requirements time to Development time, and other similar ratios.
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Note that Step 3 in this example is "estimate the project cost". Because we have the same developers, users, and
managers working on a different part of the same project, isn't it reasonable to assume that the project velocity for
earlier phases will be the same for this new phase? For us, this is at the heart of estimating new development work
with FPs. Given this scenario of having the same developers, users, and managers, and working with the same
technology on the same application, We're glad to take our chances estimating with FPs

Now, if you suddenly change any of these factors, you can use this same information for your estimates, but you're
estimate will probably vary somewhat. For instance, with our company, we've found that we can develop web
applications much, much faster than we can develop Swing applications. Of course this is an over-simplification, but
in general a simple web application conforming to HTML 3.2 specifications is much easier for us to develop, and
hence our cost estimate and delivery times will be scaled down for this environment.

Another factor you'll be able to measure is the impact of new technology and tools on your development costs. As
we mentioned, we deliver Web applications much faster than Swing applications, so a 500 FP Web application will
be developed faster than a 500 FP Swing application. Although the size (amount) of functionality we're delivering
to the customer is equivalent, the technology that we're using to deliver the applications is different, and for us, web
applications are much less expensive.

That being said, we've found that other factors, including project managers and customers can also be a major
influence on the overall development time and cost. For instance, when it comes to customers, it's much easier to
work with a small team of customers that agree on what they want an application to deliver, versus a large committee
with different opinions. The large committee is going to take more time during the requirements process, and IMHO
is going to be subject to a larger scope creep during development.

In summary, given a little bit of time and statistics, your organization can rapidly begin applying FPs to use
these same metrics. Over time, your cost and time estimates will get much more accurate. And, as you bring new
technologies into your portfolio, you'll be able to look at these metrics and see the positive (or negative) correlation of
new technology.

Bonus

In the last section we started getting into the real usefulness of FP counting - it leads to many different metrics that
you can use to measure and improve your software development process. Assuming that you take this to heart, and
become really proficient at FP counting, let us show you a few magic formulas that people in the cost estimating and
metrics world use.

Three magic formulas

The last thing we're going to share here are three things we refer to as "magic formulas", mostly because we don't
know how the authors of these formulas arrived at them. We'll have to assume that they had some data at their
disposal, and came up with these formulas to match their data.

Project Duration

The first formula is credited to Barry Boehm. The formula states that the duration of a project is equal to 2.5 times the
cube root of the work months, or:

Project Duration = 2.5 * (Cube Root of Work Months)

where Work Months is defined as Work Months = (Project Work Effort (Hours)) / (Hours
per Month) . So, if a project is estimated to take 27 work months, then the project duration can be expected to be

Project Duration = 2.5 * (3)

or 7.5 months.

Optimum Staffing Size

The origin of this formula is currently unknown, but it goes like this: Optimum Staffing Size = Square
Root of Work Months . Here, the square root of 27 is 5.2.
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Minimum Duration

The last magic formula states that the minimum duration of a software project is:

Project Duration = 0.75 * (Cube Root of Work Months)

In our example, this yields 0.75 * 3, or 2.25 months.

Summary

How does this compare to what we've measured? In our earlier example we stated that we worked 540 man-hours
10 weeks. At 160 man-hours per month, this is 3.375 months. Applying the three magic formulas we would arrive at
these numbers:

• Minimum Duration = 0.75*1.5 = 1.12 month. We didn't make it in this short time frame, but assuming 540 total
hours of development time, we could have finished in seven weeks instead of 10. (We essentially lost three
development weeks due to other issues.)

• Project Duration = 2.5*1.5 = 3.75 months. This is 15 weeks. We took 10.
• Optimum Staffing Size = 1.84 developers. We used two developers here, and I did not want any more or less on

this effort, so this correlation seems good.

Before using any of these "magic formulas" in practice, you might try reverse-engineering them like this against your
own projects, and see if they work for you.

Function Point Analysis Summary

The concept of Function Points was invented by Alan Albrecht 25 years ago, yet they remain a mystery to most
developers today. That's unfortunate, because once you know the functional size of an application, you've opens a
new door to accurate project cost estimation and other useful metrics.

A recap of the process of Function Point Analysis shows that Function Points:

• Are measured from the user's perspective (not a developer's perspective).
• Are independent of the technology used to develop the application.
• Are low cost, adding less than a 1% overhead to your process.
• Are repeatable, as studies have shown that certified function point counters can come within 10% of each other.
• Are "use case friendly", because counting function points typically corresponds to processes defined in use cases.

Using Function Point Analysis helps you more accurately estimate:

• Project cost
• Project duration
• Optimum project staffing size

An accurate counting of function points leads to a wealth of valuable statistics that can be used to improve the
development process, including:

• Number of developer hours per FP.
• Number of total hours per FP.
• Cost per FP.
• Number of FPs per month/week/day.
• Number of bugs/defects per FP.
• Number of bug/defect hours per FP.
• Productivity increases (or decreases) due to technology changes.

These metrics, and others like them, can be used as part of the feedback loop to improve your software development
lifecycle.

For more information, visit http://www.ifpug.org  .

http://www.ifpug.org
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A walk-through example

In the following chapters we provide an insight into the power and functionality of the Function Point Modeler.

Introduction to our example

In the previous chapters we have given an overview of the Function Point Analysis. We now want to deepen this
overview with a concrete example, by demonstrating the basic capabilities of the Function Point Modeler. To keep
it simple, we use the well-known example from the previous chapters. Step by step we will show you how to use the
Function Point Modeler in dealing with Function Point Analysis. You will see, Function Point Aalysis has never been
so easy.

Measure a new Application

Let's consider again our example application. We assume that the FPTracker will be a new product we will create. For
this reason, we give you an introduction to the first approach for a new application.

Perform the counting process

The following sections will guide you step by step through the procedure for the measurement of a new application.

How to determine the type of count

The first step in our FPA process is determining the type of count for the application at hand. Remember, Function
Point Counts can be one of three different types:

Name Definition

Development Project FP
Count

Measures the functions provided to the users with the first installation of the software being
delivered.

Enhancement Project FP
Count

Measures the modifications to an existing application.

Application FP Count Measures the functionality provided to users in an existing application.

Because we assume our FPTracker application will be a new product, the type of our count is a "Development Project
FP Count".

Create a Development Project

Perform this task before creating a  Development Project Count

1. From the main menu bar, select   File >New > Functionpoint Project
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2. The following wizard dialog will be showed.

• Enter the project name NewDevelopmentProject
• And click the button Next
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3. The following wizard dialog will be showed.
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• Select the IT-Development Project
• Enter the Internal Project Id as MyInternalProjectID
• Select the begin and end date
• Enter the customer, contractor and manager names
• Select the project state In the planing
• Select the type Application Project
• And click the button Finish

Create a Development Project Count

Perform the task  Create a Development Project  before creating this task.

1. From the main menu bar, select   File >New > Functionpoint Project
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2. The following wizard dialog will be showed.

• Click the button Browse... and select the NewDevelopmentProject
• Enter the count name DevelopmentProjectCount
• Select the type Development project count
• Select the phase Inception
• And click the button Finish
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Identify the scope and boundary of the count

Once you have created  Development Project Count  the Function Point Modeler Diagram Editor will be
launched.
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Before we go further with the count, we have to know the scope and boundary of the count. Function Point Modeler
distinguish between Application System and Sub System

Name Definition

Application System The Application System indicates the software being measured. An Application System
includes one ore more Sub System You can add to an Application Count only one
Application System . But Development Project Count or Enhancement Project
Count may contain more than an Application System . It is recommended is general one
Application System per Function Point Count

Sub System Sub System are a type of stereotyped component that represent independent, behavioral
units in a system. Sub System are used to represent large-scale components in the system
that you are modeling. You can model an entire Application System as a hierarchy of Sub
System .

Create an Application System

You can use Function Point Modeler to create an  Application System  to visually system boundary defined by
IFPUG-CPM .
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You must have a Function Point Modeler diagram open. By default, the Palette view opens when you are editing
Function Point Modeler Diagram file in Function Point Modeler. The Palette provides quick access to Function point
Modeler toolkit.

To create an Application System :

1. Click FPM Notes drawer in the Palette view. The drawer expands and displays a list of following items:

• Application System
• Sub System
• Transactional Function
• Data Function

You can drag and drop it onto the Function Point Modeler Diagram Editor.
2. Drag an Application System item from a drawer to the desired place ( an empty space inside the Function Point

Modeler diagram editor). You can also click a location on the page, and then click on an item in the drawer. Make
sure that you drag and drop appropriate items onto a diagram. For example, you can not drop Sub System item
onto the diagram first without an Application System .

3. A new Application System is created and displayed in the diagram with the name Application system
4. Once the Application System appears on the diagram, you can usually set some attributes for it in the Properties

view or you can click the attribute of the Application System to set its value. Type a desired name for the
Application System and press Enter.
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5. Enter the name City Library Application and press Enter.

 

 

Create a Sub System

You can use Function Point Modeler to create an  Sub System  to decompose a large Application System in to Sub
System . This structure of Sub System could be a business driven decomposition or technical decomposition.

E.g. grouping of the report functionalities in a sub system with the name Report other functionalities in a other sub
system with the name Order . Technical decomposition would be e.g. a sub system of an application system with the
name J2EE other sub system of the same application system could be Cobol

You must have a Function Point Modeler diagram open. By default, the Palette view opens when you are editing
Function Point Modeler Diagram file in Function Point Modeler. The Palette provides quick access to Function point
Modeler toolkit.

To create a Sub System :

1. Click FPM Notes drawer in the Palette view. The drawer expands and displays a list of following items:

• Application System
• Sub System
• Transactional Function
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• Data Function

You can drag and drop it onto the Function Point Modeler Diagram Editor.
2. Drag an Sub System item from a drawer to the desired place inside of the Application System . You can also

click a location on the page, and then click on an item in the drawer. Make sure that you drag and drop appropriate
items onto a diagram. For example, you can not drop Sub System item onto outside of the Application System .

3. A new Sub System is created and displayed in the diagram with the name Sub system
4. Once the Sub System appears on the diagram inside of the Application System , you can usually set some

attributes for it in the Properties view or you can click the attribute of the Sub System to set its value. Type a
desired name for the Application System and press Enter.

 

 
5. Enter the name Booking Manager and press Enter.
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Determine the unadjusted FP count

Once you have created a  Transactional Function  or  Data Functions  Function point Modeler calculates the
unadjusted function points.

Create Transactional Functions

Once you have created the Sub System a Transactional Function and a Data Function can be created.

You must have a Function Point Modeler diagram open. By default, the Palette view opens when you are editing
Function Point Modeler Diagram file in Function Point Modeler.

To create a Transactional Function :

1. Click FPM Notes drawer in the Palette view. The drawer expands and displays a list of following items:

• Application System
• Sub System
• Transactional Function
• Data Function

You can drag and drop it onto the Function Point Modeler Diagram Editor.
2. Drag an Transactional Function  item from a drawer to the desired place inside of the Transactional Functions

section the Sub System . You can also click a location Transactional Functions section, and then click on an
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item in the drawer. Make sure that you drag and drop appropriate items Transactional Functions section. For
example, you can not drop Transactional Function  item onto Data Functions section of Sub System .

3. A new Transactional Function is created and displayed in the diagram with the name Transactional Function1
4. Once the Transactional Function appears on the diagram inside of the Sub System , you can usually set some

attributes for it in the Properties view or you can click the attribute of the Transactional Function to set its value.
Type a desired name for the Transactional Function and press Enter.

 

 
5. Enter the name createBook and press Enter.
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6. Add a second Transactional Function as described above, enter the name deleteBook and press Enter.
7. Add a third Transactional Function as described above, enter the name showBook and press Enter.
8. Move mouse over the showBook Transactional Function and the text will be highlighted. Double click on this

highlighted text. The following property dialog will be showed.

Change the Function Typ of showBook as EQ and click the button Ok .
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9. Add a fourth Transactional Function as described above, enter the name migrateBook and press Enter.
10. Move mouse over the migrateBook Transactional Function and the text will be highlighted. Double click on

this highlighted text. The following property dialog will be showed.

Change the Process Typ of migrateBook as Conversion and click the button Ok .
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11. All added Transactional Functions are showed in the following picture.

 



 | Function Point Modeler Workbench | 48

 

Create Data Functions

Once you have created the Sub System a Transactional Function and a Data Function can be created.

You must have a Function Point Modeler diagram open. By default, the Palette view opens when you are editing
Function Point Modeler Diagram file in Function Point Modeler.

To create a Data Function :

1. Click FPM Notes drawer in the Palette view. The drawer expands and displays a list of following items:

• Application System
• Sub System
• Transactional Function
• Data Function

You can drag and drop it onto the Function Point Modeler Diagram Editor.
2. Drag a Data Function  item from a drawer to the desired place inside of the Data Functions section the Sub

System . You can also click a location Data Functions section, and then click on an item in the drawer. Make
sure that you drag and drop appropriate items Data Functions section. For example, you can not drop Data
Function  item onto Transactional Functions section of Sub System .

3. A new Data Function is created and displayed in the diagram with the name Data Function1
4. Once the Data Function appears on the diagram inside of the Sub System , you can usually set some attributes

for it in the Properties view or you can click the attribute of the Data Function to set its value. Type a desired
name for the Data Function and press Enter.
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5. Enter the name Book and press Enter.
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Creating connection between transactional function and data function

You must have a Function Point Modeler diagram open. By default, the Palette view opens when you are editing
Function Point Modeler Diagram file in Function Point Modeler.

To create connection between Transactional Function and Data Function :

1. In the diagram editor, in the Palette, click a FPM Connections.
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2. Click on the Transactional Function -> Data Function .
3. Move the mouse to target a Data Function in the diagram
4. Release the mouse button.
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Determine the Value Adjustment Factor

Once you have created an Application System the default Value Adjustment Factor (VAF) for the Application
System is set 1.0.

You may change the (VAF) as following:

1. By moving the mouse over an Application System the color of the attribute Value Adjustment Factor becomes
blue .

 

 
2. Double click on the Value Adjustment Factor of the Application System
3. The following General System Characteristics (GSC) dialog will be showed in the Workbench.
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4. Select the Data Communications tab. and select the last options Application is more than a front-end, and

support more than one type of TP communication protocol
5. The (GSC) has been changed and is now 0.7
6. Click the button Ok .

Calculate the Adjusted FP Count

Once you have adjusted the default Value Adjustment Factor (VAF) the new adjusted function points will be
calculated.
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Calculate Estimation

Once you have created a ProjectPlanData you can calculate ProjectEstimation. See more  Plandata and
Estimation Overview

Review the Project Data

Project data called ProjectPlanData includes all project relevant information. You can create more than one
ProjectPlanData for a Project . Each of this ProjectPlanData represents a project plan scenario for the current
project.

For example one of the project plan scenario would be for the Rational Unified Process  (RUP) and other for 
waterfall or for the software development process specified for your company. A ProjectPlanData can include one
or more ProjectEstimation . Each ProjectEstimation of this estimations represents an estimation scenario for the
project. For example one of the ProjectEstimation may be with an expert team and other with a mixed team. One
of this ProjectEstimation has to be set as default for the project. It means, that the default ProjectEstimation is the
valid estimation for the project.

Introduction to Project Plandata

In the following section you will see how to create ProjectPlanData and we will also show you how to add Count
and ProjectEstimation .

Create a new Project Plandata

You can add a ProjectPlanData as following.:

1. Open Project Editor
2. Click on Create a new Project Plandata
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3. The following object structure will have been created.

 

 
4. Select Rational Unified Process from the Development process combobox.
5. Enter the name MyProjectPlandaForRUP and save the ProjectPlanData .
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Add a Count to the Plandata

You can add a Count to a ProjectPlanData as following.:

1. Select the Counts in the tree.
2. Click on the button Add a new element

 



 | Function Point Modeler Workbench | 57

 
3. Select the counts from the following dialog.

 

 
4. The selected count will be added to the ProjectPlanData and save the ProjectPlanData
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Create a new Project Estimation

You can add a ProjectEstimation to a ProjectPlanData as following.:

1. Select the Project estimations in the tree.
2. Click on the button Add a new element

 

 
3. Enter the name Estimation_I and save the ProjectPlanData

 

 

Calculate COCOMO effort

1. Select the project and click the menu Project > Open project data editor> .
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2. The projectdata editor will be showed.

 

 
3. Click on the COCOMO tab. It will show the Cocomo editor of the project editor.
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4. Select the default sub estimation. Click on the tab Info in the Setting section . Change the name as

SubEstimation .

 

 
5. Select the SubEstimation and select the count Booking Manager .
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6. Set the complexity of some cost factors .

 

 
7. The estimation for this count will be calculated.
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8. Select the base estimation Estimation_I

 

 
9. Set the complexity of some scale factors .
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Calculate the Baseline

We will now create an Application Count from the previously Development Project Count as following.

Determine the type of count

The type of count is an Application Count .

Create a Application Project

1. From the main menu bar, select   File >New > Functionpoint Project
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2. The following wizard dialog will be showed.

• Enter the project name ApplicationCount
• And click the button Next
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3. The following wizard dialog will be showed.
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• Select the Application Project
• And click the button Finish

Create a Application Count

1. From the main menu bar, select   File >New > Functionpoint Project
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2. The following wizard dialog will be showed.
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• Click the button Browse... and select the City Library Application

 

 
• Enter the count name CityLibraryApplication
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• And click the button Finish

A new Application Count will be created from Development Project Count . The migrateBook will be deleted
from the Application Count because its Process Type conversion.
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Add, change and delete functionaliy

The next step is to add, change and delete the functionalities of the application system City Library Application .

The counting process

We will follow the counting process:

Determine the type of count

The type of count is an Enhancement Project Count .

Create a Enhancement Project

1. From the main menu bar, select   File >New > Functionpoint Project
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2. The following wizard dialog will be showed.

• Enter the project name EnhancementProjectCount
• And click the button Next
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3. The following wizard dialog will be showed.
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4. The following wizard dialog will be showed. Set the value of the fields.
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And click the button Finish

Create a enhancement count

1. From the main menu bar, select   File >New > Functionpoint Project
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2. The following wizard dialog will be showed. Enter EnhancementProjectCount as name.
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• Click the button Browse... and select the City Library Application

 

 
• And click the button Finish

A new Enhancement Project Count will be created from Application Count . The Enhancement Type of all
elementary process and data function will be set NOT CHANGED . It means, that they have null function points.
If you change Enhancement Type as CHANGED or DELETED , the function points will be calculated for the
current elementary process or data function. You can also add new elementary process or data function in the
current Enhancement Project Count .
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Determine the unadjusted FP count

Once you have created a  Transactional Function  or  Data Functions  Function point Modeler calculates the
unadjusted function points.

Add, change and delete Transactional Functions

Once you have created the Sub System a Transactional Function and a Data Function can be created.

You must have a Function Point Modeler diagram open. By default, the Palette view opens when you are editing
Function Point Modeler Diagram file in Function Point Modeler.

To create a Transactional Function :

1. Click FPM Notes drawer in the Palette view. The drawer expands and displays a list of following items:

• Application System
• Sub System
• Transactional Function
• Data Function

You can drag and drop it onto the Function Point Modeler Diagram Editor.
2. Drag an Transactional Function  item from a drawer to the desired place inside of the Transactional Functions

section the Sub System . You can also click a location Transactional Functions section, and then click on an
item in the drawer. Make sure that you drag and drop appropriate items Transactional Functions section. For
example, you can not drop Transactional Function  item onto Data Functions section of Sub System .

3. A new Transactional Function is created and displayed in the diagram with the name Transactional Function1
4. Once the Transactional Function appears on the diagram inside of the Sub System , you can usually set some

attributes for it in the Properties view or you can click the attribute of the Transactional Function to set its value.
Type a desired name for the Transactional Function and press Enter.
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5. Enter the name changeBook and press Enter.
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6. Move mouse over the showBook Transactional Function and the text will be highlighted. Double click on this

highlighted text. The following property dialog will be showed.

Double click the Transactional Function showBook , and change enter the name Enhancement Type Deleted .
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7. Click the button Ok .
8. Move mouse over the deleteBook Transactional Function and the text will be highlighted. Double click on this

highlighted text. The following property dialog will be showed.

Double click the Transactional Function deleteBook , and change enter the name Enhancement Type Changed
.

9. Your Enhancement Project Count will look like as following,
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Add, change and delete Data Functions

Once you have created the Sub System a Transactional Function and a Data Function can be created.

You must have a Function Point Modeler diagram open. By default, the Palette view opens when you are editing
Function Point Modeler Diagram file in Function Point Modeler.

To create a Data Function :

1. Click FPM Notes drawer in the Palette view. The drawer expands and displays a list of following items:

• Application System
• Sub System
• Transactional Function
• Data Function

You can drag and drop it onto the Function Point Modeler Diagram Editor.
2. Drag a Data Function  item from a drawer to the desired place inside of the Data Functions section the Sub

System . You can also click a location Data Functions section, and then click on an item in the drawer. Make
sure that you drag and drop appropriate items Data Functions section. For example, you can not drop Data
Function  item onto Transactional Functions section of Sub System .

3. A new Data Function is created and displayed in the diagram with the name Data Function1
4. Once the Data Function appears on the diagram inside of the Sub System , you can usually set some attributes

for it in the Properties view or you can click the attribute of the Data Function to set its value. Type a desired
name for the Data Function and press Enter.
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5. Enter the name Customer and press Enter.
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Calculate Estimation

You can add a ProjectPlanData as following.:

1. Select the project EnhancementProjectCount and open Project Editor for the current selected project.
2. Click on Create a new Project Plandata

 

 
3. The following object structure will have been created.
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4. Select Waterfall from the Development process combobox.
5. Enter the name MyProjectPlandaForWaterfall and save the ProjectPlanData .

 

 
6. Select the Counts in the tree.
7. Click on the button Add a new element

 

 
8. Select the counts from the following dialog.
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9. The selected count will be added to the ProjectPlanData and save the ProjectPlanData

 

 
10. Select the Project estimations in the tree.
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11. Click on the button Add a new element

 

 
12. Enter the name Estimation_II and save the ProjectPlanData

 

 
13. Click on the COCOMO tab. It will show the Cocomo editor of the project editor.
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14. Select the default sub estimation. Click on the tab Info in the Setting section . Change the name as

SubEstimation .

 

 
15. Select the SubEstimation and select the count Booking Manager .

 



 | Function Point Modeler Workbench | 88

 
16. Set the complexity of some cost factors .

 

 
17. The estimation for this count will be calculated.
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Re-Calculate the Baseline

We will now create an Application Count from the previously Enhancement Project Count as following.

Update an existing Application Count

Once you have created an Enhancement Project Count you have to update the Application Count for the current
application.

1. From the main menu bar, select   File >New > Functionpoint Project

 

 
2. The following wizard dialog will be showed.
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• Click the button Browse... and select the City Library Application with Enhancement Project Count
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• The following dialog will be showed.

 

 
• And click the button Finish

The Application Count will be updated from Enhancement Project Count . The showBook will be deleted
from the Application Count because its Enhancement Type is set as DELTED in the Enhancement Project
Count .

The transactional function changeBook and data function Customer will be added to the Application Count

The new updated Application Count looks like as following
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Create a project actual data

Once you have completed your project you can begin to gather  Project Actual Data .

1. Select the Project actual datas in the tree. You will see the following dialog. This is the default level without any
detail of the used software development process phases. Project Actual Data without detail means, that you can
gather project actual data for whole project without phases of of the used software development process.
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2. If you click on the check box Detailed Actual Data in the editor. You will see in this case a detailed structure of

the used software development process with its phase. Project Actual Data with detail means, that you can gather
project actual data for each phases of the used software development process.

If you click on the check box Detailed Actual Data of a phase in the editor. You can also specify, whether you
want to specify for each activity of any phase. In this case you can gather project actual data for each activity of
each phases of of the used software development process.
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Add a project interruption

You can add a Project Interruption as following.:

1. Click on Project interruptions and click on the button Add a new element
2. Enter the name as Because of holiday
3. Set the Start date and End date of the current Project Interruption
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Add an unestimated project effort

You can add an Unestimated Project Effort as following.:

1. Click on Unestimated efforts and click on the button Add a new element
2. Select the Training from the combo box.
3. Set the Effort of this Unestimated Project Effort as 48 hours.
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Detailed actual data with phases

Once you have completed your project you can begin to gather  Project Actual Data .

1. If you click on the check box Detailed Actual Data of any phase in the editor. You will see in this case a detailed
structure of the used software development process with its phase and activities. Project Actual Data with detail
means, that you can gather project actual data for each activity of any phases.

If you click on the check box Detailed Actual Data of a phase in the editor. You can also specify, whether you
want to specify for each activity of any phase. In this case you can gather project actual data for each activity of
each phases of of the used software development process.
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Add defect

You can add a Defect as following.:

1. Click on Defects of any Phase and click on the button Add a new element
2. Enter the name as Database connection defect
3. Select the Type as Critical Defect
4. Select the Identify Phase as Programming
5. Select the Fixed as true
6. Select the Fixed Phase as Integration Test
7. Enter the Removal effort Phase as 16
8. Enter the Description as Database connection defect...
9. Save the project
10.  
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Detailed actual data with activities

Once you have completed your project you can begin to gather  Project Actual Data .

1. If you click on the check box Detailed Actual Data of any phase in the editor. You will see in this case a detailed
structure of the used software development process with its phase and activities. Project Actual Data with detail
means, that you can gather project actual data for each activity of any phases.

If you click on the check box Detailed Actual Data of a phase in the editor. You can also specify, whether you
want to specify for each activity of any phase. In this case you can gather project actual data for each activity of
each phases of of the used software development process.
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2. Click the activity Requirement Analysis of phase Plan and Requirements

Enter Effort as 100 and Max Team Number as 4
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3. Click the activity Product Design of phase Plan and Requirements

Enter Effort as 80 and Max Team Number as 3

 

 
4. Click the activity Programming of phase Plan and Requirements

Enter Effort as 60 and Max Team Number as 2
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5. Click the activity Test Planning of phase Plan and Requirements

Enter Effort as 30 and Max Team Number as 1

 

 
6. Click the activity Verification and Validation of phase Plan and Requirements

Enter Effort as 20 and Max Team Number as 1
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7. Click the activity Project Office of phase Plan and Requirements

Enter Effort as 20 and Max Team Number as 1
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8. Click the activity CM / QA of phase Plan and Requirements

Enter Effort as 0 and Max Team Number as 0
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9. Click the activity Manuals of phase Plan and Requirements

Enter Effort as 0 and Max Team Number as 0
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10. Click the phase Plan and Requirements . You will see Effort as 240 and Max Team Number as 4 for the phase

Plan and Requirements calculated from the sum of the activities.
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Visualize the Application Lifecycle

The Software Life Cycle Management System of Function Point Modeler is described in the following section.

Introduction to Lifecycle

Function Point Modeler provides you a Software Life Cycle Management System . This key feature of Function
Point Modeler enables you to track the functional evolution of an application system from the begin.

A application system is born with a Development Project Count . If you have completed your development project,
you have to create a new Application Count for this current application system. All Process Type of Conversion
will be deleted in the new Application Count . The new Application Count will include only the real user functions
from the previously Development Project Count .

You create a Enhancement Project Count from the Application Count of your application system. In this case all
Enhancement Type of the transactional functions and data funtions will be set as Not Changed . If some of them
has to change during enhancement project, you have to set Enhancement Type as Changed . You can also add new
transactional functions and data functions to your Enhancement Project Count .

If you have completed your Enhancement Project Count you have to update the Application Count of your
application system from the latest Enhancement Project Count , so that the Application Count of your application
system has current user functions. This is repeatable till to the end of the application system life. It is called Software
Life Cycle Management System .

 

 

Specify selection criterias

The Software Life Cycle Management System enables you to look at each application system and the counts o this
application system.

Select a Application System

Perspectives provide combinations of views and editors that are suited to performing a particular set of tasks.

To open the LifeCycle Perspective perspective:
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1.
Click the Open Perspective button  on the shortcut bar on the left side of the Workbench window. (This
provides the same function as the Window > Open Perspective menu on the menu bar.)

2. Select the perspective LifeCycle Perspective .
3. When the perspective opens, the title bar of the window it is in changes to display the name of the perspective. In

addition, an icon is added to the shortcut bar, allowing you to quickly switch back to that perspective from other
perspectives in the same window.

 

 
4. Select the City Library Application in the view
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5. You will see all counts for the current selected application system City Library Application .

 

 

Select a Count

Perspectives provide combinations of views and editors that are suited to performing a particular set of tasks.

To open the LifeCycle Perspective perspective:
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1.
Click the Open Perspective button  on the shortcut bar on the left side of the Workbench window. (This
provides the same function as the Window > Open Perspective menu on the menu bar.)

2. Select the perspective LifeCycle Perspective .
3. When the perspective opens, the title bar of the window it is in changes to display the name of the perspective. In

addition, an icon is added to the shortcut bar, allowing you to quickly switch back to that perspective from other
perspectives in the same window.

 

 
4. Select the City Library Application in the view
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5. Select the EnhancementProjectCount in the view

 

 
6. You will see all detail metrics of the current selected count EnhancementProjectCount .
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Understand the differnt views

To open the LifeCycle Perspective perspective:

1.
Click the Open Perspective button  on the shortcut bar on the left side of the Workbench window. (This
provides the same function as the Window > Open Perspective menu on the menu bar.)

2. Select the perspective LifeCycle Perspective .
3. When the perspective opens, the title bar of the window it is in changes to display the name of the perspective. In

addition, an icon is added to the shortcut bar, allowing you to quickly switch back to that perspective from other
perspectives in the same window.
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4. The System view shows all application system in your workspace.

 

 
5. The Counts view shows all metrics relevant for the current selected count.
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6. The Counts view shows all metrics relevant for the current selected count.
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7. The System Lifecycle view shows the development of functions of the current selected application system.

 

 
8. The System Lifecycle view shows the development of functions of the current selected application system.

 

 
9. The Function Type view shows the distribution of functions of the current selected count.
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10. The Enhancement Type view shows the distribution of enhancement type of the current selected count.

 

 

Standard Reporting

Function Point Modeler provides you a some Standard Reporting function for counts and estimations for different
format e.g PDF, Excel, etc.

Reporting for Counts

You can create with Function Point Modeler the following reports for a count.
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Count Overview

To create a Count Overview :

1. Click on the right mouse Create reports > Count Overview
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2. Enter Target file as C:\CountOverview.pdf .
3. Press the button Ok .
4. The following Count Overview report will be created
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Count Structure

To create a Count Structure :

1. Click on the right mouse Create reports > Count Structure
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2. Enter Target file as C:\CountStructure.pdf .
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3. Press the button Ok .
4. The following Count Structure report will be created

 

 

Release Value Adjustment Factor

To create a Release Value Adjustment Factor :

1. Click on the right mouse Create reports > Count Structure

 



 | Function Point Modeler Workbench | 121

 
2. Enter Target file as C:\vaf.pdf .
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3. Press the button Ok .
4. The following Release Value Adjustment Factor report will be created

 

 

Reporting for Estimations

You can create with Function Point Modeler the following reports for a an estimation.
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Estimation Overview

To create a Estimation Overview :

1. Click on the PDF icon.

 

 
2. Enter Target file as C:\estimation_overview.pdf .

 

 
3. Press the button Ok .
4. The following Estimation Overview report will be created
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Concepts

Function Points Analysis

The following sections will introduce the basic concepts of Function Point Analysis and introduce and reinforce unit
cost estimating.

Introduction

Systems continue to grow in size and complexity, becoming increasingly difficult to understand. As improvements
in coding tools allow software developers to produce larger amounts of software to meet ever-expanding user
requirements, a method to understand and communicate size must be used. A structured technique of problem
solving, function point analysis is a method to break systems into smaller components, so they can be better
understood and analyzed. This book describes function point analysis and industry trends using function points.

Human beings solve problems by breaking them into smaller, understandable pieces. Problems that may initially
appear to be difficult are found to be simple when dissected into their components, or classes. When the objects to
be classified are the contents of software systems, a set of definitions and rules, or a scheme of classification, must
be used to place these objects into their appropriate categories. Function point analysis is one such technique: FPA is
a method to break systems into smaller components, so they can be better understood and analyzed. It also provides
a structured technique for problem solving. Function Point Analysis is a structured method to perform functional
decomposition of a software application.

Function points are a unit measure for software much like an hour is to measuring time, miles are to measuring
distance or Celsius is to measuring temperature. Function Points are interval measures much like other measures such
as kilometers, Fahrenheit, hours, so on and so forth.

Function Points measure software by quantifying its functionality provided to the user based primarily on the logical
design. Frequently the term end user or user is used without specifying what is meant. In this case, the user is a
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sophisticated user. Someone that would understand the system from a functional perspective --- more than likely
someone that would provide requirements or does acceptance testing.

There are a variety of different methods used to count function point, but this book is based upon those rules
developed by the Alan Albrecht and later revised by the International Function Point User Group ( IFPUG ). The
IFPUG rules have much to be desired, so this book attempts to fill in gaps not defined by IFPUG .

What is on the surface?

Remember a tip of an iceberg. The real issue is not the tip, but what is under the surface of the water and can not be
seen. The same is true when you design a software application.

One of the largest misconceptions of function points is understanding what functionality is being exposed to an
end user versus the delivered functionality. One trend happening in software development today is self service
applications like most major airlines are using.

If you visit American Airlines Website and/or Expedia, you will see a relatively simple screen exposed to the end
user. The end user simply puts in their departure and destinations and the dates of travel. This appears on the surface
to be a simple inquiry, but this is extremely complex. The process actually includes 1,000’s of elementary processes,
but the end user is only exposed to a very simple process. All possible routes are calculated, city names are converted
to their international three characters, interfaces are sent to all the airline carriers (each one being unique), this is an
extremely complex and robust process! When we size software applications we want to understand what is exposed
and what is under the surface.

Elementary Process:

A software application is in essence a defined set of elementary processes. When these elementary processes are
combined they interact to form what we call a software system or software application. An elementary process is not
totally independent existing alone, but the elementary processes are woven together becoming interdependent. There
are two basic types of elementary processes (data in motion and data at rest) in a software application. Data in motion
has the characteristic of moving data inside to outside the application boundary or outside to inside the application
boundary. An elementary process is similar to an acceptance test case.

Definition

On a conceptual level, function point analysis helps define two abstract levels of data - data at rest and data in motion.

Data in motion

Data in motion is handled via transactional function types or simple transactions. All software applications will have
numerous elementary processes or independent processes to move data. Transactions (or elementary processes) that
bring data from outside the application domain (or application boundary) to inside that application boundary are
referred to as external inputs.

Transactions (or elementary processes) that take data from a resting position (normally on a file) to outside the
application domain (or application boundary) are referred as either an external outputs or external inquiries (these will
be defined later in this book).

Data at rest

Data at rest that is maintained by the application in question is classified as internal logical files. Data at rest that is
maintained by another application in question is classified as external interface files.

Benefits and Uses

A function point count has many uses.

• Function Points can be used to communicate more effectively with business user groups.
• Function Points can be used to reduce overtime.
• Function points can be used to establish an inventory of all transactions and files of a current project or

application. This inventory can be used as a means of financial evaluation of an application. If an inventory is
conducted for a development project or enhancement project, then this same inventory could be used to help
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maintain scope creep and to help control project growth. Even more important this inventory helps understand the
magnitude of the problem

• Function Points can be used to size software applications. Sizing is an important component in determining
productivity (outputs/inputs), predicting effort, understanding unit cost, so on and so forth.

• Unlike some other software metrics, different people can count function points at different times, to obtain the
same measure within a reasonable margin of error. That is, the same conclusion will be drawn from the results.

• FPA can help organizations understand the unit cost of a software application or project. Once unit cost is
understood tools, languages, platforms can be compared quantitatively instead of subjectively. This type
of analysis is much easier to understand than technical information. That is, a non-technical user can easily
understand Function Points.

There are several other uses of function points. The following list are some practical applications of Function Points
and FPA.

• Defining When and What to Re-Engineer
• Estimating Test Cases
• Understanding Wide Productivity Ranges
• Understanding Scope Creep
• Calculating the True Cost of Software
• Estimating Overall Project Costs, Schedule and Effort
• Understanding Maintenance Costs
• Help with contract negotiations
• Understanding the appropriate set of metrics

When Not to Use Function Points

Function points are not a very good measure when sizing maintenance efforts (fixing problems) or when trying to
understand performance issues. Much of the effort associated with fixing problems (production fixes) is due to trying
to resolve and understand the problem (detective work). Another inherent problem with measuring maintenance work
is that much of maintenance programming is done by one or two individuals. Individual skill sets become a major
factor when measuring this type of work. The productivity of individual maintenance programmers can vary as much
as 1,000 percent.

Performance tuning may or may not have anything to do with functionality. Performance tuning is more a result of
trying to understand application throughput and processing time. There are better metrics to utilize when measuring
this type of work.

Types of Function Point Counts

Function point counts can be associated with either projects or applications. There are three major types of software
projects (Development, Enhancements and Maintenance). In accordance with these types of function points there are
three different types of function point counts (Development, Enhancement and Application).

Development Project Function Point Count

Function Points can be counted at all phases of a development project from requirements up to and including
implementation. This type of count is associated with new development work. Scope creep can be tracked and
monitored by understanding the functional size at all phase of a project. Frequently, this type of count is called a
baseline function point count.

Enhancement Project Function Point Count

It is common to enhance software after it has been placed into production. This type of function point count tries
to size enhancement projects. All production applications evolve over time. By tracking enhancement size and
associated costs a historical database for your organization can be built. Additionally, it is important to understand
how a development project has changed over time.
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Application Function Point Count

Application counts are done on existing production applications. This “baseline count” can be used with overall
application metrics like total maintenance hours. This metric can be used to track maintenance hours per function
point. This is an example of a normalized metric. It is not enough to examine only maintenance, but one must
examine the ratio of maintenance hours to size of the application to get a true picture.

Additionally, application counts can assist organizations in understanding the size of the entire corporate portfolio (or
inventory). This type of count is analogous to taking an inventory for a store. Like inventory, a dollar value can be
associated with any application function point count and for the entire organization portfolio.

What about Lines of Code (LOC)

There are several problems with using LOC as a unit of measure for software. Imagine two applications that provide
the same exact functionality (screens, reports, databases). One of the applications is written in C++ and the other
application written a language like Clarion (a very visual language). The number of function points would be exactly
the same, but aspects of the application would be different. The lines of code needed to develop the application would
not be the same. The amount of effort required to develop the application would be different (hours per function
point). We are able to compare the productivity of the languages. Unlike Lines of Code, the number of function points
will remain constant (should remain constant).

With this in mind:

• The number of lines of code delivered is dependent upon the skill level of the programmer. In fact, the higher skill
level of the programmer the fewer lines of code they will develop to perform the same function.

• Higher-level languages such as Delphi, Progress 4GL, Forte, Dynasty, VB, Java Script, or other visual languages
require far fewer lines of code than Assembler, COBOL, or C to perform the same functionality. That is, there is
an inverse relationship between level of language and work output (when work output is LOC).

• The actual number of LOC is not known until the project is almost completed. Therefore, LOC cannot be used
to estimate the effort or schedule of a project. Function Points can be derived from requirements and analysis
documents that are available early in a project life cycle.

• There is no agreed upon method to count lines of code. The statement and type of statements used in Visual C
++, Assembler, COBOL, SQL are completely different. It is common for applications to have a combination of
different languages being utilized.

Understanding Productivity

The standard economic definition of productivity is “Goods or services per unit of labor or expenses” until 1979,
when A.J. Albrecht of IBM published a paper about Function Points, there was no definition of what “goods or
services” were the output of software project. The good or service of software is the business functionality provided.

While software productivity is a relatively new subject “industrial productivity” has been a subject of interest for
many years. One of the first individuals to study productivity was Frederick Taylor (1856-1912). Taylor’s major
concern throughout most of his life was to increase efficiency in production. Taylor decided that the problem of
productivity was a matter of ignorance on the part of management. Taylor believed that application of scientific
methods, instead of customs and rules of thumb could yield higher productivity. A century after Frederick Taylor
most software managers use rules of thumb instead of systematic study.

Several scientists undertook the famous experiments at the Hawthorne plant of the Western Electric Company in
1927 and 1932. They began a study to determine the effect of illumination on workers and their productivity. They
found that productivity improved when illumination was either increased or decreased for a test group. They found
that when people felt they were being noticed then their productivity increased. They also found that the improvement
in productivity was due to such social factors as morale, satisfactory interrelationships and effective management.
They also found that the best managers were those that managed via counseling, leading, and communicating. The
phenomenon, arising basically from people being “noticed,” has been known as the Hawthorne effect.

Productivity

The definition of productivity is the output-input ratio within a time period with due consideration for quality.

Productivity = outputs/inputs (within a time period, quality considered)
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The formula indicates that productivity can be improved by (1) by increasing outputs with the same inputs, (2) by
decreasing inputs but maintaining the same outputs, or (3) by increasing outputs and decreasing inputs change the
ratio favorably.

Software Productivity = Function Points / Inputs

Effectiveness v. Efficiency:

Productivity implies effectiveness and efficiency in individual and organizational performance. Effectiveness is the
achievement of objectives. Efficiency is the achievement of the ends with least amount of resources.

Understanding Software Productivity

Software productivity is defined as hours/function points or function points/hours. This is the average cost to develop
software or the unit cost of software. One thing to keep in mind is the unit cost of software is not fixed with size.
What industry data shows is the unit cost of software goes up with size.

How does size impact productivity

As the size of software development project becomes larger the cost per function point actually rises. As can be seen
from the graph and data, the effort per unit does not remain constant as the size of the software project increases. This
is self-evident because the tasks are not the same for software projects as the size increases.

What is Marginal Cost?

As some of you remember Marginal Cost is an economic term and is different from average cost.

Average cost is the total cost of producing a particular quantity of output divided by that quantity. In this case to Total
Cost/Function Points.

Marginal cost is the change in total cost attributable to a one-unit change in output. In our case, how does per unit cost
change as the software project size change? How does the cost of software change as the product becomes larger and
larger?

Imagine the average cost per square foot of a one-story building compared to the cost per square foot of a 100-story
building. No doubt the construction costs (per unit cost) for the 100-story building are much higher than a one-story
building. This same concept is true for a software project.

Besides size there are several other factors, which impact the cost of construction

• Where the building is located
• Who is the general contractor?
• Who does the actual labor?

Why increasing Marginal Costs for Software Development?

There are a variety of reasons why marginal costs for software increase as size increases. The following is a list of
some of the reasons

• As size becomes larger complexity increases.
• As size becomes larger a greater number of tasks need to be completed.
• As size becomes larger there is a greater number of staff members and they become more difficult to manage.
• A the numbers of individuals in a project increases the number of communication paths increase also.

Communication in large projects can be very difficult.
• Since fixed costs for software projects is minimal. There are little if any economies of scale for software projects.

Function Points are the output of the software development process. Function points are the unit of software. It is
very important to understand that Function Points remain constant regardless who develops the software or what
language the software is develop in. Unit costs need to be examined very closely. To calculate average unit cost all
items (units) are combined and divided by the total cost. On the other hand, to estimate the total cost each item is
examined.
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For example, assume you are going to manufacture a computer mousepad. The total Cost to manufacture 1,000
mousepad is $2,660. The unit cost is $2.66 (per pad). The cost break down is:

• Artwork is a fixed cost at $500 (or .50 per unit)
• Set Up costs are $250 (or .25 per unit)
• Shipping costs are $10 (or .01 per unit)
• Papers for production will cost $1.50 per unit.
• Rubber Pads are $ .15 per unit.
• Application of paper to pad cost is $.25 per unit

Notice the variation in the unit cost for each item. One of the biggest problems with estimating software projects is
understanding unit cost. Software managers fail to break down items into similar components or like areas. They
assume all units cost the same.

There are different costs for each of the function point components. The unit cost for external inputs is not the same
as the unit cost of external outputs for example. The online external inputs and the batch external inputs do not have
the same unit cost (or cost per function point). The cost per unit to build and implement internal logical files is not the
same per unit cost as the building and implementing of online reports.

To accurately estimate the cost of an application each component cost needs to be estimated. The same is true for the
mousepad problem above.

Function Point Counting Process

Even though there have been attempts by the National Bureau of Standards (NBS) and IEEE to standardize terms and
definitions, there are no industry wide practiced terms and definitions related to software development. IFPUG has
developed some standard terms and definitions related to function points, but these terms and definitions need to be
applied to a variety of different software environments.

Clients who have standardized their terminology within their own environments have seen significant jumps in
productivity. That is, they have reduced the number of verbs used to describe transactions and other events.

Imagine if we compared a blue print document used for construction purposes with a typical software design
document. While the blue print uses standard terminology the software design document uses a variety of different
terminology to describe the same exact thing.

Definition

The overall objective is to determine adjusted function point count. There are several steps necessary to accomplish
this. While you may not understand the mechanics of the following steps, they will be discussed in great detail in the
remainder of the book. The actual sequence or order of steps is not necessary. Many counters will complete step 5
through out the entire count – gathering information as they go:

• Determine type of function point count
• Determine the application boundary
• Identify and rate transactional function types to determine their contribution to the unadjusted function point

count.
• Identify and rate data function types to determine their contribution to the unadjusted function point count.
• Determine the value adjustment factor (VAF)
• Calculate the adjusted function point count.

The unadjusted function point (UFP) count is determined in steps 3 & 4. Steps 3 & 4 are discussed later in this
chapter and discussed in detail later in the book. It is not important if step 3 or step 4 is completed first. In GUI and
OO type applications it is easy to begin with step 3.

The final function point count (adjusted function point count) is a combination of both unadjusted function point
count (UFP) and the general system characteristics (GSCs).

Types of Function Point Counts

Function point counts can be associated with either projects or applications. There are three types of function point
counts.
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• Development project function point count
• Enhancement project function point count
• Application function point count

High Level Steps:

• To complete a function point count knowledge of function point rules and application documentation is needed.
Access to an application expert can improve the quality of the count also.

• Once the application boundary has been established, FPA can be broken into three major parts (FPA for
transactional function types, FPA for data function types and FPA for GSCs).

Independence and Dependence:

Since the rating of transactions is dependent on both information contained in the transactions and the number of
files referenced, it is recommended that transactions are counted first. At the same time the transactions are counted
a tally should be kept of all FTR’s (file types referenced) that the transactions reference. It will be made clear in later
chapters that every FTR must have at least one or more transactions.

FPA Steps for Transactional Function Types

Later in this document external inputs, external outputs and external inquiries are discussed in detail. Each transaction
must be an elementary process. An elementary process is the smallest unit of activity that is meaningful to the end
user in the business. It must be self-contained and leave the business in consistent state.

T1. Application documentation and transaction rules are used to identify transactions.

T2. The application documentation and transaction rules are used to determine type of transaction (external input,
external output, or external inquiry).

T3. With the help of application documentation (data model and transaction model) and transaction rules the number
data elements and file type referenced are determined.

T4. Each identified transaction is assigned a value of low, average or high based upon type, data elements, and files
referenced.

T5. A distinct numerical value is assigned based upon type and value (low, average, or high).

T6. All transactions are summed to create a transaction unadjusted function point count.

FPA Steps for Files

Later in this document internal logical files and external interface files are discussed in detail.
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F1. Application documentation and file rules are used to identify files.

F2. The application documentation (transaction model and data model) is used to determine type of file (either
external interface file or internal logical file).

F3. With the help of application documentation (data model) and file rules the number data elements and record
element types are determined.

F4. Each identified file is assigned a value of low, average or high based upon type, data elements and record types.

F5. A distinct numerical value is assigned based upon type and value (low, average, or high).

F6. All files are summed to create a file unadjusted function point count.

Establishing the Boundary

Since it is common for computer systems to interact with other computer systems and/or human beings, a boundary
must be drawn around each system to be measured prior to classifying components. This boundary must be drawn
according to the sophisticated user’s point of view. In short, the boundary indicates the border between the project
or application being measured and the external applications or user domain. Once the border has been established,
components can be classified, ranked and tallied.

One of the benefits of function point is analysis is creating ratios with other metrics such hours, cost, headcount,
duration, and other application metrics. It is important the function point boundary be consistent with other metrics
that are being gathered for the application and project.

Identify the Boundary

• Review the purpose of the function point count.
• Look at how and which applications maintain data.
• Identify the business areas that support the applications.

The boundary may need to be adjusted once components have been identified. In practice the boundary may need
to be revisited, as the overall application is better understood. Function point counts may need to be adjusted as you
learn about the application.

Standard Documentation

• General Specification Documents
• Interface Documents
• Other metric reports
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• Interviews with the users
• User Documentation
• Design Documentation
• Requirements
• Data flow diagrams

Establishing the Boundary early in the Life cycle

Boundaries can be established early in the software life cycle. If the application is a replacement project, then
the project boundary should be similar (perhaps identical) to the previous application. If the application is a new
application, other applications boundaries should be reviewed to establish the correct boundary.

Technology Issues

Internet/Intranet Applications

The boundary for an Internet/Intranet application is defined in a similar way for traditional applications. For
traditional applications the boundary is not drawn just around the user interface or a group of screens but around the
entire application. Frequently, Internet/Intranet applications are just extensions to current and existing applications.
There is a tendency to create a "new" application for the Internet/Intranet extension, but this approach is incorrect.

Client/Server

The boundaries for client/server applications need to be drawn around both the client and server. The reason is that
neither the client nor server supports a users (or sophisticated) view. That is, one alone does not represent a total
application. As mentioned early, any complete application needs both data at rest (server) and data in motion (client).

Tabulating

There is no special tabulating that needs to take place for establishing the boundary, but the boundary can
dramatically impact the number of external inputs and external outputs.

Identifying RETs, DETs, FTRs

Record Element Type (RET): A RET is user recognizable sub group of data elements within an ILF or an EIF. It is
best to look at logical groupings of data to help identify them. The concept of RET will be discussed in detail in the
chapters that discuss internal logical file and external interface files.

File Type Referenced (FTR): A FTR is a file type referenced by a transaction. An FTR must also be an internal
logical file or external interface file.

Data Element Type (DET): A DET is a unique user recognizable, non-recursive (non-repetitive) field. A DET is
information that is dynamic and not static. A dynamic field is read from a file or created from DETs contained in a
FTR. Additionally, a DET can invoke transactions or can be additional information regarding transactions. If a DET
is recursive then only the first occurrence of the DET is considered not every occurrence.

A data element can be either quantitative or qualitative. A quantitative data element is data in numerical form. A
qualitative data element is data not in numerical form, but is in the form of text, photographs, sound bytes and so on.

Understanding the FTRs and DETs helped distinguish one transaction from another transactions. This concept will be
discussed in detail later in this book.

Rating

All of the components are rated based upon DET’s, and either RETs or FTRs.

Component RETs FTRs DETs

External Inputs (EI) yes yes

External Outputs (EO) yes yes

External Inquiries (EQ) yes yes



 | Function Point Modeler Workbench | 133

Component RETs FTRs DETs

External Interface Files (EIF) yes yes

Internal Logical Files (ILF) yes yes

Transaction DETs

• External Inputs: Data Input Fields, Error Messages, Calculated Values, Buttons
• External Outputs: Data Fields on a Report, Calculated Values, Error Messages, and Column Headings that are

read from an ILF. Like an EQ and EO can have an input side and output sides.
• External Inquiries: Input Side - field used to search by, the click of the mouse. Output side - displayed fields on

a screen.

Record Element Types (RETs)

Record element types are one of the most difficult concepts in function point analysis. Most record element types are
dependent on a parent - child relationship. In this case, the child information is a subset of the parent information. In a
parent child relationship there is a one to many relationship. That is, each child piece of information is linked directly
to a field on the parent file. More will be discussed about RETs in the internal logical file and external interface file
sections.

Tips to Identify RETs and DETs early in the life cycle

RETs and DETs may be difficult to evaluate early in the software life cycle. Since RETs and DETs are essential to
rating components, several techniques can be used to rate components.

• Rate all transactional function types and data function types as Average.
• Determine how are transactional function type and data function types rated in similar type applications. Are the

majority of data function types rated as low in similar type applications?

DETs for GUI

Using the strict definition of a data element provided by IFPUG’s Counting Practices Manual. “A data element is
a user recognizable, non recursive field.” Unfortunately this does not provide much guidance when counting GUI
applications. In fact, the IFPUG Counting Practices manual does not provide much detail on counting, radio buttons,
check boxes, pick list, drop downs, look ups, combo boxes, so on and so forth. In GUI applications, a data element is
information that is stored on an internal logical file or that is used to invoke a transaction.

Radio Buttons

Radio Buttons are treated as data element types. Within a group of, a frame, radio buttons the user has the option of
selecting only one radio button; so only one data element type is counted for all the radio buttons contained in the
frame.

Check Boxes

Check Boxes differ from radio buttons in that more than one check box can be selected at a time. Each check box,
within a frame, that can be selected should be treated as a data element.

Command Buttons

Command buttons may specify an add, change, delete or inquire action. A button, like OK, may invoke several
different types of transactions.
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According to IFPUG counting rules each command button would be counted as a data element for the action it
invokes. In practice this data element will not impact the rating of the transaction, but it does help understand and
dissect a screen full of transactions.

A button like next may actually be the input side of an inquiry or another transaction.
 

 

For example, a simple application to track distributors could have fields for Distributor Name, Address, City, State,
Zip, Phone Number, and Fax Number. This would represent seven fields or (seven data elements) and the add
command button would represent the eighth data element. In short, the “add” external input represent a one external
input with eight data elements, the “change” external input represents another external input with eight (seven data
elements plus the “change” command button), and the “delete” external input represents the last external input with
eight data elements (seven fields plus the “delete” command button).

Display of Graphical Images or Icons

A display of a graphical image is simply another data element. An inventory application, for example, may contain
data about parts. It may contain part name, supplier, size, and weight and include a schematic image of the part. This
schematic is treated as a single data element.

Sound Bytes

Many GUI applications have a sound byte attached. This represents one data element. The number of notes played
is simply recursive information. If the length of the sound byte increases, then the data element remains one. For
example, you can play the “Star Spangled Banner” for two seconds or four seconds, but you’ll still count the sound
bytes as one data element. The longer it is played the more recursive information it has.

Photographic Images

A photographic image is another data element, and is counted as one. A human resource application may display
employee name, start date, etc. and a photograph of the employee. The photograph is treated the same as employee
name or employee start date. The photograph is stored and maintained like any other piece of information about the
employee.

Messages

There are three types of messages that are generated in a GUI application: error messages , confirmation messages
and notification messages . Error messages and confirmation messages indicate that an error has occurred or that a
process will be or have been completed. They are not an elementary or independent process alone, but they are part
of another elementary process. A message that would state, "zip code is required" would be an example of an error
message. A message that would state, "are you sure you want to delete customer" is an example of a confirmation
message. Neither type of message is treated as a unique external output, but each is treated as a data element for the
appropriate transaction.

On the other hand, a notification messages is a business type message. A notification is an elementary process, has
some meaning to the business user and is independent of other elementary processes. It is the basis of processing and
a conclusion being drawn. For example, you may try to withdraw from an ATM machine more money than you have
in your account and you receive the dreaded message, "You have insufficient funds to cover this transaction." This
is the result of information being read from a file regarding your current balance and a conclusion being drawn. A
notification message is treated as an External Output.

DETs For Real Time Systems

Using the strict definition of a data element provided by IFPUG’s Counting Practices Manual. "A data element is a
user recognizable, non recursive field." Unfortunately this does not provide much guidance when counting real time
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or embedded systems. In fact, the IFPUG Counting Practices manual does not provide any detail on counting these
types of systems.

Some traditional definitions can be applied directly to real time and embedded systems. The fields on a diagnostics
file: time of diagnostics, hardware state during diagnostics, temperature, voltage, so on and so forth would all be
examples of data elements.

Real Time Systems may not have any "traditional user interface." That is, the stimulus for the Real Time System may
be it’s own output – or state. A real time or embedded systems can signal to determine current Hardware State (or
location) and determine the appropriate adjustment (input) based on the current state.

Navigation

Nigation is moving from one transaction to another.

External Inputs

External Inputs (EI) - is an elementary process in which data crosses the boundary from outside to inside. This data
is coming external to the application. The data may come from a data input screen or another application. The data
may be used to maintain one or more internal logical files. The data can be either control information or business
information. If the data is control information it does not have to maintain an internal logical file.

If an external input adds, changes and deletes (maintains) information on an internal logical file, then this represents
three external inputs. External inputs (especially change & delete) may be preceded by an external inquiry (see the
section on external inquiries). Hence a full function screen is add, change, delete and inquiry (more will be discussed
about inquiries later in the book).

Rating

Like all components, EI’s are rated and scored. The rating is based upon the number of data element types (DET’s)
and the file types referenced (FTR’s). DET’s and FTR’s are discussed earlier. The table below lists both the level
(low, average or high) and appropriate score (3, 4 or 6).

Files Type Referenced (FTR) Data Elements (DETs)

1-4 5-15 Greater than 15

Less than 2 Low (3) Low (3) Average (4)

2 Low (3) Average (4) High (6)

Greater than 2 Average (4) High (6) High (6)

Counting Tips

Try to ask the question, do external inputs need more or less than 2 files to be processed? For all the EIs that reference
more than 2 FTRs, all that is needed to know is if the EI has more or less than 4 data element types referenced. If the
EI has more than 4 DETs the EI will be rated as high; less than 4 DETs the EI will be rated as average. Any EIs that
reference less than 2 FTRs should be singled out and counted separately.

Examples

EIs can be business data, control data and rules based data.
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 Business Data:
Customer Name, Address, Phone, and so on and so forth.

Control Data: The data elements are those that invoke the transaction or change the behavior of the application. Each
check box represents a data element. Additionally, the sort employee list radio buttons represents one data element as
well as the time format radio buttons.

Control information changes or alters the state (or behavior) of the application. Control information specifies how,
what, and when data will be processed.

Data Elements

Unique sets of data elements help distinguish external input from other external input.

• Data Input Fields
• Calculated Values or Derived Data that are stored
• Error Messages
• Confirmation Messages
• Recursive fields are only counted as one DET.
• Action keys (command buttons such as OK, Next, so on and so forth)
• Multiple Action Keys that perform the same function are counted only as one DET.

File Types Referenced (FTRs)

Unique FTRs helps distinguish external input from other external input. An FTR must be either an Internal Logical
File and/or External Interface File. Each internal logical file that an external input maintains is counted as an FTR.
Any internal logical file or external interface file that is referenced by an external input as part of the elementary
process of maintaining an internal logical file would be considered an FTR also. For example, an External Input may
update an internal logical file, but must also reference a "security file" to make sure that the user has appropriate
security levels. This would be an example of two FTRs.

Uniqueness

A unique set of data elements, and/or a different set of FTRs, and/or a unique set of calculations make one external
input unique or different from other external inputs. That is, one of the following must be true:
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• Unique or different set of data elements
• Unique or different set of FTRs
• Unique or different calculations

Calculations alone are not an elementary process but part of the elementary process of the external input. A
calculation (or derived data) does not make the transaction an external output. External outputs and derived data will
be discussed in detail in the external output section of this document.

Understanding Enhancement Function Points

Modification of any of the items, which make an External Input unique from other external inputs, causes the EI to be
"enhanced." If any of the following are true:

• DETs added to an EI
• DETs modified on an EI. The DET was included in the last FP Count.
• A New FTR
• Modifications to a calculation that appears on an EI.

Technology Issues

GUI

Radio Buttons - each set of radio buttons is counted as one DET. Only one radio button can be selected at a time.

Pick Lists - The actual pick list (also known as drop downs, lookups) could be an external inquiry, but the result of
the inquiry may be a DET for an external input.

Check Box - Each check box that can be simultaneously checked is a unique DET.

Buttons - Buttons can be DETs. The OK button above would be a data element. If there was a series of buttons Add,
Change and Delete. Each button would be counted as a DET for the associated transaction.

A single GUI "screen" may represent several transactional function types. For example, it is common for a GUI
“screen” to have a series of external inquiries followed by an external input.

Other

Error Messages - error messages are counted as data elements (DETs), not unique external inquiries. Count one
DET for the entire input screen. Multiple Error Messages are similar to recursive values. An error message is part of
another elementary process.

The number of error messages on a GUI screen is less than the number of error messages associated with traditional
applications. If used correctly, radio buttons and pick lists can force users to select correct information; therefore,
eliminating the need to do editing behind the scenes.

In practice the number of DETs do not make much of a difference in evaluating an EI, understanding error or
confirmation messages help in the understanding of uniqueness.

Real Time and Embedded Systems - In real time and embedded systems communication between hardware and
software is common and should not be overlooked when counting these types of systems. Other types of inputs for
real time and embedded systems are: Operator Controls, Volume Controls, Sensor Readings, Radio Frequencies,
Standards and Limit Settings (Alarms Settings, so on and so forth.)

Standard Documentation

A good source of information to determine external inputs is Screen Layouts, Screen Formats & dialogs, and
layouts of any input forms. Additional inputs from other applications should be inventoried here. Inputs from other
applications must update internal logical files of the application being counted.

• Screen Layouts
• Screen Dialogs
• Design Documentation
• Functional Specifications
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• User Requirements
• Any Input Forms
• Context Diagrams
• Data Flow Diagrams

Tips to Identify External Inputs early in the life cycle

The following types of documentation can be used to assist in counting EIs prior to system implementation.

• Any refined objectives and constraints for the proposed system.
• Collected documentation regarding the current system, if such a system (either automated or manual) exits.
• Documentation of the users’ perceived objectives, problems and needs.
• Preliminary Data Flow Diagram.
• Requirements Documentation.

Typical Vocabulary

The following words are associated with external input or "inputs." While reading textual document or application
description look for these type of words, they may indicate an add, change or delete aspect of an external input.

Add, Activate, Amend (change and delete), Cancel, Change, Convert (change), Create (add), Delete, Deassign,
Disable, Disconnect (change or delete), Enable, Edit (change), Insert ( add and change), Maintain (add, change,
or delete), Memorize (add), Modify (change), Override (change), Post (add, change and delete), Remove (delete),
Reactivate (change), Remit, Replace (change), Revise (change and delete), Save (add, change or delete), Store (add),
Suspend (change or delete), Submit (add, change or delete), Update (add, change or delete), Voids (change and
delete)

External Outputs

External Outputs (EO) - an elementary process in which derived data passes across the boundary from inside to
outside. Additionally, an EO may update an ILF. The data creates reports or output files sent to other applications.
These reports and files are created from information contained in one or more internal logical files and external
interface files.

Derived Data is data that is processed beyond direct retrieval and editing of information from internal logical files or
external interface files. Derived data is usually the result of algorithms, or calculations. Derived data occurs when one
or more data elements are combined with a formula to generate or derive an additional data element(s). This derived
data does not appear in any FTR (internal logical file or external interface file).

An algorithm is defined as a mechanical procedure for performing a given calculation or solving a problem in a series
of steps.

A calculation is defined as an equation that has one or more operators. An operator is a mathematical function such as
addition, subtraction, multiplication, and division (+, -,x, /).

Transactions between applications should be referred to as interfaces. You can only have an external output or
external inquiry of data external to your application. If you get data from another application and add it to a file in
your application, this is a combination get and add (external inquiry and external input).

Rating

Like all components, EOs are rated and scored. The rating is based upon the number of data elements (DETs) and
the file types referenced (FTRs). The rating is based upon the total number of unique (combined unique input and
out sides) data elements (DETs) and the file types referenced (FTRs) (combined unique input and output sides).
DETs and FTRs were discussed earlier in this section. The table below lists both the level (low, average or high) and
appropriate score (4, 5 or 7).

File Types Referenced (FTR) Data Elements

1-5 6-19 Greater than 19

Less than 2 Low (4) Low (4) Average (5)
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File Types Referenced (FTR) Data Elements

2-3 Low (4) Average (5) High (7)

Greater than 3 Average (5) High (7) High (7)

Counting Tips

You may ask the question, Do external outputs need more or less than 3 files to be processed? For all the EOs that
reference more than 3 files, all that is needed to know is if the EO has more or less than 5 data element types. If the
EO has more than 5 data element types then the EO will be rated as high, less than 5 the EO will be rated as average.
Any EOs that reference less than 3 files should be singled out and counted separately.

Terminology

The definition states an EO contains information, which derived data passes across the boundary from inside to
outside. Some confusion may arise because an EO has an input side. The confusion is the definition reads data
passes across the boundary from inside to outside. The input side of an EO is search criteria, parameters, etc does
not maintain an ILF. The information that a cross from outside to inside (input side) is not permanent data, but it is
transient data. The intent of the information coming from outside the application (input side) is not to maintain an
ILF.

Examples

Unlike other components EO’s almost always contain business data. Rule base data and control based "outputs" are
almost always considered External Inquiries. This is true due to the fact that rule data and control type data is not
derived (or derivable).

Notification Messages are considered EOs. A notification message differs from an error message. A notification
message is an elementary process, while an error message (or confirmation message) is part of an elementary process.
A notification message is the result of some business logic processing. For example, a trading application may notify
a broker that the customer trying to place an order does not have adequate funds in their account.

Derived Data displayed in textual fashion (rows and columns) and graphical format is an example of two external
outputs.

Data Elements

Unique sets of data elements help distinguish one external output from another. Keep in mind that a DET is
something that is dynamic.

(A DET is a unique user recognizable, non-recursive (non-repetitive) field)

• Error Messages
• Confirmation Messages
• Calculated Values (derived data)
• Values on reports that are read from an internal logical file or external interface file.
• Recursive values or fields (count only once)
• Generally, do not count report headings (literals) as data elements unless they are dynamic. That is, if the report

headings are read from files that are maintained they may be DETs also.
• System generated dates that are on the tops or reports or are displayed are normally not counted as DETs. If

system generated dates is part of business information of the external output they should be counted as DETs. For
example, the date an invoice is printed or the date a check is printed.

File Types Referenced (FTR)

Unique FTRs help distinguish one external output from another. An FTR must be either an Internal Logical File and/
or External Interface File.

The elementary process associated with an external output may update an internal logical file or external interface
file. For example, the elementary process that produces as payroll check may include an update to a file to set a flag
to indicate that the payroll check was produced. This is not the same as maintaining the file. Maintained is the process
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of modifying data (adding, changed and deleting) via an elementary process (via an External Input). The primary
intent of an EO is not to maintain an ILF.

Uniqueness

A unique set of data elements, and/or a different set of FTRs, and/or a unique set of calculations makes one external
output unique or different from other external outputs. That is, one of the following must be true:

• Unique or different set of data elements
• Unique or different set of FTRs
• Unique or different calculations
• Unique processing logic

Understanding Enhancement Function Points

Modification of any of the items, which make an External Output unique from other external outputs, causes the EO
to be "enhanced." If any of the following are true:

• DETs added to an EO
• DETs modified on an EO. The DET was included in the last FP Count.
• A New FTR
• Modifications to a calculation that appears on an EO.

Technology Issues

Each media that a report is sent to is counted as a unique EO. If a report were available on line, paper and electronic
it would be counted as three EOs. Now some organizations choose to count this as only one EO. Whatever decision is
made, the organization needs to stick with it.

Disk Cache: Information that is prepared, processed, and derived and put on cache files for another application to
utilize should not be overlooked. These cached files may be external outputs or external inquiries.

Standard Documentation

• Report Layouts
• Design Documentation
• Functional Specifications
• User Requirements
• Database descriptions
• Field Sizes and Formats
• Graphical Report Layouts

Tips to Identify External Outputs early in the life cycle

The following types of documentation can be used to assist in counting External Outputs prior to system
implementation.

• Any refined objectives and constraints for the proposed system.
• Collected documentation regarding the current system, if such a system (either automated or manual) exits.
• Documentation of the users’ perceived objectives, problems and needs.
• Preliminary Data Flow Diagrams.

Typical Vocabulary

The following words are associated with an "external outputs." While reading textual documents or application
descriptions look for these types of words. They may indicate an external output. Notice these words are very similar
to those words used for an External Inquiry (discussed in the next chapter).

Browse, Display, Get, On-lines, Output, Print, Query, Reports, Request, Retrieve, Seek, Select, View
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Special Issues and Concerns

When to count DET’s for Report Headings

Report headings are counted when they are dynamic. That is, if report headings are being read from an internal logical
file they should be counted as DETs.

Can an External Output have an input side?

Since the input side is not stand-alone (independent or an elementary process) it should be considered as part of the
entire external output. The FTRs and DETs used to search should be combined with unique outside DETs and FTRs
for at grand total FTRs and DETs for the entire EO. In short, an external output can have an input side.

Can an External Output Update an Internal Logical File?

An external output can update an internal logical file, but it is incorrect to say that an external output can maintain an
internal logical file. The update is part of the elementary process of the external output. An external input maintains
data on and ILF file. The maintain process is an elementary process alone. The definition for maintaining is discussed
in the internal logical file and external input sections of this book.

Graphs

Graphs are counted the same way as the textual EOs. That is, the graph is rated and scored based on the number of
DETs and the number of FTRs. In fact, recursive information is easily seen in a graph, but can be more difficult to
visualize in a text report.

There are 10 data elements in the following table

1. Days
2. Hits
3. % of Total Hits
4. User Sessions
5. Total Hits (weekday)
6. Total % (weekday)
7. Total User Sessions (weekday)
8. Total Hits (weekend)
9. Total % (weekend)
10. Total User Sessions (weekend)

Days, Hits, % of Total Hits and User Sessions all have recursive data.
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The same data could be processed and presented as bar graph. But on the following bar graph there are only two data
elements (user session and day of week). The bar graph is a separate external output and is unique from the above
table. In short, it provides different business slightly different information than the table.

External Inquiries

External Inquiry (EQ) - an elementary process with both input and output components that result in data retrieval
from one or more internal logical files and external interface files. The input process does not update or maintain any
FTRs (Internal Logical Files or External Interface Files) and the output side does not contain derived data.

Transactions between applications should be referred to as interfaces. You can only have an external output or
external inquiry of data external to your application. If you get data from another application and add it to a file in
your application, this is a combination get and add (external inquiry and external input).

Rating

Like all components, EQs are rated and scored. Basically, an EQ is rated (Low, Average or High) like an EO, but
assigned a value like and EI. The rating is based upon the total number of unique (combined unique input and out
sides) data elements (DETs) and the file types referenced (FTRs) (combined unique input and output sides). DETs
and FTRs were discussed in an earlier chapter. If the same FTR is used on both the input and output side, then it is
counted only one time. If the same DET is used on both the input and output side, then it is only counted one time.

Functional Complexity Matrix (shared table between EO and EQ)

File Types Referenced (FTR) Data Elements

1-5 6-19 Greater than 19

less than 2 Low (3) Low (3) Average (4)

2 or 3 Low (3) Average (4) High (6)

Greater than 3 Average (4) High (6) High (6)

Examples

EQs can contain business data, control data and rules based data.

Business Applications: An example of Business data is customer names, addresses, phone number, so on and so forth.
An example of Rules Data is a table entry that tells how many days a customer can be late before they are turned over
for collection.

Drop Down List (a listing of customers by name) would be an example of an EQ.

A screen full of customer address information would be an example of an EQ.
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Reset (or restore) functionality where all the modified fields are reset to their saved values. The key to understanding
this an external query is the “reset to their saved values.” Clearly a table is being read.

Terminology

The definition states that an EO contains information, which derived data passes across the boundary from inside
to outside. Some confusion may arise because an EO has an input side. The confusion is the definition reads data
passes across the boundary from inside to outside. The input side of an EO is search criteria, parameters, etc does
not maintain an ILF. The information that a cross from outside to inside (input side) is not permanent data, but it is
transient data. The intent of the information coming from outside the application (input side) is not to maintain an
ILF.

Data Elements

Unique sets of data elements help to distinguish one external inquiry from another external inquiry.

• Input Side

• Click of a the mouse
• Search values
• Action keys (command buttons)
• Error Messages
• Confirmation Messages (searching)
• Clicking on the an action key
• Scrolling
• Recursive fields are counted only once.

• Outside

• Values read from an internal logical file or external interface file
• Color or Font changes on the screen
• Error Messages
• Confirmation Messages
• Recursive fields are counted only once.

• The combined (unique) total input and outside DETs are used when rating EQs.

Like an EI, action keys that perform the same function but appear multiple times are counted as only one DET.

Error Messages and confirmation messages can and do occur on either the input side and/or output side. If a user
initiates a search and a message is displayed, "please wait searching" is an example of a confirmation message on the
input side. The message "all fields must be populated" is another example of an error message on the input side. On
the other hand, if the message is "customer not found" is an example of an error message on the output side. That is,
the input side contained no problems. The database was searched and the "error" has occurred on the output side of
the transaction.

File Type Referenced (FTRs)

Unique FTRs help distinguish one external inquiry from another external inquiry.

Both the input side and output side must be considered when evaluating the FTRs used by an external inquiry.
Normally they are the same but there are instances where they may not be the same. The combined total should be
used when evaluating an EQ. For example, a security check may be done on the input side of an external inquiry. The
security check is done to make sure the user of the application has the appropriate level of authority to view the data.

Uniqueness

A unique set of data elements, and/or a different set of FTRs make one external inquiry unique or different from other
external inquiry. That is, one of the following must be true:

• Unique or different set of data elements
• Unique or different set of FTRs
• Unique processing logic
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Sorting does not make on external inquiry unique from another since the data elements and FTR’s are the same.

An external inquiry cannot have calculated values or derived data . This characteristic distinguishes an external
inquiry from an external output.

Understanding Enhancement Function Points

Modification of any of the items, which make an External Inquiry unique from other external inquiries, causes the EQ
to be "enhanced." If any of the following are true:

• DETs added to an EQ
• DETs modified on an EQ. The DET was included in the last FP Count.
• A New FTR

Example of Graphical Data

Imagine the following map. There are two different ways to get the same exact data. One you can click on the specific
state or you can use the drop down list. Once you choose a state data is generated and presented to the screen. These
two EQ are repetitive and do the same exact thing. We would not consider this as two EQs but only one. You can
view this map by visiting http://quickfacts.census.gov/qfd/index.html

Technology Issues

• GUI applications are usually rich with EQs (and EOs).
• A dynamic pick list that reads from a file is an example an External Inquiry.
• GUI screens my have a series of EQs prior to an EI.

Standard Documentation

• Screen Layouts
• Design Documentation
• Functional Specifications
• Table Layouts
• User Requirements
• Database descriptions
• Pick lists
• Field sizes and formats

http://quickfacts.census.gov/qfd/index.html
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Tips to Identify EQs early in the life cycle

The following types of documentation can be used to assist in counting internal logical files prior to system
implementation.

• Any refined objectives and constraints for the proposed system.
• Collected documentation regarding the current system, if such a system (either automated or manual) exits.
• Documentation of the users’ perceived objectives, problems and needs.
• Preliminary Data Flow Diagrams.

Typical Vocabulary

The following words are associated with an “external inquiry.” While reading textual document or application
description look for these type of words. They may indicate an external inquiry. Notice the words are very similar to
those related to external outputs.

Browse, Display, Extract, Fetch, Find, Gather, Get, Drop Down, Lists, Look Ups, On-lines, Output, Pick Lists, Print,
Query, Scan, Seek, Select, Show, View, Reports

Special Issues and Concerns

Can an External Inquiry not have an input side?

Even though it may not be visible all external inquiries have an input side. In cases where the input side is not readily
visible is referred to as an implied inquiry.

Can an External Inquiry Update an Internal Logical File?

Like an external output, an external inquiry may update an internal logical file, but it is incorrect to say that an
external inquiry can maintains an internal logical file. The update is part of the elementary process of the external
inquiry. The definition for maintaining is discussed in the internal logical file and external input sections of this book.
The only component that maintains an internal logical file is an external input.

Menus (Dynamic Menus)

The menu displayed to the right is a dynamic menu. Word displays the last several files that have been opened. We
can easily conclude that this information is being read from some type of internal file. Hence, the information is
dynamic. The menu would be counted as an external inquiry.

Even though the IFPUG Manual explicitly states that menus are not counted, in this case it is clear that the menu is
dynamic and changes.

The real distinction is if a menu is dynamic or static. That is, are the contents of the screen or report dynamic (read
from some file) or are they static (hard coded).

Transaction Review

This chapter reviews the three types of transactional function type (external input, external output and external
inquiry).

Multiple Languages

Consider an application that is a single language. More than likely report headings, text descriptions are all “hard
coded." That is the user cannot dynamically change the headings or the text. Now consider an application that has
been developed with multiple languages in mind. The report headings, text descriptions are all read from files.
Compare the following chart in Spanish to the English chart presented earlier. Is this chart a unique external output or
the same external output?
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The Spanish chart is not a unique external output. If external outputs are available in multiple languages then several
things need to be considered. First there is probably some control input that allows the user to dynamically select the
language. Second, there is an additional FTR referenced that contains the language text. Third, this language internal
logical file is maintained by an external input. Fourth, there are more data elements in the report. If an external output
is available in more than one language then it is not considered an unique external output, but the external output is
more complex (more DETs and more FTRs).

Display of Graphical Images or Icons

A display of a graphical image is simply another data element. An inventory application may contain data about parts.
It may contain part name, supplier, size, and weight and include a schematic image of the part. This schematic is
treated as another data element.

Another example would be a map. The map may be "hot." As the mouse pointer is moved over the map different city
names are displayed. If the user clicks on a particular hot point details about that city is displayed. The details about
each city are contained in an internal logical file or external interface file then the details could be an external inquiry.

The following map of the United States is "hot." If you click on Kansas City, then you get the following information.

Kansas City, Missouri: Population 435,146: Location: 39.1 N, 94.5 W Houston, Texas: Populations 2,231,130:
Location: 29.8 N, 95.4 W Chicago, Illinois: Population 2,783,726: Location: 41.8 N, 87.6 W

This would be an example of another inquiry.



 | Function Point Modeler Workbench | 147

Messages

There are three types of messages that are generated in a GUI application: Error messages, Confirmation Messages
and Notification Messages. An error message and a confirmation message indicate that an error has occurred or that
a process will be or have been completed. A message that would state, "Zip code is required" would be an example
of an error message. A message that would state, "Are you sure you want to delete the customer?" is an example of a
confirmation message. Neither of these types of messages is treated as a unique External Output, but they are treated
as data elements for the appropriate transaction.

On the other hand, a notification messages is a business type message. It is the basis of processing and a conclusion
being drawn. For example, you may try to withdraw from an ATM machine more money than you have in your
account and you receive the dreaded message, "You have insufficient funds to cover this transaction." This is
the result of information being read from a file regarding your current balance and a conclusion being drawn. A
notification message is treated as an External Output.

Notification Messages may be the result of processing and the actual processing or derived data my not be seen. If
a message is created to be sent to a pager (beeper) at a given time. This is much like an alarm. That is current time
is compared to set time and they are equal the message is sent. The pager message has one data element the text
message.

Complex Control Inputs

Control inputs change the behavior of an application or the content of a report. In the "Create Report" control screen,
the user has the ability to select which reports are going to be produced. This particular screen has several data
element types. The check box, graph type, dimensions elements, sub-items and the action keys.

Note that the users can choose each report individually. In fact each report is as an object. The generated report is a
combination of several reports (or objects). Each object has several attributes.

Hyperlinks on WebPages

Many hyperlinks are nothing more than menus. In this case, they are not treated as an EI, EO or EQ.

According to the rules for an external inquiry a request must come from outside the application boundary and
information must be displayed from inside to outside the application boundary. A hyperlink is just that – a hyperlink.
A hyperlink is navigation to another part of the application or another Internet/Intranet site. No information crosses
the boundary.

An external inquiry must reference at least one internal logical file and/or one external interface file. Both an internal
logical file and an external interface file must be a logical group of related information. Imagine hyperlinking to
another Website -- all the information displayed is not a logical group of information.

On the other hand, a hyperlink that sends a parameter that is used to search could be an example of an external
inquiry. That is, the hyperlink follows the rules required for an external inquiry. There is an input side (the parameter)
and there is an output side the results of the search. In this case the output side is dynamic and changes. This is in
sharp contrast to a static hyperlink that navigates to another part of the Website.

Internal Logical Files

Internal Logical Files (ILF) - a user identifiable group of logically related data that resides entirely within the
application boundary and is maintained through External Inputs. An internal logical file has the inherent meaning it is
internally maintained, it has some logical structure and it is stored in a file.

Even though it is not a rule, an ILF should have at least one external output and/or external inquiry. That is, at least
one external output and/or external inquiry should include the ILF as an FTR. Simply put, information is stored in an
ILF, so it can be used later. The EO or EQ could be from another application. It is worth noting that it is possible that
a specific ILF is not referenced by EO or EQ, but it is used by an EI (other than the EI that maintains it).

Again, even though it is not a rule, an ILF should have at least one external input.
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Rating

Like all components, ILFs are rated and scored. The rating is based upon the number of data elements (DETs) and the
record types (RETs). DET’s and RET’s were discussed earlier. The table below lists both the level (low, average or
high) and appropriate score (7, 10 or 15).

Record Element Types (RET) Data Elements

1 to 19 20 - 50 51 or More

1 Low (7) Low (7) Average (10)

2 to 5 Low (7) Average (10) High (15)

6 or More Average (10) High (15) High (15)

Counting Tips

Determine the appropriate row first then the column. Ask the question, do all files contain one record type or more
than one record type? If all or many of the files only contain one record type, then all that is needed to know if the file
contains more or less than 50 data elements types (DETs). If the file contains more than 50 data elements the file will
be rated as average, if less than 50 data element types the file will be considered low. Any files that contain more than
one record type can be singled out and counted separately.

Examples

ILFs can contain business data, control data and rules based data. The type of data contained in an ILF is the same
type of data an EI to contains and maintains.

It is common for control data to have only one occurrence within an ILF. For example control data file may only
contain parameter settings, or a status setting. For example, part of the on board automobile system only contains
current information, oil pressure, engine temperature, so on and so forth. This particular process of the on board
system does not care about historical data – only the current instance. When the status changes the file is updated with
current information and there is no historical information. The on board system may keep track of historical changes
in diagnostics files, but this would be a totally separate process. This process is not used to keep the car running, but
to help a mechanic understand what has been going on with the engine.

Real Time and Embedded Systems: For example, Telephone Switching is made of all three types, Business Data,
Rule Data and Control Data. Business Data is the actual call, Rule Data is how the call should be routed through the
network, and Control Data is how the switches communicate with each other. Like control files it is common real
time systems will have only one occurrence in an internal logical file.

Business Applications: An example of Business data is customer names, addresses, phone number, so on and so forth.
An example of Rules Data is a table entry that tells how many days a customer can be late before they are turned over
for collection.

Record Element Types

The idea behind RETs is to quantify complex data relationships maintained in a single FTR.

Record element types are one of the most difficult concepts in function point analysis. Most record element types
are dependent on a parent - child relationship. The child information is a subset of the parent information. In a parent
child relationship there is a one to many relationship.

Imagine a customer file that contains Name, Address, so on and so forth. In addition all the credit cards and credit
card numbers of the customer are contained in the file. This would be an example of 2 record types. There would be
multiple occurrences of credit cards and numbers for each customer. The credit card and numbers are meaningless
when not linked to the customer.

Data Element Types

Count a DET’s for each unique user recognizable, nonrecursive field on the ILF or EIF. Fields that are redundant and
appear more than one time are only counted one time. Fields that are redundant because of implementation concerns
are counted only one time.
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Count a DET’s for each piece of data in an ILF or EIF that exists because the user requires a relationship with another
ILF to be maintained (key information). If an EIF has multiple key fields only the key fields that relate back to an ILF
are counted as data element types.

Technology Issues

Lotus Notes refers to data stores as "forms." Powerbuilder Applications may store information on the host or client.
Count it only one time. COBOL Applications may use a variety of data stores such as IMS, DB2 etc.… It is important
to view data from the "logical model."

In Internet applications an html can be a data store if it is maintained.

Standard Documentation

• Table Layouts
• Database descriptions
• Logical data models
• Field sizes and formats
• Design Documentation
• Functional Specifications
• User Requirements

Tips to Identify ILFs early in the life cycle

The following types of documentation can be used to assist in counting internal logical files prior to system
implementation.

• Any refined objectives and constraints for the proposed system.
• Collected documentation regarding the current system, if such a system (either automated or manual) exits.
• Documentation of the users perceived objectives, problems and needs.
• Preliminary Data Models.

Other comments

Code maintenance may not be maintained by the application and they may not be maintained by any other
application, but they exist. The issue is that these same tables may be used by external inquiries. A strict interpretation
of the rules would not allow the inquiries to be counted. It is recommended that this type of tables be treated as
external interface file.

External Interface Files

External Interface Files (EIF) - a user identifiable group of logically related data that is used for reference purposes
only. The data resides entirely outside the application boundary and is maintained by another applications external
inputs. The external interface file is an internal logical file for another application. An application may count a file as
either a EIF or ILF not both. An external interface file has the inherent meaning it is externally maintained (probably
by some other application), an interface has to be developed to get the data and it is stored in a file.

Each EIF included in a function point count must have at least one external output or external interface file against it.
At least one transaction, external input, external output or external inquiry should include the EIF as a FTR.

Every application, which references the EIF, needs to include it in their FP Count. Some organizations have a pull
theory and others have a push theory of data. The pull theory is an external application "reaching into" another
applications and retrieving data. Those organizations which have push theory require applications to create interfaces
(EO or EQ) which other applications read.

Rating

Like all components, EIFs are rated and scored. The rating is based upon the number of data elements (DETs) and the
record types (RETs). DETs and RETs were discussed earlier in this section. The table below lists both the level (low,
average or high) and appropriate score (5, 7 or 10).
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Record Element Types (RET) Data Elements

1 to 19 20 - 50 51 or More

1 Low (5) Low (5) Average (7)

2 to 5 Low (5) Average (7) High (10)

6 or More Average (7) High (10) High (10)

Counting Tips

Only count the part of the file that is used by the application being counted not the entire file. The internal logical file,
of another application, that you access may have a large amount of data, but only consider the DETs and/or RETs that
are used when rating an EIF.

Determine the appropriate row first then the column. Ask the question, do all files contain one record type or more
than one record type? If all or many of the files only contain one record type, then all that is needed to know if the file
contains more or less than 50 data elements types (DETs). If the file contains more than 50 data elements the file will
be rated as average, if less than 50 data element types the file will be considered low. Any files that contain more than
one record type can be singled out and counted separately.

Examples

EIFs can contain business data, control data and rules based data.

Real Time and Embedded Systems: For example, Telephone Switching is made of all three types, Business Data,
Rule Data and Control Data. Business Data is the actual call, Rule Data is how the call should be routed through the
network, and Control Data is how the switches communicate with each other.

Business Applications: An example of Business data is customer names, addresses, phone number, so on and so forth.
An example of Rules Data is a table entry that tells how many days a customer can be late before they are turned over
for collection.

Technology Issues

Lotus Notes refers to data stores as "forms." Client/Server Applications may store information on the host or client.
Count it only one time. COBOL Applications may use a variety of data stores such as IMS, DB2 etc.… It is important
to view data from the "logical model."

Standard Documentation

• Table Layouts
• Interface Diagrams
• Database descriptions
• Logical data models
• Field sizes and formats
• Design Documentation
• Functional Specifications
• User Requirements

Tips to Identify EIFs early in the life cycle

The following types of documentation can be used to assist in counting external interface files prior to system
implementation.

• Any refined objectives and constraints for the proposed system.
• Collected documentation regarding the current system, if such a system (either automated or manual) exits.
• Documentation of the users perceived objectives, problems and needs.
• Preliminary Data Models.
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General System Characteristics

The value adjustment factor (VAF) is based on 14 general system characteristics (GSCs) that rate the general
functionality of the application being counted. Each characteristic has associated descriptions to determine the
degrees of influence.

Rating

The degrees of influence range on a scale of zero to five, from no influence to strong influence. Each characteristic is
assigned the rating based upon detail descriptions provided by the IFPUG Manual. They ratings are:

• 0 Not present, or no influence
• 1 Incidental influence
• 2 Moderate influence
• 3 Average influence
• 4 Significant influence
• 5 Strong influence throughout

Standard Documentation

• General Specification Documents
• Interviews with the users

Rating GSCs early in the life cycle

GSCs can be rated relative early in the software life cycle. In fact, if a user cannot answer these fourteen questions,
then the entire project needs to be re-evaluated.

Tabulating

Once all the 14 GSCs have been answered, they should be tabulated using the IFPUG Value Adjustment Equation
(VAF)

Another way to understand the formula is VAF = (65 + TDI)/100, where TDI is the sum of the results from each
question. A Microsoft Excel formula would be: =0.65+SUM(A1:A14)/100 ; assuming that the values for the
characteristics were in cells A1 – A14.

GSCs at a Glance

General System Characteristic Brief Description

1. Data communications How many communication facilities are there to aid in the transfer or
exchange of information with the application or system?

2. Distributed data processing How are distributed data and processing functions handled?

3. Performance Did the user require response time or throughput?

4. Heavily used configuration How heavily used is the current hardware platform where the application
will be executed?

5. Transaction rate How frequently are transactions executed daily, weekly, monthly, etc.?

6. On-Line data entry What percentage of the information is entered On-Line?

7. End-user efficiency Was the application designed for end-user efficiency?

8. On-Line update How many ILF’s are updated by On-Line transaction?

9. Complex processing Does the application have extensive logical or mathematical processing?

10. Reusability Was the application developed to meet one or many users needs?
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General System Characteristic Brief Description

11. Installation ease How difficult is conversion and installation?

12. Operational ease How effective and/or automated are start-up, back up, and recovery
procedures?

13. Multiple sites Was the application specifically designed, developed, and supported to
be installed at multiple sites for multiple organizations?

14. Facilitate change Was the application specifically designed, developed, and supported to
facilitate change?

Considerations for GUI Applications

GSC items such as Transaction Rates, End User Efficiency, On Line Update, and Reusability usually score higher
for GUI applications than on traditional applications. On the other hand, Performance, Heavily used configuration,
multiple sites, will score lower for GUI applications than traditional applications.

Detail GSCs

Each of the following general system characteristic descriptions includes guidelines to determine the degree of
influence.

Each guideline contains a definition of the GSC, rules for determining the score, and, in situations where the rule
needs further clarification, hints have been provided to help apply the rules consistently across all platforms.

Hints are not intended to cover all situations but are meant to provide additional guidance in determining the
appropriate score.

Data Communications

Definition

Data Communications describes the degree to which the application communicates directly with the processor.

The data and control information used in the application are sent or received over communication facilities. Devices
connected locally to the control unit are considered to use communication facilities. Protocol is a set of conventions
that permit the transfer or exchange of information between two systems or devices. All data communication links
require some type of protocol.

Score

Score As Descriptions to Determine Degree of Influence

0 Application is pure batch processing or a stand-alone application

1 Application is batch but has remote data entry or remote printing

2 Application is batch but has remote data entry and remote printing

3 Application includes on-line data collection or TP (teleprocessing) front end to a batch process or
query system

4 Application is more than a front-end, but supports only one type of TP communications

5 Application is more than a front-end, and supports more than one type of TP communications
protocol

Hints

Protocol examples include FTP, dial-up, Token Ring, Ethernet, SNA, TCP/IP, IPX/SPX, HTTP, XML, WAP, NTP,
ICQ, and NETBEUI. This list should not be considered exhaustive.
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Hints to Rules 1 and 2

• Remote devices might include a 3270 terminal connected to a mainframe computer that allows only simple edits
(numeric vs. alpha), or printers connected via parallel port (the user can specify where to direct the output).

• The entry of data does not involve reading or writing directly to an ILF. Data are entered on-line, but the
transactions are stored in a temporary file for batch update of ILF(s) at a later time.

• The entry of data does not involve reading or writing directly to an ILF.

Hints to Rule 3

• Simple business rules and minimal edits (e.g., alpha/numeric, range check, required data, etc.) may be performed.
When this data is eventually processed by the application, additional edits are performed.

• The entry of data does not involve reading or writing directly to an ILF. Data are entered on-line, but the
transactions are stored in a temporary file for batch update of ILF(s) at a later time.

Hints to Rule 4

• Data for the application is collected and may directly update ILF(s) or be stored for future processing using an
input device, which performs edits based on business rules.

• Only one communication protocol is used. Typically, when this data is processed by the application, no further
edits are required.

• The entry of data involves reading or writing to an ILF.
• For example, client-server data entry or Internet data entry, but not both.

Hints to Rule 5

• Same as 4, however, data collection is performed using multiple telecommunication protocols.
• For example, client-server data entry and Internet data entry of the same transaction.

Typically

• Batch applications receive a score of 0 to 3
• On-line applications receive a score of 4
• Web-based applications receive a score of 4 or 5
• Real-time, telecommunication, or process control systems receive a score of 4 or 5

Distributed Data Processing

Definition

Distributed Data Processing describes the degree to which the application transfers data among physical components
of the application.

Distributed data or processing functions are a characteristic of the application within the application boundary.

Score

Score As Descriptions To Determine Degree of Influence

0 Data is not transferred or processed on another component of the system.

1 Data is prepared for transfer, then is transferred and processed on another component of the
system, for user processing.

2 Data is prepared for transfer, then is transferred and processed on another component of the
system ,not for user processing.

3 Distributed processing and data transfer are on-line and in one direction only.

4 Distributed processing and data transfer are on-line and in both directions
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Score As Descriptions To Determine Degree of Influence

5 Distributed processing and data transfer are on-line and are dynamically performed on the most
appropriate component of the system.

Hints

Distributed data processing by definition is not an application that is contained on a central processor, which sends
data to other applications. In a distributed environment, the application is viewed as requiring multiple components
(hardware) on which certain processing or data resides. A knowledgeable user would usually recognize this
configuration.

Hints to Rule 0

• Presentation, processing, and I/O components are all in the same place (i.e., stand-alone applications).

Hints to Rule 1

• Application downloads data to a user’s client machine, so the user can use Excel or other reporting tools to
prepare graphs and perform other analysis.

• Process that transfers data from mainframe to an external component for user processing. This transfer is
performed using a simple protocol such as FTP.

• Transferred to a user for processing.

Hints to Rule 2

• Process that transfers data from mainframe to mid-tier. For example;, processing with SAS-PC.
• Application sends data to client or server. This data is then processed or used to produce reports, etc. No data or

confirmation is sent back to the client or server.
• Transferred to a component for processing.

Hints to Rule 3

• Data is sent between client and server in one direction only. This data is then processed or used to produce reports,
etc. by the receiving application. This data typically includes transactions that update an ILF on the client or
server.

• For example – client-server or web-enabled applications.

Hints to Rule 4

• Data is sent between client and server in either direction. This data is then processed or used to produce reports,
etc. by the receiving application. This data typically includes transactions that update an ILF on the client or
server.

• For example - client-server or web-enabled applications.
• The application runs under an operating system that automatically handles the allocation between components,

however, the use of the operating system did not influence the design and implementation of the application.

Hints to Rule 5

• The developer must consider special application software that looks at multiple processors and runs the
application on a specific type of processor. This is invisible to the user.

• The application runs under an operating system that automatically handles the dynamic allocation between
components, and the use of the operating system specifically influenced the design and implementation of the
application.
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Typically

• Many applications, including legacy applications, receive a score of 0
• Primitive distributed applications that include batch applications in which data is not transferred online on-line

receive a score of 1 to 2
• Client-server or web-based applications receive a score of 3 to 4
• It is uncommon to score 5
• There must be multiple servers or processors, each of which would be selected dynamically on the basis of its

real-time availability to score 5

Performance

Definition

Performance describes the degree to which response time and throughput performance considerations influenced the
application development.

Application performance objectives, stated or approved (or implied) by the user, in either response or throughput,
influence (or will influence) the design, development, installation, and support of the application.

Score

Score As Descriptions To Determine Degree of Influence

0 No special performance requirements were stated by the user.

1 Performance and design requirements were stated and reviewed but no special actions were
required.

2 Response time or throughput is critical during peak hours. No special design for CPU utilization
was required. Processing deadline is for the next business cycle.

3 Response time or throughput is critical during all business hours. No special design for CPU
utilization was required. Processing deadline requirements with interfacing systems are
constraining.

4 In addition, stated user performance requirements are stringent enough to require performance
analysis tasks in the design phase.

5 In addition, performance analysis tools were used in the design, development, and/or
implementation phases to meet the stated user performance requirements.

Hints

• GSCs 3, 4 and 5 are somewhat related. For this GSC, think in terms of "How fast can we make the application go
and how much did/does that impact the design, development, and/or implementation?"

• The users may require real time access to their data, stating or implying standards for response time and
throughput capacity.

• Response time typically relates to interactive processing; throughput relates to batch processing.

Typically

• Batch applications receive a score of 0 to 4
• On-line (including interactive client-server or web-enabled) applications receive a score of 0 to 4
• Web-based applications receive a score of 4 or 5
• Most MIS on-line systems receive a score of 2
• Real-time, telecommunication, or process control systems receive a score of 0 to 5
• A score of 5 requires the use of performance analysis tools
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Heavily Used Configuration

Definition

Heavily Used Configuration describes the degree to which computer resource restrictions influenced the development
of the application.

A heavily used operational configuration may require special considerations when designing the application. For
example, the user wants to run the application on existing or committed equipment that will be heavily used.

Score

Score As Descriptions To Determine Degree of Influence

0 No explicit or implicit operational restrictions are included.

1 Operational restrictions do exist, but are less restrictive than a typical application. No special
effort is needed to meet the restrictions.

2 Stated operational restrictions require special constraints on one piece of the application in the
central processor or a dedicated processor.

3 Stated operational restrictions require special constraints on one piece of the application in the
central processor or a dedicated processor.

4 Stated operational restrictions require special constraints on the entire application in the central
processor or a dedicated processor.

5 In addition, there are special constraints on the application in the distributed components of the
system.

Hints

• GSCs 3, 4 and 5 are somewhat related.
• For this GSC think in terms of "How much does the infrastructure influence the design?"

Examples

Examples of operational restrictions may include the following (not an exhaustive list):

• This question indicates that the application must run on a computer that is under- powered and can not adequately
handle the new or changed functionality and that somehow the developers can overcome this by developing the
application differently.

• More than one application accessing the same data can create operational restrictions.
• Application competing for the same resource and technologies with the potential deadlocks must be tuned and

constrained to avoid performance degradation.

Typically

• Most applications receive a score of 2
• Client-server, web-enabled, real-time, telecommunication or process control systems receive a score of 3 to 5,

but then you would need either a dedicated processor or multiple processors processing the same transactions and
searching for the most expeditious means of processing.

Transaction Rate

Definition

Transaction Rate describes the degree to which the rate of business transactions influenced the development of the
application.
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The transaction rate is high, and it influences the design, development, installation, and support of the application.
Users may require what they regard as normal response time even during times of peak volume.

Score

Score As Descriptions To Determine Degree of Influence

0 No peak transaction period is anticipated.

1 Low transaction rates have minimal effect on the design, development, and installation phases.

2 Average transaction rates have some effect on the design, development, and installation phases.

3 High transaction rates affect the design, development, and/or installation phases.

4 High transaction rate(s) stated by the user in the application requirements or service level
agreements are high enough to require performance analysis tasks in the design, development,
and/or installation phases.

5 High transaction rate(s) stated by the user in the application requirements or service level
agreements are high enough to require performance analysis tasks and, in addition, require the
use of performance analysis tools in the design, development, and/or installation phases.

Hints

• GSCs 3, 4 and 5 are somewhat related. For this GSC think in terms of "How many transactions can be processed
by the application in a given period of time?"

• Often this score is the same as the score for GSC 3 because transaction rates often influence performance
requirements.

Typically

• Batch applications receive a score of 0 to 3
• On-line (including interactive client-server or web-enabled) applications receive a score of 0 to 4
• Real-time, telecommunication, or process control systems receive a score of 0 to 5
• A score of 5 requires the use of performance analysis tools

Online Data Entry

Definition

Online Data Entry describes the degree to which data is entered or retrieved through interactive transactions.

On-line User Interface for data entry, control functions, reports, and queries are provided in the application.

Score

Score As Descriptions To Determine Degree of Influence

0 All transactions are processed in batch mode.

1 1% to 7% of transactions are interactive.

2 8% to 15% of transactions are interactive.

3 16% to 23% of transactions are interactive.

4 24% to 30% of transactions are interactive.

5 More than 30% of transactions are interactive.
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Hints

• This refers to types of transactions not volumes.
• For example, if an application has 45 EIs, EOs, and EQs, what percent of the EIs, EOs, and EQs are accomplished

via on-line transactions.

Typically

• Batch applications receive a score of 0 to 1
• On-line, real-time, telecommunication, or process control systems receive a score of 5
• Most contemporary on-line (including interactive client-server or web-enabled) applications receive a score of 5
• Batch systems with on-line features may have a lot of batch transactions, but there must be at least 71 percent

batch to receive a score of less than 5.

End-User Efficiency

Definition

End-User Efficiency describes the degree of consideration for human factors and ease of use for the user of the
application measured.

The on-line functions provided emphasize a design for user efficiency (human factor/user friendliness). The design
includes:

• Navigational aids (e.g., function keys, jumps, dynamically generated menus, hyper-links)
• Menus
• On-line help and documents
• Automated cursor movement
• Scrolling
• Remote printing (via on-line transmissions)
• Pre-assigned function keys (e.g., clear screen, request help, clone screen)
• Batch jobs submitted from on-line transactions
• Drop down List box
• Heavy use of reverse video, highlighting, colors, underlining, and other indicators
• Hard-copy documentation of on-line transactions (e.g., screen print)
• Mouse interface
• Pop-up windows
• Templates and/or defaults
• Bilingual support (supports two languages: count as four items)
• Multi-lingual support (supports more than two languages: count as six items) January

Score

Score As Descriptions To Determine Degree of Influence

0 None of the above.

1 One to three of the above.

2 Four to five of the above.

3 Six or more of the above, but there are no specific user requirements related to efficiency.

4 Six or more of the above, and stated requirements for user efficiency are strong enough to require
design tasks for human factors to be included.

5 Six or more of the above, and stated requirements for user efficiency are strong enough to require
use of special tools and processes in order to demonstrate that the objectives have been achieved.
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Hints

• Use a convention of a score of 4 whenever the application is deployed in a GUI environment (unless it scores 5).
• Usually only software environments that prepare applications for mass-market or non-technical users score 5, and

only if they have ergonomics specialists and/or usability studies as part of their process.

Typically

• Pure batch applications receive a score of 0
• Character mode user interface receive a score of 1 or possibly a 2
• GUI user interface to be used for low volume transactions receive a score of 3
• GUI user interface to be used for high volume transactions and most Web Intranet user interfaces receive a score

of 4 (requires design tasks for human factors)
• Web Internet user interfaces receive a score of 5 (requires special tools and processes to demonstrate that the

objectives have been achieved)

Online Update

Definition

On-line Update describes the degree to which internal logical files are updated on-line.

The application provides on-line update for the internal logical files.

Score

Score As Descriptions To Determine Degree of Influence

0 None.

1 On-line update of one to three control files is included. Volume of updating is low and recovery
is easy.

2 On-line update of four or more control files is included. Volume of updating is low and recovery
is easy.

3 On-line update of major internal logical files is included.

4 In addition, protection against data loss is essential and has been specially designed and
programmed in the system.

5 In addition, high volumes bring cost considerations into the recovery process. Highly automated
recovery procedures with minimum human intervention are included.

Hints

• On-line update usually requires a keyed file or database.
• Automatic recovery provided by the operating system counts if it impacts the application.

Typically

• Pure batch applications receive a score of 0.
• On-line updates of files that modify the way an application processes or validates data receive a score of 1 or 2.
• On-line updates of user persistent data receive a score of 3.
• MIS applications receive a score of 3 or less.
• Most GUI type applications receive a score of 3 or above.
• Applications which use programmed recovery such as SQL roll back and commit receive a score of 4.

Operational/routine backup is not considered protection against data loss.
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• Applications required to recover data, reboot, or perform other self-contained functions in the event of a system
error receive a score of 5. Recovery may require a human to press enter or perform some other minimal function
to initiate this process.

Complex Processing

Definition

Complex processing describes the degree to which processing logic influenced the development of the application.
The following components are present:

• Sensitive control and/or application-specific security processing.
• Extensive logical processing
• Extensive mathematical processing
• Much exception processing, resulting in incomplete transactions that must be processed again.
• Complex processing to handle multiple input/output possibilities.

Score

Score As Descriptions To Determine Degree of Influence

0 None of the above.

1 Any one of the above.

2 Any two of the above.

3 Any three of the above.

4 Any four of the above.

5 All five of the above.

Hints

• Sensitive control or security process (e.g., individual users would have different access authority to screens where
they could view and/or change data) may include special audit processing (audit data would be captured whenever
data was viewed and/or changed and reported).

• Application-specific security processing may include internally developed security processing or use of purchased
security packages.

• Extensive logical processing is Boolean logic (use of ‘AND’, ‘OR’) of greater than average difficulty or a
minimum of 4 nested conditional (IF, CASE) statements. Extensive logical processing does not occur in most MIS
applications.

• Extensive mathematical processing is arithmetic that is beyond the capability of a 4-function calculator (add,
subtract, multiply, divide). This is usually not present in most MIS applications. However, an engineering
application may qualify.

• Exception processing includes incomplete ATM transactions caused by TP interruption, missing data values,
failed validations, or cycle redundancy checks which can be used to recreate lost pieces of data

• Multiple input/output possibilities include multi-media, device independence, voice, OCR reading, barcode
reading, retinal scanning, and Breathalyzer analysis.

Typically

Scoring is not platform dependent.
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Reusability

Definition

Reusability describes the degree to which the application and the code in the application have been specifically
designed, developed, and supported to be usable in other applications.

Score

Score As Descriptions To Determine Degree of Influence

0 No reusable code.

1 Reusable code is used within the application.

2 Less than 10% of the application code developed is intended for use in more than one application.

3 Ten percent (10%) or more of the application code developed is intended for use in more than
one application.

4 The application was specifically packaged and/or documented to ease reuse, and the application
is customized at the source code level.

5 The application was specifically packaged and/or documented to ease reuse, and the application
is customized for use by means of user parameter maintenance.

Hints

Hints for Rule 1

• A score of 1 is awarded for reusing code regardless of where it was developed.
• Code developed specifically for reuse within the application and used more than once within the application

counts as well as code retrieved from a central library and available for general use

Hints for Rule 2

• To score 2 or more, the code must be developed for use in more then one application, stored and managed in a
central library and be available for general use. Code from one application that is cut and pasted into another
application is not considered reuse.

• The reusable code would be supported by documentation that enables and eases the reuse.

Hints for Rule 5

• Examples of applications customized through use of parameters include PeopleSoft and SAP and would generally
receive a score of 5.

• Reused code may be slightly modified in the receiving application.
• Examples of reuse include objects or other static code maintained in an object/code library.

Typically

Scoring is not platform dependent.

Installation Ease

Definition

Installation Ease describes the degree to which conversion from previous environments influenced the development
of the application.
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Conversion and installation ease are characteristics of the application. A conversion and installation plan and/or
conversion tools were provided and tested during the system test phase.

Score

Score As Descriptions To Determine Degree of Influence

0 No special considerations were stated by the user, and no special setup is required for installation.

1 No special considerations were stated by the user, but special setup is required for installation.

2 Conversion and installation requirements were stated by the user, and conversion and installation
guides were provided and tested. The impact of conversion on the project is not considered to be
important.

3 Conversion and installation requirements were stated by the user, and conversion and installation
guides were provided and tested. The impact of conversion on the project is considered to be
important.

4 In addition to 2 above, automated conversion and installation tools were provided and tested.

5 In addition to 3 above, automated conversion and installation tools were provided and tested.

Hints

• Conversion and installation includes converting pre-existing data into new data files, loading files with actual
data, or developing special installation software, such as porting.

• Purchased or developed software must be used in order to take credit for installation and conversion.

Hint for Rule 1

• Most business applications require some special setup to install the application and receive a score of 1.

Hint for Rule 2

• If the application has conversion and installation requirements and installation guides were provided, and
providing these functions and guides were not on the critical path of the project, score a 2.

Hint for Rule 3

• If the application has conversion and installation requirements and installation guides were provided, and
providing these functions and guides were on the critical path of the project, score a 3.

Hint for Rules 4 and 5

• If the application has conversion and installation requirements and can be installed with no external intervention,
score a 4 or 5, depending on the other requirements for the scoring of 2 and 3

Typically

Scoring is not platform dependent.

Operational Ease

Definition

Operational Ease describes the degree to which the application attends to operational aspects, such as start-up, back-
up, and recovery processes.

Operational ease is a characteristic of the application. The application minimizes the need for manual activities, such
as tape mounts, paper handling, and direct on-location manual intervention.
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Score

Score As Descriptions To Determine Degree of Influence

0 No special operational considerations other than the normal back-up procedures were stated by
the user.

1 - 4 One, some, or all of the following items apply to the application. Select all that apply. Each item
has a point value of one, except as noted otherwise.

• Start-up, back-up, and recovery processes were provided, but human intervention is required.
• Start-up, back-up, and recovery processes were provided, but no human intervention is

required (count as two items)
• The application minimizes the need for tape mounts and/or remote data access requiring

human intervention
• The application minimizes the need for paper handling.

5 The application is designed for unattended operation. Unattended operation means no human
intervention is required to operate the system other than to start up or shut down the application.
Automatic error recovery is a feature of the application.

Hints

Hint to Rule 1-4a

• Application has the ability to perform start-up, back-up, and recovery; however, human response is required to
initiate the function.

Hint to Rule 1-4b

• Application has the ability to perform start-up, back-up, and recovery; and no human response is required to
initiate the function.

Hint to Rule 1-4c

• If the application has conversion and installation requirements and installation guides were provided, and
providing these functions and guides were on the critical path of the project, score a 3.

Hint for Rules 4 and 5

• The application minimizes the need to access data that is not immediately available.
• This may include importing data from a distributed processor to the local processor prior to execution to eliminate

access delays.

Hint to Rule 1-4d

• The application has been designed to provide the user with data in a condensed format or via a media other than
paper.

• This could include elimination of detailed printed information or access to on-line reports, inquiries, microfiche,
CD, or other such media.

Hint to Rule 5

• A score of 5 is assigned to an application that runs and recovers automatically from errors, on its own – an
unattended operation.

• Unattended operation may include unmanned satellite, nuclear reactor, or air traffic control.
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Typically

Scoring is not platform dependent.

Multiple Sites

Definition

Multiple Sites describes the degree to which the application has been developed for different hardware and software
environments.

Score

Score As Descriptions To Determine Degree of Influence

0 The needs of only one installation site were considered in the design.

1 The needs of more than one installation site were considered in the design, and the application is
designed to operate only under identical hardware and software environments.

2 The needs of more than one installation site were considered in the design, and the application is
designed to operate only under similar hardware and/or software environments.

3 The needs of more than one installation site were considered in the design, and the application is
designed to operate under different hardware and/or software environments

4 Documentation and support plan are provided and tested to support the application at multiple
installation sites and the application is as described by 2.

5 Documentation and support plan are provided and tested to support the application at multiple
installation sites and the application is as described by 3.

Hints

The term multiple sites is a logical term and is not necessarily physical. There can be multiple sites within the same
physical location. The determining factor is based upon the needs of the various installations.

Hints for Rule 0

• Most mainframe applications would probably score 0.
• However, if an application is installed on multiple mainframe computers with significantly different

configurations or different operating systems, it would receive a score of greater than 0.

Hints for Rule 1

• For example, Windows NT on hardware with exactly the same configuration.

Hints for Rule 2

• For example, Windows 95, 98 and NT on hardware with a similar configuration.
• Variations could include different memory sizes, various storage capability, different processor speeds, and

different printer types.

Hints for Rule 3

• For example, Windows, OS X, UNIX, Linux, and VOS3 on different types of hardware.
• Differences could include Intel based PC, MAC, Tandem, Sun, and AS400.

Typically

Scoring is dependent on the number of different platforms.
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Facilitate Change

Definition

Facilitate Change describes the degree to which the application has been developed for easy modification of
processing logic or data structure.

The following characteristics can apply for the application:

• Flexible Query

1. Flexible query and report facility is provided that can handle simple requests. (count as 1 item)
2. Flexible query and report facility is provided that can handle requests of average complexity. (count as 2

items)
3. Flexible query and report facility is provided that can handle complex requests. (count as 3 items)

• Business Control Data

1. Business control data is kept in tables that are maintained by the user with on-line interactive processes, but
changes take effect only on the next business cycle. (count as 1 item)

2. Business control data is kept in tables that are maintained by the user with on-line interactive processes, and
the changes take effect immediately. (count as 2 items)

Score

Score As Descriptions To Determine Degree of Influence

0 None of the above.

1 A total of one item from above.

2 A total of two items from above.

3 A total of three items from above.

4 A total of four items from above.

5 A total of five items from above.

Hints

Flexible Query and Reporting:

• A flexible query and reporting facility means more than a list of choices in a "canned" query or report.
• It is the ability of the user to control the data, data source, sequence and format of their query or report request.
• It means freedom to design screen layout, horizontal and vertical sorting, data item display formats, selection

criteria for both files and data items.
• It includes true user programming for inquiries and is sometimes referred to as ad hoc query or reporting
• Using filters which control the amount of data viewed or printed in a fixed format is not considered to be a

flexible query and report facility.
• Query and/or report writer capability is often provided by languages such as SQL or Focus or by some of the more

dynamic ad hoc reporting tools (e.g., Crystal Reports).

Hint for Rule A1

• Simple requests may include and/or logic applied to only one internal logical file.

Hint for Rule A2

• Requests of average complexity may include and/or logic applied to more than one internal logical file.
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Hint for Rule A3

• Complex requests may include and/or logic combinations on one or more internal logic files.

Business Control Data:

• Business Control Data (Reference Data) is stored to support the business rules for the maintenance of the Business
Data; e.g., in a payroll application it would be the data stored on the government tax rates for each wage scale and
the date the tax rate became effective.

• See Part 2, Code Data for additional information.

Typically

Scoring is not platform dependent.

History and IFPUG

This chapter provides a brief history of Function Points and describe IFPUG.

Brief History

Function Point Analysis was developed first by Allan J. Albrecht in the mid 1970s. It was an attempt to overcome
difficulties associated with lines of code as a measure of software size, and to assist in developing a mechanism to
predict effort associated with software development. The method was first published in 1979, then later in 1983. In
1984 Albrecht refined the method and since 1986, when the International Function Point User Group (IFPUG) was
set up, several versions of the Function Point Counting Practices Manual have been published by IFPUG.

Growth and Acceptance of Function Point Analysis

The acceptance of Function Point Analysis continues to grow. This is indicated by the growth of the International
Function Point User Group (IFPUG). Since 1987 membership in IFPUG has grown from 100 members to nearly 600
members in 1997. Additionally, in less than six years conference attendance has grown from 125 in 1988 to over 300
by 1997. Examination of IFPUG clearly indicates that the majority of its is members are from North America, but
Function Point analysis growth outside North America is strong. This is evident by the growing number of function
point organizations worldwide. There are numerous affiliate organizations of IFPUG. There are affiliate organizations
in Italy, France, Germany, Austria, India, The Netherlands, Australia, Japan, and several other countries.

The exercises at the end of the section help the student demonstrate that they have gained the basic knowledge
required.

More Information about IFPUG

More information about joining IFPUG, conferences, committees can be obtained by contacting the IFPUG.

Website: http://www.IFPUG.org

Calculating Adjusted Function Point

Describe the calculations necessary for determining the final Function Point Counts. The exercises at the end of the
section help the student demonstrate that they have gained the basic knowledge required.

Understanding the Equations

There are three sets of equations new projects (Development), existing projects (Baseline or Application) and for
enhancement projects. There are two equations for the enhancement projects. The first equation accounts for size of
the enhancement project while the second equation adjusts the size of the Application.

Forget About the Equations for a Minute

The equations can be very cumbersome and there are many variables. Forget about the exact equations for a moment.

When you develop a new application you need to know the entire size of the project. This means you would want to
include the number of function points of the application plus any other function points that need to be developed. For
example, you may need to develop a mini (temporary) application to assist with conversion efforts. So in the end, you

http://www.ifpug.org
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would have the number of function points for the application to be installed plus any other functions you needed to
develop.

When you have an enhancement project and you are going to modify an existing production application, you are
concerned about two things. The first thing is the size of the actual enhancement project. How many function points
is this project? The size of this project includes any added functionality, any changed functionality, and any deleted
functionality. Also in an enhancement project you may have other functionality needed that is not directly part of the
enhancement project.

Normally an enhancement project is the size of any (added functionality plus any changed functionality) x the value
adjustment factor. The value adjustment factor normally does not change; there is normally no conversion effort, so
on and so forth.

The second concern is how did the enhancement project change the actual production application. Is the existing
production application larger than before? And if it is larger by how much? This would be any added functionality.
Also you would want to know of any functionality that exist before and is larger after the enhancement.

In practice the size of the existing production application will be impacted by added functionality more. Many
organizations learn that existing application size does not change much, but they are changing existing functionality.

Definition

The final Function Point Count is obtained by multiplying the VAF times the Unadjusted Function Point (UAF). The
standard function point equation is:

FP = UAF * VAF

Where:

• UAF = Unadjusted Function Points
• VAF = Value Adjustment Factor

Unadjusted Function Point

Development Project Function Point Calculation

Use the following formula to calculate the development project function point count. Notice there is an additional
term CFP which is conversion function points. Often when a new application is replacing an old application, the
data must be converted. Sometimes a "mini application" needs to be developed to assist in the conversion. This
mini application does not exist after the new application is up and running. This is why development function point
calculation is different the application function point count (see next below).

DFP = (UFP + CFP) * VAF

Where:

• DFP is the development project function point count
• UFP is the unadjusted function point count
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• CFP is the function points added by the conversion unadjusted function point count
• VAF is the value adjustment factor

Application Function Point Count (Baseline)

Use the following formula to establish the initial function point count for an existing application. The user is
receiving functionality. There are no changes to the existing functionality or deletions of unneeded functionality. The
application function point count does not include conversion requirements.

AFP = ADD * VAF

Additionally, this equation is used to establish the function point count for an application at any point in time.

• AFP is the initial application function point count.
• ADD is the unadjusted function point count of those functions that were installed by the development project.

Since many enhancement projects (that were not counted) have been installed in the application, the ADD in this
case represents all functionality that exists within the application boundary at a particular point in time.

• VAF is the value adjustment factor of the application.

Enhancement Project Function Point Calculation

Use the following formula to calculating the size for enhancement projects.

EFP = [(ADD + CHGA + CFP) * VAFA] + (DEL* VAFB)

Where:

• EFP is the enhancement project function point count.
• ADD is the unadjusted function point count of those functions that were added by the enhancement project.
• CHGA is the unadjusted function point count of those functions that were modified by the enhancement project.

This number reflects the functions after the modifications.
• CFP is the function point count added by the conversion.
• VAFA is the value adjustment factor of the application after the enhancement project.
• DEL is the unadjusted function point count of those functions that were deleted by the enhancement project. It is

important to consider the absolute value of the DEL not the negative value.
• VAFB is the value adjustment factor of the application before the enhancement project.

In practice:

EFP = [(ADD + CHGA + CFP) * VAFA] + (DEL* VAFB)

In practice VAFA = VAFB = VAF, so the equation becomes

EFP = (ADD + CHGA + CFP+ DEL)* VAF)

Also normally CFP = 0, so the equation simplifies further

EFP = ((ADD + CHGA + DEL)* VAF)

Simplification of the equation

To examine the equation in detail let’s assume that VAFA = VAFB = 1 and CFP = 0. Hence EFP = (ADD + CHGA
+ DEL). That is, the size of an enhancement project is a summation of all added functionality, changed functionality
and any deleted functionality.

In theory and in practice, each piece of the formula must be adjusted by the appropriate Value Adjustment factor.
Assume now that VAFA <> VAFB. The added and changed after is adjusted by the VAFA, but the deleted is adjusted
by the VAFB. Additionally, if CFP <> 0 then it should be adjusted by VAFA.

Application After Enhancement Project

AFP = [(UFPB + ADD + CHGA) - (CHGB + DEL)] * VAFA

Where:

• UFPB = Unadjusted Function Point Count Before Enhancement.
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• AFP = Application Function Point Count
• DEL = is the number of function points deleted (the negative value).
• All other acronyms are the same as before.

Of course, an enhancement calculation can add and/or Delete functionality from the UFPB. Added functionality can
be due to new components or added functionality can be due to increase in size of existing components. For example,
an existing external input could go from a low to an average – valued at 3 to 4.

In Practice

Normally VAFA = VAFB = VAF, so the equation can be re-arranged

AFP = (UFPB+ADD + CHGA-CHGB – DEL)* VAF

Lets assume that CHGA = CHGB and DEL = 0.

Then AFP= (UFPB + ADD) * VAFA

NESMA Impacted Enhancement Function Points

The Netherlands Software Metrics Association (NESMA) has published guidelines on counting enhancement projects
that supplement the IFPUG guidelines. Full details of the NESMA Method can be found in FUNCTION POINT
ANALYSIS FOR SOFTWARE ENHANCEMENT GUIDELINES Version 2.2.1. The NESMA Method considers
the application of FPA to software enhancement from the perspective of the standard function point analysis method.
The result of this work, embodied in these guidelines, is a method applicable to software enhancement and testing that
is strongly related to the standard FPA method. The term Enhancement Function Point Analysis (EFPA) is used to
differentiate the method from the standard function point analysis method.

Methodology

Six steps are necessary for determining the size of the enhancement expressed in enhancement function points:

• Identify the transactional and data functions within the scope of the enhancement project and determine their
functional size.

• Determine which transactional and data functions are to be added.
• Determine which transactional and data functions are to be deleted.
• Determine which data functions are to be changed and determine the impact factor.
• Determine which transactional functions are to be changed and determine the impact factor.
• Calculate the number of Enhancement Function Points.

The analysis is primarily concerned with determining the FPA user functions which are added, modified or deleted.
For this part of the analysis Function Point Analysis (FPA) is used. The result is a summary of the impacted FPA user
functions with their functional size.

During enhancement, user transactions and logical data files can be added, modified or deleted. With regard to
deleted user transactions and logical data files, the number of function points before deletion is decisive; for added
and modified user transactions and logical data files, the number of function points after modification is decisive. The
impact of an enhancement may go beyond what is initially apparent from the enhancement proposal. For example, the
change of a logical file or transaction may impact other transactions or logical files.

After this, every impacted function needs to be carefully assessed to identify the extent of the impact of enhancement
on the function. The impact factor reflects the degree of change of each identified (data and transactional) function.

Finally, the enhancement size of each affected transactional and data function is calculated by multiplying its base
size by its impact factor. The enhancement size is measured in “Enhancement Function Points” (EFP), not standard
function points, which is a different measure. It is imperative to maintain the distinction between the standard
function point unit used to express the size of software (FP) and the unit used to express the size of an enhancement
(EFP). In the following chapters, the relationship between the original and the new unit of measure will be described.

Identify the functions within the scope of the enhancement project

The enhancement proposal, the functional documentation of the current system and the function point analysis of the
existing system are used to identify the transactional and data functions within the scope of the enhancement project.
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A function point analysis of the existing system is an essential prerequisite because all existing functions that are
affected either directly or indirectly by the enhancement contribute to the function point size of the enhancement. If,
for any reason, a function point analysis of the existing system is not available, one must be undertaken to identify, as
a minimum, the functions affected by the enhancement.

The size of the existing system, or that part impacted by the enhancement project, is expressed in standard function
points.

Determine which transactional and data functions will be added

The enhancement proposal should specify the transactional and data functions to be added to the application.
From the proposal it should be possible to calculate the size of the functions added by applying the standard FPA
methodology. The impact factor for added functions is 1.00.

Hence, the number of enhancement function points for a single added function is determined as follows:

EFP ADDED = FP ADDED

This means, for example, that 3 function points added will result in 3 enhancement function points.

Determine which transactional and data functions will be deleted

The (data and transactional) functions that will be deleted from the existing system are identified from the
enhancement proposal and the number of function points they represent is determined. For deleted functions an
impact factor of 0.40 is used. The number of enhancement function points for a single deleted function is determined
as follows:

EFP DELETED = FP DELETED x 0.40

This means, for example, that 6 function points deleted will result in 6 x 0.40 = 2.4 enhancement function points.

Determine which data functions will be modified and determine the impact factor

A data function can be either an internal logical file (ILF) or an external interface file (EIF). Each type of data
function is assessed to identify:

• data functions that change internally: DETs added, deleted or changed; and
• data functions that change type but do not change internally (that is, an EIF is changed into an ILF or vice versa).

Determine which data functions will change and how many function points each data function represents after the
change, applying the standard FPA rules.

For data functions that change internally an impact factor is calculated from the percentage of DETs changed. The
percentage change is defined as the ratio of DETs changed divided by the original number of DETs.

Percentage change = Number of DETs added/changed/deleted / Number of DETs in original data function * 100

The impact factor is taken from the table below using the percentage change in the number of DETs.

Percentage DETs <= 33.3% <= 66.6% <= 100.0% > 100.0%

Impact Factor 0.25 0.50 0.75 1.00

If a data function changes type (for example, an external interface file becomes an internal logical file), a value of
0.40 is used for the impact factor. However, in case of a change of type one needs to check if there is also an internal
change of the Logical File (change of DETs). If the number of DETs changes as well as the type, the impact factor
due to the change in the number of DETs must be determined. The value of the impact factor due to the change in
type is compared with that due to the change in the number of DETs and the higher value is used in the calculation of
the enhancement function point size.

The number of enhancement function points for a single changed data function is determined as follows:

EFP CHANGED = FP CHANGED x I CHANGED

The number of enhancement function points arising from a change in data functions therefore depends on the extent
of the change in the data function.
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If an EIF or an ILF is split into two (or more) data functions, one deleted data function and two (or more) added data
functions are counted.

If an EIF and an ILF are combined, two deleted data functions and one added data function are counted.

Determine which transactional functions will be modified and determine the impact factor

The transactional functions that change are identified and the size of each transaction after the change (the
enhancement) is determined.

A transactional function is considered changed if it is altered in some way but retains the same name and purpose
after enhancement as before enhancement. To determine the functional size of a transactional function after
the change the same counting guidelines are used as for new-built systems, applying the standard FPA rules. A
transactional function may be affected by changes to data functions. All transactional functions specified in the
enhancement proposal and those affected by changes to data functions are included in the scope of the analysis.

This means that a transaction is counted when at least one of the following conditions is satisfied:

• the transaction is identified in the enhancement proposal; or;
• the transaction undergoes a function change as a consequence of other changes defined in the enhancement

proposal.

In general, a transaction must be counted if the user can identify that the transaction has changed. This means that at
least one of the following criteria is met:

• a transaction is affected by a DET that is added, changed or deleted;
• a transaction is affected by a Logical Data File (ILF or EIF) that is added, changed or deleted;
• the user interface is functionally changed (for example, the composition of a screen or a report);
• the business logic supporting a transaction is changed (for example, edit rules or calculations performed on the

transaction data);
• a cosmetic change visible in the user interface is made, for example:

• static data is changed or moved in a report or other media,
• a heading is replaced or changed in a report or on a screen

A change to the name of a DET is not regarded as a change in a transaction. The nature of the DET does not change if
the name only is changed.

There are four steps to calculating the enhancement function point size of a change to a transaction:

1. Identify the DETs and FTRs used by the transaction.
2. Determine the percentages of DETs and FTRs changed as a result of the enhancement.
3. Determine the impact factor for the transaction.
4. Calculate the number of enhancement function points.

Identify the DETs and FTRs used by the transaction

The enhancement function point size of a changed transactional function is calculated from the function point size of
the function after the change and the change impact factor. The impact factor is determined by the percentage changes
in the numbers of DETs and FTRs used by the transaction.

If the change is cosmetic only, the number of changed DETs and FTRs is nil. The impact of such a change is
considered minimal and the value of the impact factor (0.25) reflects a relatively low impact. However, the change
will be included in the scope of the enhancement project.

Determine the percentage of DETs and FTRs changed as a result of the enhancement

The impact factor is determined by the percentage changes to the numbers of DETs and FTRs used by the transaction
compared with the original numbers of DETs and FTRs.

Percentage DETs = Number of DETs added/changed/deleted / Number of DETs in original transaction * 100

Percentage FTRs = Number of FTRs added/changed/deleted / Number of FTRs in original transaction * 100

Changes in excess of 100% are possible when DETs and FTRs are added to a transaction.



 | Function Point Modeler Workbench | 172

Calculate the enhancement function point size

The enhancement function point size of a single transactional function is calculated as follows:

EFP CHANGED = FP CHANGED x I CHANGED

Calculate the size of the enhancement project

The size of the enhancement project is the sum of the number of enhancement function points for all the affected
transactional and data functions.

EFP TOTAL = # EFP ADDED + # EFP DELETED + # EFP CHANGED

Calculate the size of the system after enhancement

The functional size of a system may change as a result of the enhancement. The size after enhancement can be
calculated by analysing the whole application anew or by taking account of the changes from the original FPA
analysis. Steps to take are:

1. Calculate the function point size of the application prior to the change (FP BASE ) using the standard FPA method.
2. Identify the transactional and data functions deleted from the existing application and determine their function

point size (# FP DELETED ).
3. Determine the transactional and data functions changed. Calculate the number of function points these represent

before and after the enhancement (# FP AFTER and # FP BEFORE ), using the standard FPA method.
4. Determine the transactional and data functions added to the system and calculate how many function points these

represent (# FP ADDED ).
5. Calculate the size of the system after enhancement (FP NEW ).

FP NEW = FP BASE + (# FP ADDED ) + (# FP AFTER-CHANGE - # FP BEFORE-CHANGE ) - (# FP DELETED )

Note: the Impact Factor does not play when determining the size of the system after enhancement.

Function Point Modeler Diagram Elements

Actor

An actor represents a role of a user that interacts with the system that you are modeling. The user can be a human
user, an organization, a machine, or another external system.

Application System

The Application System indicates the software being measured.

Subsystem

Subsystems are a type of stereotyped component that represent independent, behavioral units in a system. Subsystems
are used to represent large-scale components in the system that you are modeling. You can model an entire
application system as a hierarchy of subsystems.

Transactional Functions

Transactional functions represent the functionality provided to the user to process data. Transactional functions are
either external inputs, external outputs, or external inquiries.

• An external input (EI)  is an elementary process that processes data or control information that comes from
outside the applications boundary. The primary intent of an EI is to maintain one or more ILF s and/or to alter the
behavior of the system.

• An external output (EO) is an elementary process that sends data or control information outside the applications
boundary. The primary intent of an external output is to present information to a user through processing logic
other than or in addition to the retrieval of data or control information. The processing logic must contain at least
one mathematical formula or calculation, or create derived data. An external output may also maintain one or
more ILF s and/or alter the behavior of the system.



 | Function Point Modeler Workbench | 173

• An external inquiry (EQ) is an elementary process that sends data or control information outside the application
boundary. The primary intent of an external inquiry is to present information to a user through the retrieval of
data or control information. The processing logic contains no mathematical formula or calculation, and creates no
derived data. No ILF is maintained during the processing, nor is the behavior of the system altered.

Source: Function Point Counting Practices Manual , see the IFPUG web site at http://www.ifpug.org  for additional
information.

Data Functions

Data functions represent the functionality provided to the user to meet internal and external data requirements. Data
functions are either internal logical files or external interface files.

• An internal logical file (ILF) is a user identifiable group of logically related data or control information
maintained within the boundary of the application. The primary intent of an ILF is to hold data maintained
through one or more elementary processes of the application being counted.

• An external interface file (EIF) is a user identifiable group of logically related data or control information
referenced by the application, but maintained within the boundary of another application. The primary intent of an
EIF is to hold data referenced through one or more elementary processes within the boundary of the application
counted. This means an EIF counted for an application must be in an ILF in another application.

Source: Function Point Counting Practices Manual , see the IFPUG web site at http://www.ifpug.org  for additional
information.

Relations

A relationship is a connection between model elements. A Function Point Model relationship is a type of model
element that adds semantics to a Function Point Model by defining the structure and behavior between the model
elements.

Relation between Actor and Subsystem

A relationship between Actor and Subsystem is a type of model element that adds semantics to a Function Point
Model by defining the structure and behavior between a model element Actor and a model element Subsystem.

Relation between Subsystem and Subsystem

A relationship between Subsystem and Subsystem is a type of model element that adds semantics to a Function Point
Model by defining the structure and behavior between two model elements of the type Subsystem.

Relation between Transactional Function and Data Function

A relationship between Transactional Function and Data Function is a type of model element that adds semantics to
a Function Point Model by defining the structure and behavior between model elements Transactional Function and
Data Function.

Relation between Data Function and Data Function

A relationship between Data Function and Data Function is a type of model element that adds semantics to a Function
Point Model by defining the structure and behavior between two model elements of Type Data Function.

Note

A note is a non-FPM diagram element, which contains comments or textual information.

Notes can be added to indicate comments, observations or explanations on a particular diagram element. When
required, a single note can be added to multiple diagram elements.

Modeling with Function Point Modeler

Function Point Modeler Projects

You can create different project type with Function Point Modeler . This wizard helps you create a new project in
the Function Point Modeler .

http://www.ifpug.org
http://www.ifpug.org
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The most important of them for you is the Functionpoint Project . The Functionpoint Project contains three types
of projects.
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1. The Application Project is like a container for the Application Counts . This kind of project does not include
any project information except Project Name . You may create one Application Project for each Application
System one Application Project for an application domain that contains all Application Systems in this domain.

You can not make an estimation for the Application Project , becaus eit is nat real it-project.
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2. The second Functionpoint Project type is the IT-Development Project . Create IT-Development Project if you

have to count a New Development Project Count according IFPUG-CPM rules.

The IT-Development Project is a real it-project that contains all project relevant metrics. At the and of your
counting process you may estimate an IT-Development Project .
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3. The last Functionpoint Project type is the IT-Enhancement Project . Create IT-Enhancement Project if you

have to count a Enhancement Project Count according IFPUG-CPM rules.

The IT-Enhancement Project is also a real it-project that contains all project relevant metrics. At the and of your
counting process you may estimate an IT-Enhancement Project .
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Function Point Modeler Counts

You can create Application Count , Development Project Count or Enhancement Project Count with Function
Point Modeler . This tree types of counts are defined IFPU-CPM and are the IFPU-conform .
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1. You can create an Application Count without any real it-project. It is recommended that you can start with
Application Count to size all existing Application Systems in your company. Create an Application Project
before you create an Application Count .

Based on this Application Counts you can create the further Enhancement Project Count .
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2. The second count type is the Development Project Count . Create an IT-Development Project before you create

an Development Project Count .
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3. The last count type is the Enhancement Project Count . Create an IT-Development Project before you create

an Development Project Count .
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Projectdata and Cocomo Estimation

Function Point Modeler gives you insight into the key process, project and product metrics within your company.
The  Software Life Cycle Experience Database (SLED) is designed to meet the needs of a wide range of product,
process and project metrics. It delivers significant metrics about product, process, project and estimation (see the
following picture).

The  SLED model is easy to extend for customer requirements and contains the core business objects like Project, 
ProjectPlanData , ApplicationSystem , Count and Estimation . You can read more about each of this objects in the
following chapters.
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Software Life Cycle Experience Database (SLED)

Plandata and Estimation Overview

Project data called ProjectPlanData includes all project relevant information. You can create more than one
ProjectPlanData for a Project . Each of this ProjectPlanData represents a project plan scenario for the project.

For example one of the project plan scenario would be for the Rational Unified Process (RUP) and other for
waterfall or for the software development process specified for your company. A ProjectPlanData can include
one or more ProjectEstimation . Each ProjectEstimation represents an estimation scenario for the project. For
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example one of the ProjectEstimation may be with an expert team and other with a mixed team. One of this
ProjectEstimation has to be set as default for the project. It means, that the default ProjectEstimation is valid
estimation for the project.

One of this ProjectPlanData also has to be set as default . It means, that the default ProjectPlanData is valid for the
project. Only the default ProjectPlanData of the completed projects in Software Life Cycle Experience Database
(SLED) are used for the calibration and other metrics reports.

Plandata

You can create more than one ProjectPlanData for a Project . Each of this ProjectPlanData represents a
project plan scenario for the project. ProjectPlanData includes beside project relevant metrics the Counts ,
ProjectEstimations , ProcessVersions , ProjectActualData , ProjectInterruptions and UnestimatedEfforts .

One of this ProjectPlanData has to be set as default. It means, that the default Project Plan Data is valid for the
project. Only the default ProjectPlanData of the completed projects in Software Life Cycle Experience Database
(SLED) are used for the calibration and other metrics reports.

Project Plandata Element

You can create more than one ProjectPlanData for a Project . Each of this ProjectPlanData represents a
project plan scenario for the project. ProjectPlanData includes beside project relevant metrics the Counts ,
ProjectEstimations , ProcessVersion , ProjectActualData , ProjectInterruptions and Unestimated Efforts .

One of this ProjectPlanData has to be set as default . It means, that the default ProjectPlanData is the valid for the
project. Only the default ProjectPlanData of the completed projects in Software Life Cycle Experience Database
(SLED) are used for the calibration and other metrics reports.

 

 

Project
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Referenced Counts

A project can contain one or more Counts, which exists in the current project. You can add one or more Count to a
ProjectPlanData . Only the added counts can be considered for an estimation in this Project Plan Data.

Project Estimation

A ProjectPlanData can include one or more ProjectEstimation . Each of this ProjectEstimation represents
different estimation scenario for the project. For example one of the Project Estimation may be with an expert team
and other with a mixed team etc..

One of this ProjectEstimation has to be set as default for the project. It means, that the default ProjectEstimation
is the valid estimation for the project. An ProjectEstimation can contains one CocomoBase and one ore more
CocomoSub . The CocomoBase is the the sum of Sub Estimation, which also means total estimation of the project.
The Sub Estimation enable you to estimate each logical or technical sub systems of the counted application or
application of a project separately.

You can specify the Scale Factors in the Base Estimation for the whole project/application. You can also specify
the Cost Factors for each Sub System or Application in the Sub Estimation separately. This feature enables you to
estimate each sub system of an application or each application of the project precise and correctly.

For example: There are application A and application B to be developed in your project. Each of this application
will be developed by different team on the different platform with different language in the same project. There some
factor like scale factors has to be set for whole project. You can adjust this scale factors in the Base Estimation for
the whole project. You can also create two Sub Estimations for the application A and application B. In this two Sub
Estimation you can adjust the Cost Factors for each application system separately. Finally you have two separated sub
estimation for each application and a Base Estimation for whole project (application A + application B)

 

 

Project Plan Data
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Project Actual Data

A ProjectPlanData contain one ProjectActualData . The ProjectActualData contains the
ProjectPhaseActualData , ProjectInterruption and UnestimatedEffort some project relevant information like
fluctuation , endDate and etc. (see in the following picture).

The attribute hasDetail indicates whether the detailed ProjectActualData exist. If this attribute is set false , you can
record Project Actual Data for entirety project without any ProjectPhaseActualData (see in the following chapter).

ProjectActualData also contains ProjectInterruption and UnestimatedEffort (see in the following chapter).

 

 

Project Actual Data

Project Phase Data

A ProjectPhaseActualData represents all project relevant information of a phase of the used Software
Development Process. A ProjectActualData contain depend on the used Software Development Process several
ProjectPhaseActualData . A ProjectPhaseActualData contains one or more ProjectActivityActualData and some
project relevant information like fluctuation and endDate , etc. (see in the following picture).

The attribute hasDetail indicates whether the detailed ProjectActivityActualData exist. If this attribute is set false,
you can record ProjectPhaseActualData for current phase without any ProjectActivityActualData (see in the
following chapter).

ProjectPhaseActualData also contains ProjectInterruption and Defect (see in the following chapter).
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Project Phase Actual Data

Project Activity Data

A ProjectActivityActualData represents all project relevant information of an activity in the specified phase of the
used Software Development Process. A ProjectPhaseActualData contain depend on the used Software Development
Process several ProjectActivityActualData .

The ProjectActivityActualData contains the attribute effort and maxTeamNumber . (see in the following picture) is
the last leaf of Project Actual Data. .

 

 

Project Activity Actual Data

Project Interruption

A ProjectInterruption represents the interruptions during the project. The ProjectPlanData , ProjectActualData
and ProjectPhaseActualData can contain one or more ProjectInterruption .
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The ProjectInterruption contains the attribute reason , beginDate and endDate (see in the following picture).

 

 

Project Interruption

Unestimated Effort

An UnestimatedEffort represents the unestimated efforts in the project. The ProjectPlanData and
ProjectActualData can contain one or more UnestimatedEffort .

The UnestimatedEffort contains the attribute reason and effort (see in the following picture).

 

 

Unestimated Effort

Defect

A Defect represents the defects occured in the project. There are tree types of defect:

• Critical Defect
• Major Defect
• Minor Defect

The ProjectPhaseActualData can contain one or more Defect . This is the phase which caused the defect. We also
need the phases, in which the defect is identified and fixed phases for defect. This informations are very important to
improve the Software Development Process in your company

The Defect also contains the attribute defectRemovalEffort , etc. (see in the following picture).
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Defect

Cocomo

The CO nstructive CO st MO del COCOMO cost estimation model is used by thousands of software project
managers, and is based on a study of hundreds of software projects. Unlike other cost estimation models, COCOMO
is an open model, so all of the details are published, including:

• The underlying cost estimation equations
• Every assumption made in the model (e.g. "the project will enjoy good management")
• Every definition (e.g. the precise definition of the Product Design phase of a project)
• The costs included in an estimate are explicitly stated (e.g. project managers are included, secretaries aren't)

COCOMO II is the latest major extension to the original COCOMO (COCOMO 81) model published in 1981.
COCOMO consists of three submodels, each one offering increased fidelity the further along one is in the project
planning and design process. Listed in increasing fidelity, these submodels are called the Applications Composition,
Early Design, and Post-architecture models.

Introduction to the COCOMO Model:

The most fundamental calculation in the COCOMO model is the use of the Effort Equation to estimate the number
of Person-Months required to develop a project. Most of the other COCOMO results, including the estimates for
Requirements and Maintenance, are derived from this quantity. 

Source Lines of Code:

The COCOMO calculations are based on your estimates of a project's size in Source Lines of Code (SLOC) . SLOC
is defined such that:

• Only Source lines that are DELIVERED as part of the product are included -- test drivers and other support
software is excluded

• SOURCE lines are created by the project staff -- code created by applications generators is excluded
• One SLOC is one logical line of code
• Declarations are counted as SLOC
• Comments are not counted as SLOC

The major difference between DSI and SLOC is that a single Source Line of Code may be several physical lines.
For example, an "if-then-else" statement would be counted as one SLOC, but might be counted as several DSI .
The original COCOMO 81 model was defined in terms of Delivered Source Instructions, which are very similar to
SLOC .

The Scale Drivers:

In the COCOMO II model, some of the most important factors contributing to a project's duration and cost are the
Scale Drivers. You set each Scale Driver to describe your project; these Scale Drivers determine the exponent used in
the Effort Equation.

The 5 Scale Drivers are:

• Precedentedness
• Development Flexibility
• Architecture / Risk Resolution
• Team Cohesion
• Process Maturity

Note that the Scale Drivers have replaced the Development Mode of COCOMO 81 . The first two Scale Drivers,
Precedentedness and Development Flexibility actually describe much the same influences that the original
Development Mode did.



 | Function Point Modeler Workbench | 190

Cost Drivers:

COCOMO II has 17 cost drivers and you assess your project, development environment, and team to set each cost
driver. The cost drivers are multiplicative factors that determine the effort required to complete your software project.
For example, if your project will develop software that controls an airplane's flight, you would set the Required
Software Reliability (RELY) cost driver to Very High. That rating corresponds to an effort multiplier of 1.26,
meaning that your project will require 26% more effort than a typical software project. COCOMO II defines each of
the cost drivers, and the Effort Multiplier associated with each rating.

Personnel Factors:

• Analyst Capability
• Applications Experience
• Programmer Capability
• Personnel Continuity
• Platform Experience
• Language and Tool Experience

Product Factors:

• Required Software Reliability
• Database Size
• Software Product Complexity
• Required Reusability
• Documentation Match to Life-Cycle Needs

Platform Factors:

• Execution Time Constraint
• Main Storage Constraint
• Platform Volatility

Project Factors:

• Use of Software Tools
• Required Development Schedule
• Multisite Development

COCOMO II Effort Equation:

The COCOMO II model makes its estimates of required effort (measured in Person-Months PM ) based primarily on
your estimate of software project's size (as measured in thousands of SLOC, KSLOC )):

Effort = 2.94 * EAF * (KSLOC) E

Where:

• EAF Is the Effort Adjustment Factor derived from the Cost Drivers
• E Is an exponent derived from the five Scale Drivers

As an example, a project with all Nominal Cost Drivers and Scale Drivers would have an EAF of 1.00 and exponent,
E, of 1.0997. Assuming that the project is projected to consist of 8,000 source lines of code, COCOMO II estimates
that 28.9 Person-Months of effort is required to complete it:

Effort = 2.94 * (1.0) * (8) 1.0997 = 28.9 Person-Months

Effort Adjustment Factor:

The Effort Adjustment Factor in the effort equation is simply the product of the effort multipliers corresponding to
each of the cost drivers for your project.
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For example, if your project is rated Very High for Complexity (effort multiplier of 1.34), and Low for Language And
Tools Experience (effort multiplier of 1.09), and all of the other cost drivers are rated to be Nominal (effort multiplier
of 1.00), the EAF is the product of 1.34 and 1.09.

Effort Adjustment Factor = EAF = 1.34 * 1.09 = 1.46

Effort = 2.94 * (1.46) * (8) 1.0997 = 42.3 Person-Months

COCOMO II Schedule Equation:

The COCOMO II schedule equation predicts the number of months required to complete your software project. The
duration of a project is based on the effort predicted by the effort equation:

Duration = 3.67 * (Effort) SE

Where:

• Effort Is the effort from the COCOMO II effort equation
• SE Is the schedule equation exponent derived from the five Scale Drivers

Continuing the example, and substituting the exponent of 0.3179 that is calculated from the scale drivers, yields an
estimate of just over a year, and an average staffing of between 3 and 4 people:

Duration = 3.67 * (42.3) 0.3179 = 12.1 months

Average staffing = (42.3 Person-Months) / (12.1 Months) = 3.5 people

The SCED Cost Driver:

The COCOMO cost driver for Required Development Schedule (SCED) is unique, and requires a special
explanation.

The SCED cost driver is used to account for the observation that a project developed on an accelerated schedule will
require more effort than a project developed on its optimum schedule. A SCED rating of Very Low corresponds to an
Effort Multiplier of 1.43 (in the COCOMO II.2000 model) and means that you intend to finish your project in 75%
of the optimum schedule (as determined by a previous COCOMO estimate). Continuing the example used earlier,
but assuming that SCED has a rating of Very Low, COCOMO produces these estimates:

Duration = 75% * 12.1 Months = 9.1 Months

Effort Adjustment Factor = EAF = 1.34 * 1.09 * 1.43 = 2.09

Effort = 2.94 * (2.09) * (8) 1.0997 = 60.4 Person-Months

Average staffing = (60.4 Person-Months) / (9.1 Months) = 6.7 people

Notice that the calculation of duration isn't based directly on the effort (number of Person-Months) instead it's
based on the schedule that would have been required for the project assuming it had been developed on the nominal
schedule. Remember that the SCED cost driver means "accelerated from the nominal schedule".

Function Point Modeler And COCOMO:

Because COCOMO is well defined, and because it doesn't rely upon proprietary estimation algorithms, Function
Point Modeler supports COCOMO II Post Architecture and offers these advantages to its users :

• COCOMO estimates are more objective and repeatable than estimates made by methods relying on proprietary
models

• COCOMO can be calibrated to reflect your software development environment, and to produce more accurate
estimates

Function Point Modeler is a faithful implementation of the COCOMO model that is easy to use on small projects,
and yet powerful enough to plan and control very large projects.

Typically, you'll start with only a rough description of the software system that you'll be developing, and you'll use
Function point Modeler to give you early estimates about the proper schedule and staffing levels. As you refine your
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knowledge of the problem, and as you design more of the system, you can use Function Point Modeler to produce
more and more refined estimates.

Function Point Modeler allows you to define a software structure to meet your needs. Your initial estimate might
be made on the basis of a system containing 3,000 lines of code. Your second estimate might be more refined so that
you now understand that your system will consist of two subsystems (and you'll have a more accurate idea about how
many lines of code will be in each of the subsystems). Your next estimate will continue the process -- you can use
Function Point Modeler to define the sub estimation of each subsystem. Function Point Modeler permits you to
continue this process until you arrive at the level of detail that suits your needs.

Multiple Module Effort Estimation

Function Point Modeler allows you to define a software structure to meet your needs. Your project might consist of
several application systems with different platform or language or of one application system with several sub systems
(different platform or language). You want to estimate each application system or sub system separately.

Your initial estimate might be made on the basis of a application system. Your second estimate might made on the
basis of several application system system which will consist of several subsystems, etc. You can use Function Point
Modeler to define the sub estimation of each subsystem. Function Point Modeler permits you to continue this
process until you arrive at the level of detail that suits your needs.

You can use Function Point Modeler to define the sub estimation of each subsystem and to quantify each subsystem
separately by using COCOMO cost factor. You can also use Function Point Modeler to define some factors for
whole project by using COCOMO scale factor. Your project might contain two application systems, one of them
is system A based on the J2EE and other is system B based SAP . You have to estimate your project as a whole.
You can define the COCOMO cost factor in the CocomoBase estimation for whole project. You might create two
CocomoSub estimation for the system A and system B.

You'll define sub estimations, assign COCOMO cost factor values of each sub estimation, etc. The sum of the
CocomoSub estimations is the total project estimation.

Base Estimation

Function Point Modeler allows you to define several sub estimations for large a project. Your project might consist
of several application systems with different platform or language or of one application system with several sub
systems (different platform or language). You want to estimate each application system or sub system separately.

Base Estimation Overview

You might create ProjectEstimation which contains one ProjectEstimation . A ProjectEstimation contains only
one CocomoBase . You can also use CocomoBase to adjust some factors scale factor and the cost factor SCED for
whole project. A CocomoBase includes at least one or more CocomoSub estimation (see in the following picture).
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CocomoBase

Settings

You might adjust the following scale factors and cost factor.

Scale Factors adjusted for CocomoBase:

• PREC
• FLEX
• RESL
• TEAM
• PMAT

Cost Factor adjusted for CocomoBase:

• SCED
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CocomoBase Editor

Counts

You might assign Count to a CocomoSub but not to CocomoBase .

Scala Factors

The application size exponent is aggregated of five scale factors (SF) that describe relative economies or
diseconomies of scale that are encountered for software projects of dissimilar magnitude. A project exhibits
economies of scale if the exponent is less than one i.e. effort is non-linearly reduced. Economies and diseconomies of
scale are in balance should the exponent hold a value of one. A project exhibits diseconomies of scale if the exponent
is more than one i.e. effort is non-linearly increased.

Scala Factor PREC

If a product is similar to several previously developed projects, then the precedentedness is high.

Feature Very Low Nominal/High Extra High

Organizational
understanding of product
objectives

General Considerable Thorough

Experience in working with
related software systems

Moderate Considerable Extensive

Concurrent development of
associated new hardware and
operational procedures

Extensive Moderate Some

Need for innovative data
processing architectures,
algorithms

Considerable Some Minimal

Scale Factors for COCOMO.II Early Design and Post-Architecture Models
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PREC
Descriptors

thoroughly
unprecedented

largely
unprecedented

somewhat
unprecedented

generally
familiar

largely
familiar

thoroughly
familiar

Rating Levels Very Low Low Nominal High Very High Extra High

Value 6.20 4.96 3.72 2.48 1.24 0.00

Scala Factor FLEX

Feature Very Low Nominal/High Extra High

Need for software
conformance with
preestablished requirements

Full Considerable Basic

Need for software
conformance with external
interface specifications

Full Considerable Basic

Combination of
inflexibilities above
with premium on early
completion

High Medium Low

Scale Factors for COCOMO.II Early Design and Post-Architecture Models

FLEX
Descriptors

rigorous occasional
relaxation

some
relaxation

general
conformity

some
conformity

general goals

Rating Levels Very Low Low Nominal High Very High Extra High

Value 5.07 4.05 3.04 2.03 1.01 0.00

Scala Factor RESL

RESL combines two scale factors; "Design Thoroughness by Product Design Review (PDR)" and "Risk Elimination
by PDR". The next table combines these ratings factors to form a more comprehensive characterization for the
COCOMO II RESL ranking. It moreover narrates the ranking levels to the MBASE/RUP Life Cycle Architecture
(LCA) milestone above and beyond the waterfall PDR milestone. RESL ranking should be subjectively weighted in
order to average the outlined distinctiveness.

Feature Very Low Low Nominal High Very High Extra High

Risk Management
Plan identifies
all critical risk
items, establishes
milestones for
resolving them by
PDR or LCA.

None Little Some Generally Mostly Fully

Schedule, budget,
and internal
milestones
through PDR or
LCA compatible
with Risk
Management
Plan.

None Little Some Generally Mostly Fully
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Feature Very Low Low Nominal High Very High Extra High

Percent of
development
schedule devoted
to establishing
architecture,
given general
product
objectives.

5 10 17 25 33 40

Percent of
required top
software
architects
available to
project.

20 40 60 80 100 120

Tool support
available for
resolving risk
items, developing
and verifying
architectural
specs.

None Little Some Good Strong Full

Level of
uncertainty in
key architecture
drivers: mission,
user interface,
COTS, hardware,
technology,
performance.

Extreme Significant Considerable Some Little Very Little

Number and
criticality of risk
items.

> 10 Critical 5-10 Critical 2-4 Critical 1 Critical > 5 Non-
Critical

< 5 Non-
Critical

Scale Factors for COCOMO.II Early Design and Post-Architecture Models

RESL
Descriptors

little (20%) some (40%) often (60%) generally
(75%)

mostly (90%) full (100%)

Rating Levels Very Low Low Nominal High Very High Extra High

Value 7.07 5.65 4.24 2.83 1.41 0.00

Scala Factor TEAM

The scale factor for team cohesion accounts for sources of project instability and entropy for the reason that of
intricacy in synchronizing stakeholders of a project. Endusers, customers, developers, maintainers, interfacers, and
such are included in this category. Boehm construes that "these difficulties may arise from differences in stakeholder
objectives and cultures; difficulties in reconciling objectives; and stakeholders’ lack of experience and familiarity
in operating as a team". The following table outlines definitions for TEAM rating levels. TEAM ranking should be
subjectively weighted in order to average the outlined distinctiveness.
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Characteristic Very Low Low Nominal High Very High Extra High

Consistency
of stakeholder
objectives and
cultures

Little Some Basic Considerable Strong Full

Ability,
willingness of
stakeholders to
accommodate
other
stakeholders’
objectives

Little Some Basic Considerable Strong Full

Experience of
stakeholders in
operating as a
team

None Little Little Basic Considerable Extensive

Stakeholder
teambuilding to
achieve shared
vision and
commitments

None Little Little Basic Considerable Extensive

Scale Factors for COCOMO.II Early Design and Post-Architecture Models

TEAM
Descriptors

very difficult
interactions

some difficult
interactions

basically
cooperative
interactions

largely
cooperative

highly
cooperative

seamless
interactions

Rating Levels Very Low Low Nominal High Very High Extra High

Value 5.48 4.38 3.29 2.19 1.10 0.00

Scala Factor PMAT

The procedure for determining PMAT is organized around the Software Engineering Institute’s Capability Maturity
Model (CMM). The time period for rating Process Maturity is the time the project starts. There are two ways of rating
Process Maturity. The first captures the result of an organized evaluation based on the CMM.

Overall Maturity Level:

• CMM Level 1 (lower half)
• CMM Level 1 (upper half)
• CMM Level 2
• CMM Level 3
• CMM Level 4
• CMM Level 5

Scale Factors for COCOMO.II Early Design and Post-Architecture Models

PMAT
Descriptors

CMM Level 1
(lower half)

CMM Level 1
(upper half)

CMM Level 2 CMM Level 3 CMM Level 4 CMM Level 5

Rating Levels Very Low Low Nominal High Very High Extra High

Value 7.80 6.24 4.68 3.12 1.56 0.00

Project Cost Factor
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Project factors account for influences on the estimated effort such as use of modern software tools, location of the
development team, and compression of the project schedule.

Project Cost Factor SCED

The rating for SCED is defined in terms of the percentage of schedule stretch-out or acceleration with respect to a
nominal schedule for a project requiring a given amount of effort. The following table delineates that accelerated
schedules produces more effort in initializing phases in order to eliminate risks and refine the architecture, but more
effort in concluding processes to achieve more system tests and documentation. Stretch-outs in schedule are not
considered as adding to or decreasing the effort in developing software.

SCED
Descriptors

75% of
nominal

85% of
nominal

100% of
nominal

130% of
nominal

160% of
nominal

Rating Levels Very Low Low Nominal High Very High Extra High

Value 1.43 1.14 1.00 1.00 1.00 n/a

Custom Scale Factors

You may want to extend Scale Factors by defining your own custom scale factors.

 

 

Create Customer Scale Factor

Once you've created your own custom scale factor you can use it for your estimation.
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Use Customer Scale Factor

Cocomo Constants

To estimate the effort and development time, COCOMO use the equations with constants called coefficients (a, b, c,
d) .

You can calibrate this coefficients for different kind of project, domain or platform in your company. You may you
this calibrated coefficients for appropriate project.

Function Point Modeler enables you to use this calibrated coefficients for the estimation.

 

 

Sub Estimation

You can use Function Point Modeler to define the sub estimation of each subsystem and to quantify each subsystem
separately by using COCOMO cost factor. You can also use Function Point Modeler to define some factors for
whole project by using COCOMO scale factor. Your project might contain two application systems, one of them
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is system A based on the J2EE and other is system B based SAP . You have to estimate your project as a whole.
You can define the COCOMO cost factor in the CocomoBase estimation for whole project. You might create two
CocomoSub estimation for the system A and system B.

Sub Estimation Overview

You can use Function Point Modeler to define the sub estimation of each subsystem and to quantify each subsystem
separately by using COCOMO cost factor. You can also use Function Point Modeler to define some factors for
whole project by using COCOMO scale factor. Your project might contain two application systems, one of them
is system A based on the J2EE and other is system B based SAP . You have to estimate your project as a whole.
You can define the COCOMO cost factor in the CocomoBase estimation for whole project. You might create two
CocomoSub estimation for the system A and system B.

You'll define sub estimations, assign COCOMO cost factor values of each sub estimation, etc. The sum of the
CocomoSub estimations is the total project estimation.

 

 

CocomoBase

Settings

The Setting Section allows you to set counts, COCOMO cost factors and COCOMO constants.
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COCOMO settings section

Counts

You can select sub systems of a count for an sub estimation via the counts tree. You will see all counts added to the
current project plan data. You can not select a sub system twice in an estimation.

 

 

Counts tree

Info

You can edit the name of a sub estimation in the Info tab. You may also set Requirements Evolution and Volatility
REVL for this estimation. COCOMO II uses a factor called REVL , to adjust the effective size of the product
caused by requirements evolution and volatility, by such factors as mission or user interface evolution, technology
upgrades or COTS volatility. It is the percentage of code discarded due to requirements evolution.
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COCOMO info

You can also set the software type produced or maintenanced in this project. Default is the New Development
Software see in following section.

New developing software

The New developing software means that the software is implemented implemented from scratch. The New
Development Adjustment Factor is 1.0 in this case.

 

 

New developing software

Maintenanced software

The New developing software means the changes that have to be made to computer programs after they have been
delivered to the customer or user. It includes adding new capabilities and fixing or adapting existing capabilities.

Effective Maintenance Size = (Size Added + Size Modified) * MAF

Where:
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• Size Added The new functionalities added to software
• Size Modified The modified functionalities of software
• MAF Maintenance Adjustement Factor  MAF is used to adjust the effective maintenance size to account for

software understanding and unfamiliarity effect, as with reuse

MAF = AAF (1+ (SU * UNFM)) / 100

Where:

• MAF Maintenance Adjustement Factor
• AAF Adaption Adjustment Factor
• SU Software Understanding
• UNFM Programmer Unfamiliarity

 

 

Maintenanced software dialog

Adapted software

The existing code is treated as a white box and is modified for use with the product is called adapted software code .

Adapted code is preexisting code that has some changes to it, while reused code has no changes to the preexisting
code.

AAF = (0.4 * DM)+ (0,3 * CM)) + (0,3 * IM))

Where:

• AAF Adaption Adjustment factor
• DM Percentage of Design Modified
• CM Percentage of Code Modified
• IM Percentage of Integration Required for Adapted Software

AAM = (AA + AAF + (SU * UNFM))) / 100

Where:

• AAM Adaption Adjustment Modifier
• AA Assessment and Assimilation
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• AAF Adaption Adjustment factor
• SU Software Understanding
• UNFM Programmer Unfamiliarity

 

 

Adapted software dialog

Reused software

The existing code is treated as a black box and is not modified for use with the product is called reused software
code .

Adapted code is preexisting code that has some changes to it, while reused code has no changes to the preexisting
code.

AAM = (AA + (0,3 * IM))/100

Where:

• AAM Adaption Adjustment Modifier
• AA Assessment and Assimilation
• IM Percentage of Integration Required for Adapted Software
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Reused software dialog

Product Cost Factors

Product factors account for variation in the effort required to develop software caused by characteristics of the
product under development.

COCOMO II presupposes that a product that is complex also has high reliability requirements, or incorporates the use
of an outsized testing database and thus requires additional time for completion.

Product Cost Factor RELY

RELY is a measure to which degree the application must perform its projected function over a certain period of time.
Its rating schemes are explicated in the following table.

RELY
Descriptors

slight
inconvenience

low, easily
recoverable
losses

moderate,
easily
recoverable
losses

high financial
loss

risk to human
life

Rating Levels Very Low Low Nominal High Very High Extra High

Effort Multipliers 0.82 0.92 1.00 1.10 1.26 n/a

Product Cost Factor DATA

The DATA cost driver delineated in the following table captures the influence test data requirements have on program
development. Its rating is assessed by calculating the ratio of bytes in the testing database to SLOC in the program.
The basis for this cost driver is that database size is important for the reason that of the resources required for
generating test data.

DATA
Descriptors

Testing DB
bytes/Pgm
SLOC < 10

10 = D/P < 100 100 = D/P <
1000

D/P = 1000

Rating Levels Very Low Low Nominal High Very High Extra High

Effort Multipliers n/a 0.90 1.00 1.14 1.28 n/a
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Product Cost Factor CPLX

The Table (found at the end of this section) provides the new COCOMO II CPLX rating scale. Complexity is
divided into five areas: control operations, computational operations, device-dependent operations, data management
operations, and user interface management operations. Select the area or combination of areas that characterize the
product or a sub-system of the product.

Rating Levels Very Low Low Nominal High Very High Extra High

Effort Multipliers 0.73 0.87 1.00 1.17 1.34 1.74

The complexity rating is the subjective weighted average of the following areas.

Control
Operations

Computational
Operations

Device-
dependent
Operations

Data
Management
Operations

User Interface
Management
Operations

Very Low Straight-line code
with a few non-
nested structured
programming
operators:
DOs, CASEs,
IFTHENELSEs.
Simple module
composition via
procedure calls or
simple scripts.

Evaluation
of simple
expressions: e.g.,
A=B+C*(D-E)

Simple read, write
statements with
simple formats.

Simple arrays in
main memory.
Simple COTS-DB
queries, updates.

Simple input
forms, report
generators.

Low Straightforward
nesting of
structured
programming
operators. Mostly
simple predicates

Evaluation of
moderate-level
expressions: e.g.,
D=SQRT(B**2-
4.*A*C)

No cognizance
needed of
particular
processor or
I/O device
characteristics. I/
O done at GET/
PUT level.

Single file
subsetting with
no data structure
changes, no edits,
no intermediate
files. Moderately
complex COTS-
DB queries,
updates.

Use of simple
graphic user
interface (GUI)
builders.

Nominal Mostly simple
nesting. Some
intermodule
control. Decision
tables. Simple
callbacks or
message passing,
including
middleware-
supported
distributed
processing

Use of standard
math and
statistical
routines. Basic
matrix/vector
operations.

I/O processing
includes device
selection, status
checking and
error processing.

Multi-file input
and single
file output.
Simple structural
changes, simple
edits. Complex
COTS-DB
queries, updates.

Simple use of
widget set.

High Highly nested
structured
programming
operators with
many compound
predicates. Queue
and stack control.

Basic numerical
analysis:
multivariate
interpolation,
ordinary
differential
equations. Basic

Operations at
physical I/O
level (physical
storage address
translations;
seeks, reads, etc.).

Simple triggers
activated by data
stream contents.
Complex data
restructuring.

Widget set
development
and extension.
Simple voice I/O,
multimedia.
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Control
Operations

Computational
Operations

Device-
dependent
Operations

Data
Management
Operations

User Interface
Management
Operations

Homogeneous,
distributed
processing. Single
processor soft
real-time control.

truncation,
roundoff
concerns.

Optimized I/O
overlap.

Very High Reentrant
and recursive
coding. Fixed-
priority interrupt
handling. Task
synchronization,
complex
callbacks,
heterogeneous
distributed
processing.
Single-processor
hard real-time
control.

Difficult but
structured
numerical
analysis: near-
singular matrix
equations, partial
differential
equations. Simple
parallelization.

Routines
for interrupt
diagnosis,
servicing,
masking.
Communication
line handling.
Performance-
intensive
embedded
systems.

Distributed
database
coordination.
Complex
triggers. Search
optimization.

Moderately
complex
2D/3D, dynamic
graphics,
multimedia.

Extra High Multiple resource
scheduling with
dynamically
changing
priorities.
Microcode-
level control.
Distributed hard
real-time control.

Difficult and
unstructured
numerical
analysis:
highly accurate
analysis of
noisy, stochastic
data. Complex
parallelization.

Device timing-
dependent
coding, micro-
programmed
operations.
Performance-
critical embedded
systems.

Highly coupled,
dynamic
relational and
object structures.
Natural language
data management.

Complex
multimedia,
virtual reality.

Product Cost Factor RUSE

This cost driver accounts for the additional effort needed to construct components intended for reuse on current or
future projects.

• across project applies across the modules in a single financial applications project
• across project applies across the modules in a single financial applications project
• across program applies across multiple financial applications for one organization
• across product line applies across multiple organizations
• across multiple product lines applies across financial and marketing product lines

RUSE
Descriptors

none across project across
program

across product
line

across
multiple
product lines

Rating Levels Very Low Low Nominal High Very High Extra High

Effort Multipliers n/a 0.95 1.00 1.07 1.15 1.24

Product Cost Factor DOCU

COCOMO II specifies the rating scale for DOCU in the following table as evaluation in terms of the suitability of the
project’s documentation to its life-cycle needs.



 | Function Point Modeler Workbench | 208

DOCU
Descriptors

Many
lifecycle needs
uncovered

Some lifecycle
needs
uncovered

Rightsized
to life-cycle
needs

Excessive for
lifecycle needs

Very excessive
for lifecycle
needs

Rating Levels Very Low Low Nominal High Very High Extra High

Effort Multipliers 0.81 0.91 1.00 1.11 1.23 n/a

Project Cost Factors

Project factors account for influences on the estimated effort such as use of modern software tools, location of the
development team, and compression of the project schedule.

Project Cost Factor TOOL

TOOL incorporates the process of using CASE tools support for the development which reflects upon the capability,
maturity, and integration of them, see the following table.

TOOL
Descriptors

edit, code,
debug

simple,
frontend,
backend
CASE, little
integration

basic lifecycle
tools,
moderately
integrated

strong, mature
lifecycle tools,
moderately
integrated

strong,
mature,
proactive life-
cycle tools,
well integrated
with
processes,
methods,
reuse

Rating Levels Very Low Low Nominal High Very High Extra High

Value 1.17 1.09 1.00 0.90 0.78 n/a

Project Cost Factor SITE

Determining the SITE cost driver rating involves the assessment and judgementbased averaging of site collocation
and communication support as described in the following table.

Collocation
Descriptors

International Multicity and
Multicompany

Multicity or
Multicompany

Same city or
metro.area

Same building
or complex

Fully
collocated

Communications
Descriptors

Some phone,
mail

Individual
phone, FAX

Narrow band
email

Wideband
electronic
communication

Wideband
elect. comm.,
occasional
video conf.

Interactive
multimedia

Rating Levels Very Low Low Nominal High Very High Extra High

Value 1.22 1.09 1.00 0.93 0.86 0.80

Platform Cost Factors

The platform refers to the target-machine complexity of hardware and infrastructure software. Boehm considers
additional platform factors, e.g. distribution, parallelism, embeddedness, and real-time operations.

Platform Cost Factor TIME

The rating in the following table is expressed in terms of the percentage of available execution time expected to be
used by the system or subsystem consuming the execution time resource.
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TIME
Descriptors

= 50% use
of available
execution time

70% use of
available
execution time

85% use of
available
execution time

95% use of
available
execution time

Rating Levels Very Low Low Nominal High Very High Extra High

Value n/a n/a 1.00 1.11 1.29 1.63

Platform Cost Factor STOR

The following table specifies a rating that represents the degree of main storage constraint imposed on a software
system or subsystem.

STOR
Descriptors

= 50% use
of available
storage

70% use of
available
storage

85% use of
available
storage

95% use of
available
storage

Rating Levels Very Low Low Nominal High Very High Extra High

Value n/a n/a 1.00 1.05 1.17 1.46

Platform Cost Factor PVOL

PVOL implies the complexity of hardware and software products calls on to perform its tasks. The platform includes
any compilers or assemblers supporting the development of the software system. Development of e.g. software as OS
formulates the platform as the computer hardware. Development of e.g. database management system originates the
platform as hardware and OS. Network text browser development specifies the platform as the network, computer
hardware, the operating system, and the distributed information repositories.

PVOL
Descriptors

Major change
every 12 mo.;
Minor change
every 1 mo.

Major: 6 mo.;
Minor: 2 wk.

Major: 2 mo.;
Minor: 1 wk.

Major: 2 wk.;
Minor: 2 days

Rating Levels Very Low Low Nominal High Very High Extra High

Value n/a 0.87 1.00 1.15 1.30 n/a

Personnel Cost Factors

Personnel factors have the strongest affect on effort required to develop software compared to other cost drivers.
These ratings are most likely to change during the course of a project reflecting the gaining of experience or the
rotation of people onto and off the project. Personnel factors rank the development team’s capability and experience
but exclude the individual aspect.

Personnel Cost Factor ACAP

ACAP considers personnel who work on requirements, high-level design and detailed design hence, accompanying
attributes are analysis and design ability, efficiency and thoroughness, and the ability to communicate and cooperate.
The following table does not reflect on the level of experience of the analyst. APEX, LTEX, and PLEX are used in
the rating of this attribute.

ACAP
Descriptors

5th percentile 35th percentile 55th percentile 75th percentile 90th percentile

Rating Levels Very Low Low Nominal High Very High Extra High

Value 1.42 1.19 1.00 0.85 0.71 n/a

Personnel Cost Factor PCAP

Evaluating PCAP should be founded on the capability of the programmers as a team rather than as individuals hence,
associated factors ought to be ability, efficiency and thoroughness, and the ability to communicate and cooperate. The
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following table does not reflect on the level of experience of the programmer. APEX, LTEX, and PLEX are used in
the rating of this attribute.

PCAP
Descriptors

5th percentile 35th percentile 55th percentile 75th percentile 90th percentile

Rating Levels Very Low Low Nominal High Very High Extra High

Value 1.34 1.15 1.00 0.88 0.76 n/a

Personnel Cost Factor PCON

The rating scale for PCON depicted in the following table is in terms of the project’s annual personnel turnover.
Three percent (very high continuity) to 48 percent (very low continuity) are the limits for this cost driver.

PCON
Descriptors

48% / year 24% / year 12% / year 6% / year 3% / year

Rating Levels Very Low Low Nominal High Very High Extra High

Value 1.29 1.12 1.00 0.90 0.81 n/a

Personnel Cost Factor APEX

Ranking APEX is coupled with the level of applications experience of the project team developing the software
system or subsystem. The ratings in the following table are characterized in terms of the project team’s equivalent
level of experience with this kind of software system

APEX
Descriptors

<= 2 months 6 months 1 year 3 years 6 years

Rating Levels Very Low Low Nominal High Very High Extra High

Value 1.22 1.10 1.00 0.88 0.81 n/a

Personnel Cost Factor PLEX

PLEX recognizes the importance of understanding the utilization of more powerful platforms, including more graphic
user interface, database, networking, and distributed middleware capabilities.

PLEX
Descriptors

<= 2 months 6 months 1 year 3 years 6 years

Rating Levels Very Low Low Nominal High Very High Extra High

Value 1.19 1.09 1.00 0.91 0.85 n/a

Personnel Cost Factor LTEX

LTEX reflects upon software development that includes the utilization of CASE tools which perform requirements
and design representation and analysis, configuration management, document extraction, library management,
program style and formatting, consistency checking, planning and control.

PLEX
Descriptors

<= 2 months 6 months 1 year 3 years 6 years

Rating Levels Very Low Low Nominal High Very High Extra High

Value 1.20 1.09 1.00 0.91 0.84 n/a

Custom Cost Factors

You may want to extend Cost Factors by defining your own custom cost factors.



 | Function Point Modeler Workbench | 211

 

 

Create Customer Cost Factor

Once you've created your own custom cost factor you can use it for your estimation.

 

 

Use Customer Cost Factor

Cocomo Constants

To estimate the effort and development time, COCOMO use the equations with constants called coefficients (a, b, c,
d) .

You can calibrate this coefficients for different kind of project, domain or platform in your company. You may you
this calibrated coefficients for appropriate project.

Function Point Modeler enables you to use this calibrated coefficients for the estimation.
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Reporting and Statistics

Function Point Modeler provides you some standard reports and statistics beside Function Point Modeler Report
Designer

Project Estimation Report

You can create a project estimation report as PDF file. This report contains all relevant informations and settings of
the current estimation.

You can quickly navigate you estimation structure in the three on the left side to see selected information.

This estimation report is suitable for the project manager.
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Development Process Statistic

Function Point Modeler provides you detail standard reports and statistics about the effort distributions regarding
selected Software Development Process .

Development Process Statistic shows you the effort distributions of each phase of selected Software Development
Process and the effort distributions of activities of each phase of selected Software Development Process

In the following you see the so called percent distribution :

 

 

In the next picture you see the so called effort distribution of the same estimation above:
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Development Process Phase Statistic

Function Point Modeler provides you detail standard reports and statistics about the effort distributions of each
phase of the selected Software Development Process .

Development Process Phase Statistic shows you the effort distributions of each phase of selected Software
Development Process .

In the following you see the activity distributions of the inception phase :
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Development Process Activity Statistic

Function Point Modeler provides you detail standard reports and statistics about the effort distributions of each
phase of the selected Software Development Process .

Development Process Activity Statistic shows you the effort distributions of each activity for the phases of selected
Software Development Process .

In the following you see the activity effort distributions of the Management activity for all phases :
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Staffing Statistic

Function Point Modeler provides you detail standard reports and statistics about the effort distributions of each
phase of the selected Software Development Process .

Staffing Statistic shows you the staffing distributions of each phase of selected Software Development Process .

In the following you see the staffing distributions for all phases :
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Application System Lifecycle

Function Point Modeler also manages the lifecycle of the Elementary Processes, Logical Files, Sub Systems
and Application Systems. Each of this has its unique key. This unique key enables us to track the lifecycle of this
components from the beginning (creation or development time ) to the end (deletion or end-of-life ). You are able to
track the functional growing of your application system as well as its cost during its life.

In the following you see detail lifecycle of a selected Application System :

 

 

In the following you see quick lifecycle of a selected Application System :
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Software Lifecycle Empirical / Experience Database

Function Point Modeler Enterprise enables you to set up a Software Life Cycle Experience Database (SLED) in
your company without any effort, since the data model of the SLED is the same model of the objects in the Function
Point Modeler.

SLED enables you insight into the key process, project and product metrics within your company. The Metrics
Database SLED is designed to meet the needs of a wide range of product, process and project metrics. It delivers
significant metrics about product, process and project.

data model does not meet the requirements in your company or you have other metrics in your company. Function
Point Modeler architecture will make it easy for you to customize you company data to the Metrics Database SLED .

In the following you see SLED data model :
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Sharing Projects in Teams

Function Point Modeler allows synchronization of workspace resources with a versioning and configuration
management repository (e.g. CVS, SVN). The CVS and SVN are known as centralised version control systems 
(CVCS) .

A versioning and configuration management repository allows synchronization of workspace resources with a remote
location to share projects file in your counting team. At a minimum it allows pushing resources in the workspace to a
remote location and pulling resources from a remote location into the workspace.

Standard Reporting

Cocomo Masterdata

Function Point Modeler allows you to customize the following Cocomo settings.

In the following you see the Cocomo Masterdata :

 

 

Cocomo Constant

Function Point Modeler allows you to customize or calibrate the Cocomo constants A and B that are used for the
calculation of the estimation

You may use this customized or calibrated constants in any Cocomo estimation.

You may set the constants A and B yourself without any calibration process. In this case you have to deselect check
button calibrate from SLED .
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In the following you see the Cocomo Constant setting dialog :

 

 

You may also set the constants A and B from the result of a calibration process.

In the following you see the Cocomo Constant setting dialog with a calibration :
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Scale Factor

Function Point Modeler allows you to customize the Scale Factors . The attribute Used means whether it is used for
the Cocomo calculation or not.

It is recommended that first of all you collect the complexities of your customized Scale Factors before you use it in
the Cocomo calculation.

In the following you see the Scale Factor setting dialog :

 

 

Cost Factor

Function Point Modeler allows you to customize the Cost Factors . The attribute Used means whether it is used for
the Cocomo calculation or not.

A Cost Factors can also consist of so called Sub Cost Factors . The sum of settings of Sub Cost Factors will be
used for the parent Cost Factors .

It is recommended that first of all you collect the complexities of your customized Cost Factors before you use it in
the Cocomo calculation.

In the following you see the Cost Factor setting dialog :
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Gearing Factor

Function Point Modeler allows you to customize the Gearing Factors for the languages.

What is a gearing factor?

The gearing factor is simply the average number of Source Lines of Code (SLOC) per function point in the
completed project. It is calculated by dividing the final code count for a completed project by the final function point
count. (SLOC) counts are logical, not physical line counts.

In the following you see the Gearing Factor setting dialog :
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Architecture Type

Function Point Modeler allows you to customize the Architecture Type .

The following default Architecture Types are defined:

• One-tier
• Two-tiers
• Three-tiers
• N-tiers
• Other

In the following you see the Architecture Type setting dialog :
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Platform Type

Function Point Modeler allows you to customize the Platform Type .

The following default Platform Types are defined:

• Mixed
• Host
• J2EE
• .Net
• SAP
• DWH
• Other

In the following you see the Platform Type setting dialog :
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Project Type

Function Point Modeler allows you to customize the Project Type .

The following default Project Types are defined:

• Application Project
• Integration Project
• Migration Project

In the following you see the Project Type setting dialog :
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Estimation Type

Function Point Modeler allows you to customize the Estimation Type .

The following default Estimation Types are defined:

• Project Begin
• During Project
• Project End

In the following you see the Estimation Type setting dialog :
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External Work Type

Function Point Modeler allows you to customize the External Work Type .

The following default External Work Types are defined:

• Unknown
• Project management
• Implementation

In the following you see the External Work Type setting dialog :
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Unestimated Effort Reason

Function Point Modeler allows you to customize the Unestimated Effort Reason .

The following default Unestimated Effort Reason are defined:

• Unknown
• External Effort
• Training

In the following you see the Unestimated Effort Reason setting dialog :
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Development Process

Function Point Modeler Enterprise Edition allows you to manage the software development process in your
company.

Function Point Modeler Enterprise Edition provides default Rational Unified Process (RUP) and Waterfall.
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You may also create your own software development process specified for your company. The new created software
development process must extend either the Rational Unified Process or Waterfall.
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You can also define the phases and activities of this new software development process.
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You can also change the estimation distribution for each phase or activity.
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The estimation is now distributed based on the new defined software development process.
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Diagram Customization

Function Point Modeler allows you to customize the appearance and behavior of digrams in many ways. It is
possible, to set the following settings to your own needs and desires:

• Global Settings
• Diagram Appearance
• Connection Styles
• Copy/Paste Behaviour
• Diagram Layout Style
• Diagram Pathmaps
• Diagram Printing Options
• Rulers and Grid Settings

For some of these settings, it is necessary to close an already opened diagram editor and reopen it. An example are the
setting for the layout style. This works only if an editor is reopened.

Product License

Function Point Modeler is available in two different versions.

The Standard Edition of Function Point Modeler ist free, i.e. it can be used for all personal and business purposes
without restrictions. This version enables accurate development project counting, enhancement project counting and
application counting using IFPUG 4.2 and 4.3 function point analysis. The Enterprise Edition differs from Standard
Edition in that it includes a Software Life Cycle Experience Database (SLED) and supports UML Export / Import and
many other useful features.

To get the full extent of the Enterprise Edition a registration is required, see also www.functionpointmodeler.com .

ditafilesconceptswww.functionpointmodeler.com
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After successful registration you will receive a license key, with which you can unlock the full range of features in
Enterprise Edition.

Understand Project Logging

Function Point Modeler offers a special view, which allows you to analyze and to consider the internal workings of
the application. Internally, the Function Point Modeler makes use of the famous logging framework Log4J . You
can analyze the messages, which will be created by this framework, in a simple manner with the help of the provided
view.

Tasks

Working with Diagram Elements

You can perform the following tasks to use Working with Diagram Elements .

Actor

You can perform the following tasks to use Actor .
Create a new Actor

To create a new Actor in a Count, perform the following steps.

1. Click on the Actor entry in the editor palette.
 

 

2. Move your mouse pointer to a free area in the editor and perform a mouse click. Please keep in mind, you can not
place an Actor element as part of another diagram element. The mouse pointer will show you, if an insert action
on the given diagram position is possible.
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3. Enter a name for your new Actor element.
 

 

4. An alternative way to create a new Actor features the diagram editor select mode.
 

 

5. Move your mouse pointer to a free area in the editor. Please keep in mind, you can not place an Actor element as
part of another diagram element. A popup window will be displayed.
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6. Click on the Actor element
 

 

7. Enter a name for your new Actor element.
 

 

Delete an existing Actor

To delete an existing Actor in a Count, perform the following steps.

1. Move your mouse pointer to an Actor element in the editor area and perform a right mouse click.
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2. Select the menu item Delete from model .
 

 

3. An alternative way to delete an existing Actor is described in the following steps.

4. Move your mouse pointer to an Actor element in the diagram editor and perform a mouse click to select this
element.
 

 

5. Press DEL on your keyboard.

Change Actor Properties

After you create an Actor , you can edit its various properties, such as its name, etc.

To change the properties of Actor , perform the following steps.

1. Move your mouse pointer to an Actor element in the editor area and perform a right mouse click.
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2. Select the menu item Show Properties View .
 

 

3. The following Properties View will be showed. .
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4. Enter a name for your Actor element.
 

 

5. Click Enter to change the properties.
 

 

Create or Modify an Actor Relation

The palette of a graphical editor provides tools to create connections in the diagram. There are different types of
connections available in the palette:

This tool lets the user create a connection between Actors and Sub System by starting the connection on a source
object (Actor) dropping it on a target object (Sub System)s.

1. Click on the Actor -> Subsystem  entry in the editor palette.
 



 | Function Point Modeler Workbench | 242

 

2. Move your mouse pointer to an Actor in the editor and perform a mouse click and drag and drop the connection
from the Actor to target Sub System .
 

 

3. An alternative way to create a connection is described in the following steps.

4. Move your mouse pointer to an Actor in the editor. A popup window will be displayed. Click on the out going
arrow and drag and drop the connection from the Actor to target Sub System .
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Application System

You can perform the following tasks to use Application System .
Create a new Application System

To create a new Application System in a Count, perform the following steps.

1. Click on the Application System entry in the editor palette.
 

 

2. Move your mouse pointer to a free area in the editor and perform a mouse click. Please keep in mind, you can not
place a Application System element as part of another diagram element. The mouse pointer will show you, if an
insert action on the given diagram position is possible.
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3. Enter a name for your new Application System element.
 

 

4. An alternative way to create a new Application System features the diagram editor select mode.
 

 

5. Move your mouse pointer to a free area in the editor. Please keep in mind, you can not place a Application System
element as part of another diagram element. A popup window will be displayed.
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6. Click on the Application System element
 

 

7. Enter a name for your new Application System element.
 

 

Delete an existing Application System

To delete an existing Application System in a Count, perform the following steps.

1. Move your mouse pointer to an Application System element in the editor area and perform a right mouse click.
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2. Select the menu item Delete from model .
 

 

3. An alternative way to delete an existing Application System is described in the following steps.

4. Move your mouse pointer to an Application System element in the diagram editor and perform a mouse click to
select this element.
 

 

5. Press DEL on your keyboard.

Change Application System Properties

After you create an Application System , you can edit its various properties, such as its name, platform type etc.

To change the properties of Application System , perform the following steps.

1. Move your mouse pointer to an Application System element in the editor area and perform a right mouse click.
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2. Select the menu item Show Properties View .
 

 

3. The following Properties View will be showed. .
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4. Enter a name for your Application System element.
 

 

5. Click Enter to change the properties.
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Subsystem

You can perform the following tasks to use Subsystem .
Create a new Subsystem

To create a new Sub System in a Count, perform the following steps.

1. Click on the Sub System entry in the editor palette.
 

 

2. Move your mouse pointer to the Subsystem section of an Application System in the editor and perform a mouse
click. Please keep in mind, you can place a Sub System element as part of Application System diagram element.
The mouse pointer will show you, if an insert action on the given diagram position is possible.
 

 

3. Enter a name for your new Sub System element.
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4. An alternative way to create a new Sub System features the diagram editor select mode.
 

 

5. Move your mouse pointer to the Subsystem section of an Application System in the editor. Please keep in mind,
you can place a Sub System element as part of Application System diagram element. A popup window will be
displayed.
 

 

6. Click on the Application System element
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7. Enter a name for your new Sub System element.
 

 

Delete an existing Subsystem

To delete an existing Sub System in a Count, perform the following steps.

1. Move your mouse pointer to a Sub System element in the editor area and perform a right mouse click.
 

 

2. Select the menu item Delete from model .
 

 

3. An alternative way to delete an existing Sub System is described in the following steps.

4. Move your mouse pointer to a Sub System element in the diagram editor and perform a mouse click to select this
element.
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5. Press DEL on your keyboard.

Change Subsystem Properties

After you create a Subsystem System , you can edit its various properties, such as its name, platform type etc.

To change the properties of Subsystem System , perform the following steps.

1. Move your mouse pointer to an Subsystem System element in the editor area and perform a right mouse click.
 

 

2. Select the menu item Show Properties View .
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3. The following Properties View will be showed.
 

 

4. Enter a name for your Sub System element.
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5. Click Enter to change the properties.
 

 

Create or Modify a Subsystem Relation

The palette of a graphical editor provides tools to create connections in the diagram. There are different types of
connections available in the palette:

This tool lets the user create a connection between Actors and Sub System by starting the connection on a source
object (Actor) dropping it on a target object (Sub System).

1. Click on the Actor -> Subsystem  entry in the editor palette.
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2. Move your mouse pointer to an Actor in the editor and perform a mouse click and drag and drop the connection
from the Actor to target Sub System .
 

 

3. An alternative way to create a connection is described in the following steps.

4. Move your mouse pointer to an Actor in the editor. A popup window will be displayed. Click on the out going
arrow and drag and drop the connection from the Actor to target Sub System .
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Transactional Function

You can perform the following tasks to use Transactional Function .
Create a new Transactional Function

To create a new Transactional Function in a Count, perform the following steps.

1. Click on the Transactional Function entry in the editor palette.
 

 

2. Move your mouse pointer to the Transactional Functions section of an Sub System in the editor and perform a
mouse click. The mouse pointer will show you, if an insert action on the given diagram position is possible.
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3. Enter a name for your new Transactional Function element.
 

 

4. An alternative way to create a new Transactional Functions features the diagram editor select mode.
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5. Move your mouse pointer to the Transactional Functions section of an Sub System in the editor. A popup window
will be displayed.
 

 

6. Enter a name for your new Transactional Functions element.
 

 

Delete an existing Transactional Function

To delete an existing Transactional Function in a Count, perform the following steps.

1. Move your mouse pointer to a Transactional Function element in the editor area and perform a right mouse
click.
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2. Select the menu item Delete from model .
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3. An alternative way to delete an existing Transactional Function is described in the following steps.

4. Move your mouse pointer to a Transactional Function element in the diagram editor and perform a mouse click
to select this element.
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5. Press DEL on your keyboard.

Change Transactional Function Properties

After you create a Transactional Function , you can edit its various properties, such as its enhancement type, process
type etc.

To change the properties of Transactional Function , perform the following steps.

1. Move your mouse pointer to an Transactional Function element in the editor area and perform a right mouse
click.
 

 

2. Select the menu item Show Properties View .
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3. The following Properties View will be showed. Click on the green arrow button.
 

 

4. The following Properties Dialog will be showed. Once you have changed the properties click on the button Ok
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Create or Modify a Transactional Function Relation

The palette of a graphical editor provides tools to create connections in the diagram. There are different types of
connections available in the palette:

This tool also lets the user create a connection between Transactional Function and Data Function by starting the
connection on a source object (Transactional Function) dropping it on a target object (Data Function).

1. Click on the Transactional Function -> Data Function  entry in the editor palette.
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2. Move your mouse pointer to an Transactional Function in the editor and perform a mouse click and drag and
drop the connection from the Transactional Function to target Data Function .
 

 

3. An alternative way to create a connection is described in the following steps.

4. Move your mouse pointer to an Transactional Function in the editor. A popup window will be displayed.
Click on the out going arrow and drag and drop the connection from the Transactional Function to target Data
Function .



 | Function Point Modeler Workbench | 265

 

 

Data Function

You can perform the following tasks to use Data Function .
Create a new Data Function

To create a new Data Function in a Count, perform the following steps.

1. Click on the Data Function entry in the editor palette.
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2. Move your mouse pointer to the Data Functions section of an Sub System in the editor and perform a mouse click.
The mouse pointer will show you, if an insert action on the given diagram position is possible.
 

 

3. Enter a name for your new Data Function element.
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4. An alternative way to create a new Data System features the diagram editor select mode.
 

 

5. Move your mouse pointer to the Data Functions section of an Sub System in the editor. A popup window will be
displayed.
 

 

6. Enter a name for your new Data Functions element.
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Delete an existing Data Function

To delete an existing Data Function in a Count, perform the following steps.

1. Move your mouse pointer to a Data Function element in the editor area and perform a right mouse click.
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2. Select the menu item Delete from model .
 

 

3. An alternative way to delete an existing Data Function is described in the following steps.

4. Move your mouse pointer to a Data Function element in the diagram editor and perform a mouse click to select
this element.
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5. Press DEL on your keyboard.

Change Data Function Properties

After you create a Data Function , you can edit its various properties, such as its enhancement type, process type etc.

To change the properties of Data Function , perform the following steps.

1. Move your mouse pointer to an Data Function element in the editor area and perform a right mouse click.
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2. Select the menu item Show Properties View .
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3. The following Properties View will be showed. Click on the green arrow button.
 

 

4. The following Properties Dialog will be showed. Once you have changed the properties click on the button Ok
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Create or Modify a Data Function Relation

The palette of a graphical editor provides tools to create connections in the diagram. There are different types of
connections available in the palette:

This tool also lets the user create a connection between Transactional Function and Data Function by starting the
connection on a source object (Transactional Function) dropping it on a target object (Data Function).

1. Click on the Transactional Function -> Data Function  entry in the editor palette.
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2. Move your mouse pointer to an Transactional Function in the editor and perform a mouse click and drag and
drop the connection from the Transactional Function to target Data Function .
 

 

3. An alternative way to create a connection is described in the following steps.

4. Move your mouse pointer to an Data Function in the editor. A popup window will be displayed. Click on the in
going arrow and drag and drop the connection from the Data Function to target Transactional Function .
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Adding notes to units

You can add a note to a unit to comment on it or describe it. The note does not affect the function of the topology
elements.

To create a note, click Note or Text in the Palette and use the mouse to drag a rectangle that represents the note on the
diagram. For attached notes, click Note Attachment and then click the unit or link to which the note will be attached.
Then, type the text for the note.

You can add three types of notes to a diagram:

1. Unattached notes: Unattached notes are displayed as colored text boxes on the diagram into which you can type
text.

2. Note attachments : Note attachments are linked to one or more units or links. Like the notes, these links have no
meaning in the topology except to indicate to which unit or link the note text applies.

3. Text boxes : Text boxes are similar to unattached notes, but they have no background color.
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Working with Projects and Counts

Create a Application Project

To create a new Application Project , perform the following steps.

1. From the main menu bar, select File > New > Project .
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2. The following Creat wizard will be displayed
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3. Select the Function Point Modeler > Functionpoint Project and click  Next .

4. Enter a project name and click  Next .
 



 | Function Point Modeler Workbench | 279

 

5. Click Finish .
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The new created Application Project will be displayed in the project explorer

 



 | Function Point Modeler Workbench | 281

 

Create a Development Project

To create a new Development Project , perform the following steps.

1. From the main menu bar, select File > New > Project .
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2. The following Creat wizard will be displayed
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3. Select the Function Point Modeler > Functionpoint Project and click  Next .

4. Enter a project name and click  Next .
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5. Enter the required field and click Finish .
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The new created Development Project will be displayed in the project explorer
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Create a Enhancement Project

To create a new Enhancement Project , perform the following steps.

1. From the main menu bar, select File > New > Project .
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2. The following Create wizard will be displayed
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3. Select the Function Point Modeler > Functionpoint Project and click  Next .

4. Enter a project name and click  Next .
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5. Enter the required field and click Finish .
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The new created Enhancement Project will be displayed in the project explorer
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Create a Application Count

To create a new Application Count , perform the following steps.

1. Select an Application Project in the Project Explorer.
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2. From the main menu bar, select File > New > Count .
 

 

3. The following Create wizard will be displayed
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4. Enter the count name and click  Finish .

The new created empty Application Count will be displayed in the Function Point Modeler workbench. You may
continue with  Create a new Application System  .
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Create a Development Project Count

To create a new Development Project Count , perform the following steps.

1. Select an Development Project in the Project Explorer.
 

 

2. From the main menu bar, select File > New > Count .
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3. The following Create wizard will be displayed
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4. Enter the count name and click  Finish .

The new created empty Development Project Count will be displayed in the Function Point Modeler workbench.
You may continue with  Create a new Application System  .
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Create a Enhancement Project Count

To create a new Enhancement Project Count , perform the following steps.

1. Select an Enhancement Project in the Project Explorer.
 

 

2. From the main menu bar, select File > New > Count .
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3. The following Create wizard will be displayed
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4. Enter the count name and click  Finish .

The new created empty Enhancement Project Count will be displayed in the Function Point Modeler workbench.
You may continue with  Create a new Application System  .
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Change Count Properties

After you create a Count , you can edit its various properties, such as its name, phase etc.

To change the properties of Count , perform the following steps.

1. Move your mouse pointer to a Count on the workbench element in the editor area and perform a right mouse
click.
 

 

2. Select the menu item Show Properties View .
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3. The following Properties View will be showed.
 

 

4. Enter a name for your Count.
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5. Click Enter to change the properties.
 

 

Seal a Count

Once you have finished with a count you may seal this Count .

The sealing of a count means that you can not change the count any more.

Select a count from the Project Explorer and select Seal from the popup menu.
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Once you have sealed a count, the count will be displayed with lock in the tree.
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Unseal a Count

You may also unseal a count which is already sealed. But it is not recommended!

1. Select a count from the Project Explorer and select Properties from the popup menu.
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2. The following dialog will be showed.Click Unseal... button on the dialog.
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Once you have unsealed a count, the lock on the count will be disappear in the tree.
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Working with Projectdata and Cocomo Estimation

 

 

Create or Modify Project Plandata

 

 

To create a new Project Plandata , perform the following steps.

1. Select Open projectdata editor from the popup menu in the Project Explorer .
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2. The following Projectdata Editor will be displayed in the Function Point Modeler workbench. Click o the
Create a new Project Plandata .
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The new created Development Project will be displayed in the Projectdata Editor.
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Add or Modify Referenced Counts

 

 

To add a new Count to a Project Plandata , perform the following steps.

1. Select Counts in the tree of a Project Plandata and click on the Add a new element .
 

 

2. The following Counts Selection Dialog will be displayed in the Function Point Modeler workbench. Select a
count and click on the Ok button .
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The new added count will be displayed in the tree of Project Plandata .
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Add or Modify Project Estimations

 

 

To add a new Estimations to a Project Plandata , perform the following steps.

Select Project estimations in the tree of a Project Plandata and click on the Add a new element .
 

 

The new added Project estimation will be displayed in the tree of Project Plandata .
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Create or Modify Project Actual Data

 

 

Once you have created a Project Plandata , a Project Actual Data has been created with it automatically.

The new created Project Actual Data is showed below.

 

 

Create or Modify Project Phase Data

 

 

Once you have created a Project Plandata , a Project Actual Data has been created with it automatically.
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Click Detailed Actual Data check box.
 

 

The new created Project Phase Actual Data will be displayed in the tree of Project actual data .
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Create or Modify Project Activity Actual Data

 

 

Once you have created a Project Plandata , a Project Actual Data has been created with it automatically.
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Click Detailed Actual Data check box.
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The new created Project Activity Actual Data will be displayed in the tree of Project Phase Actual Data .

 

 

Add or Modify Project Interruption

 

 

To add a new Interruption to a Project Plandata , perform the following steps.

Select Project interruption in the tree of a Project Plandata and click on the Add a new element .
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The new added Project interruption will be displayed in the tree of Project Plandata .

 

 

Add or Modify Unestimated Effort
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To add a new Unestimated Effort to a Project Plandata , perform the following steps.

Select Unestimated efforts in the tree of a Project Plandata and click on the Add a new element .
 

 

The new added Unestimated Effort will be displayed in the tree of Project Plandata .
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Add or Modify Defect

 

 

To add a new Defect to a Project Plandata , perform the following steps.

1. Select the Project actual data in the tree of a Project Plandata and click Detailed Actual Data check box.
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2. Select the Defects in the tree of a Project Plandata and click on the Add a new element .
 

 

The new added Deffect will be displayed in the tree of Project Plandata .
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Working with Base Estimations

 

 

The project-level drivers the scale factors and the cost factor SCED are used only for Base Estimation. If you select
an Base Estimation only the scale factors and the cost factor SCED are showed on the right side. This project-level
drivers have to be adjusted for whole project.
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1. Select Project estimations in the tree of a Project Plandata and click on the Add a new element .
 

 

2. Click on the Cocomo tab on the Project Plandata editor. You will see the new added estimation in the
estimation tree .
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3. Select the Base Estimation on the estimation tree . You will see the the scale factors and the cost factor SCED
on the left site. You can now adjust this factor for the Base Estimation .
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The adjusted scale factors will be displayed on the chart .

 

 

Working with Subestimations

 

 

The component-level Cost Drivers are used for each Sub estimation . Each Base estimation contains 1-n sub
estimations. The software systems are comprised of multiple subsystems or components. You can create Sub Sub
estimation for each subsystem or component. If you select a Sub estimation only the whole component-level
Cost Drivers are showed on the right side. This component-level Cost Drivers have to be adjusted for the current
subsystems or components.
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Usually software systems are comprised of multiple subsystems or components. It is possible to use COCOMO II to
estimate effort and schedule for multiple components. The COCOMO II method for doing this does not use the sum
of the estimate for each components as this would ignore effort due to integration of the component. The COCOMO
II multiple method for n number of modules has the following steps:

1. Sum the sizes for all of the components, Size1, to yield to aggregate size. SizeAggregate = # Size

2. Apply the project-level drivers, the Scale Factors and the SCED Cost Driver to the aggregated size to derive the
overall basic effort for the total project, PMBasic . PMBasic = A x (SizeAggregate )E x SCED

3. Determine each component’s basic effort, PMBasic(i) , by apportioning the overall basic effort to each component
based on its contribution to the aggregate size. PMBasic(i) = PMBasic x (Size / SizeAggregat )

4. Apply the component-level Cost Drivers (excluding SCED) to each component’s basic effort. PMi = PMBasic(i) x
# EMi (i=1-16)

5. Sum each component’s effort to derive the aggregate effort, PMAggregate for the total project. PMAggregate = #
PMi

6. The schedule is estimated by repeating steps 2 through 5 without the SCED Cost Driver used in step 2.

1. Select the Estimation I in the tree and click the Add button
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2. Click on the Info tab on the Project Plandata editor. You may change the name of Sub estimation and the adjust
Cost Drivers
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The adjusted cost factors will be displayed on the chart .

 

 

Create a Project Estimation Report

 

 

To create an Estimation Report , perform the following steps.

1. Select a Base Estimation in the tree and click the button Generate PDF file right upon.
 

 

2. The following dialog will be showed. Enter the file name and click the button Ok
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The following PDF file will be created. .

 

 

Working with Application System Lifecycle
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Navigating Application Systems

 

 

Function Point Modeler enables you to navigate application system Lifecycle.

To start a Life Cycle perspective , perform the following steps.

1. Click the Open Perspective on the right upon of Function Point Modeler .
 

 

2. The following dialog will be showed. Select the Life Cycle and click the button Ok
 

 

The Life Cycle will be showed. Click an desired system and the desired count of the selected system on the Life
Cycle .
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Navigating Application System Counts

 

 

Function Point Modeler enables you to navigate application system Lifecycle.

To start a Life Cycle perspective , perform the following steps.

1. Click the Open Perspective on the right upon of Function Point Modeler .
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2. The following dialog will be showed. Select the Life Cycle and click the button Ok
 

 

The Life Cycle will be showed. Click an desired system and the desired count of the selected system on the Life
Cycle .

 

 

Analyze Lifecycle Data

 

 

Function Point Modeler enables you to navigate application system Lifecycle.

To start a Life Cycle perspective , perform the following steps.
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1. Click the Open Perspective on the right upon of Function Point Modeler .
 

 

2. The following dialog will be showed. Select the Life Cycle and click the button Ok
 

 

The Life Cycle will be showed. Click an desired system and the desired count of the selected system on the Life
Cycle .

You will see detail information (e.g. Process type, Enhancement type, etc.) of the current selected count
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Working with SLED

 

 

Setup SLED Database

 

 

MS Access

 

 

To connect to a MS Access SLED database, perform the following steps.

The steps to set up an ODBC connection depends on your operating system. In the following description the
procedures in Windows Vista is demonstrated. If you're using a different operating system this steps may vary.

1. Select Start > Control Panel in the Windows Task bar.

2. Select ODBC Datasources .

3. Switch to the System-DSN tab.

4. Press the Add button.

5. Select the MS Access driver and press the Finish button.

6. Enter a description in the Datasource Name filed, e.g. FPM .

7. Press the Select button.

8. Switch to your Database location, select the Database file and press the OK button.

9. Press the OK button in the following to dialog steps.
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10. In Function Point Modeler, switch to the SLED perspective. To do this, select Window > Open perspective >
Other ... > SLED from the menu bar.

11. Click on the New... button in the toolbar of the Connections view.
 

 

12. Select entry Generic JDBC from the list of availables connection profile types.
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13. Enter a name for your new connection profile e.g. MS Access .

14. Enter an optional description for your new connection profile e.g. MS Access@localhost.

15. Press the Next button

16. Press the following button to define a new driver definition.
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17. Select the required Generic JDBC driver template from the list of available templates.
 

 

18. Switch to the JAR List tab.

19. To add a new correct driver, press the button Add JAR/Zip... and select a valid Java Runtime Library rt.jar .

20. Switch to the Properties tab.

21. Correct the entry in the Connection URL, so that it points to your Generic JDBC Database, e.g. jdbc:odbc:FPM .
The last part of this URL corresponds to your ODBC Definition Name you've created in the previous steps.

22. Correct the entry in the Database name field, e.g. FPM .

23. Select Driver Class and press the button at the end of the field.
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24. Enter sun.jdbc.odbc.JdbcOdbcDriver under Type Class Name and press OK.
 

 

25. Enter a valid User ID for your Database.

26. Press the OK button.

27. If required, enter a password for your database and press the Test Connection button to validate your settings. If
you receive a message like Ping succeeded! you can press the Finish button to confirm your selections.

A new entry with for your SLED MS Access Database will be added to the Connection view.
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MySQL

 

 

To connect to a MySQL SLED database, perform the following steps.

1. Switch to the SLED perspective. To do this, select Window > Open perspective > Other ... > SLED from the
menu bar.

2. Click on the New... button in the toolbar of the Connections view.
 

 

3. Select entry MySQL from the list of availables connection profile types.
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4. Enter a name for your new connection profile e.g. MySQL .

5. Enter an optional description for your new connection profile e.g. MySQL@localhost.

6. Press the Next button

7. Press the following button to define a new driver definition.
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8. Select the required MySQL driver template from the list of available templates.
 

 

9. Switch to the JAR List tab.

10. Remove the listed driver, if you receive an error message by selecting it and then press the button Remove JAR/
Zip . To add a new correct driver, press the button Add JAR/Zip... and select a valid JAR file which is consistent
with the selected MySQL version.

11. Switch to the Properties tab.

12. Correct the entry in the Connection URL, so that it points to your MySQL database location, e.g. jdbc:mysql://
localhost:3306/fpm .

13. Correct the entry in the Database name field, e.g. fpm .
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14. Enter a valid Password and User ID for your Database.

15. Press the OK button.

16. Press the Test Connection button to validate your settings. If you receive a message like Ping succeeded! you
can press the Finish button to confirm your selections.

A new entry with for your SLED Derby Database will be added to the Connection view.

 

 

Derby

 

 

To connect to a Dertby SLED database, perform the following steps.

1. Switch to the SLED perspective. To do this, select Window > Open perspective > Other ... > SLED from the
menu bar.

2. Click on the New... button in the toolbar of the Connections view.
 

 

3. Select entry Derby from the list of availables connection profile types.
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4. Enter a name for your new connection profile e.g. Derby .

5. Enter an optional description for your new connection profile e.g. Derby@localhost.

6. Press the Next button

7. Select the entry Derby Embedded JDBC Driver 10.2 Default from the list of available drivers.
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8. Enter a location under Database location where your Derby Database exists, or where you want to create a new
Derby Database e.g. C:\Temp\MyDerbyDB .

9. Enter a valid Username and Password for your Database.

10. Select option Create database if you want to create a new Database. If you connect to an existing Database,
please deselect this option.

11. Press the Test Connection button to validate your settings. If you receive a message like Ping succeeded! you
can press the Finish button to confirm your selections.

A new entry with for your SLED Derby Database will be added to the Connection view.

 

 

Export Project to SLED

 

 

To export Projects to a SLED database, perform the following steps.

1. Right click inside the Project Navigator view and select Export... > Function Point Modeler > Project to
SLED .
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2. Press the Next button.

3. Select the connection profile to which you want to export. Keep in mind, only connected profiles are visible.
 

 

4. Select the projects you want to export. It's also possible to select or de-select all projects.
 

 

5. Enable the option Overwrite existing projects if you want to overwrite by default. If this option is not set, a
dialog will be presented if a project already exists in SLED.
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6. Select the Finish when you're finished with your selection.

Analyze SLED Content

 

 

To Analyze SLED Content, perform the following steps.

1. Switch to the SLED perspective. To do this, select Window > Open perspective > Other ... > SLED from the
menu bar.

2. Connect to a SLED database in the Connections view, if not already connected.
 

 

3. Enter a search criteria in the SLED Explorer view . To analyze the complete SLED content, leave this field
empty.
 

 

4. Press the Reload SLED Content button in the SLED Explorer view.
 

 

5. Select the element in the SLED Explorer tree which should be analyzed.
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View and analyze properties for the selected element.

 

 

Working in Teams

Setup Project Management System
Setup CVS Project Management System

To connect to a CVS team repository, perform the following steps.

1. Switch to the CVS Repository Exploring perspective. To do this, select Window > Open perspective >
Other ... > CVS Repository Exploring from the menu bar.
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2. The relevant perspective will be opened. Select the view CVS Repositories . If you now click the right mouse
button, a pop-up menu appears. Select the menu item New > Repository Location... .
 

 

3. In the new pop-up window, you can specify your CVS server, user information and protocol. To get this
informations, you may need to contact your administrator.
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4. Select the option Validate Connection on Finish .

5. Press the Finish button.

If everything is correct, the connection is set up and you can continue to use the team repository.
 

 

Setup SVN Project Management System

To connect to a SVN team repository, perform the following steps.
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1. Switch to the SVN Repository Exploring perspective. To do this, select Window > Open perspective >
Other ... > SVN Repository Exploring from the menu bar.
 

 

2. The relevant perspective will be opened. Select the view SVN Repositories . If you now click the right mouse
button, a pop-up menu appears. Select the menu item New > Repository Location... .
 

 

3. In the new pop-up window, you can specify your SVN server, user information and password. To get this
informations, you may need to contact your administrator.
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4. Select the option Validate Repository Location on finish .

5. Press the Finish button.

If everything is correct, the connection is set up and you can continue to use the team repository.
 

 

Working with CVS Repositories
Share Projects in CVS

To share a Project in a CVS team repository, perform the following steps.

1. Switch to the Functionpoint perspective. To do this, select Window > Open perspective > Other ... >
Functionpoint  from the menu bar.
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2. In the Project Navigator view, select the project you want to share in a team repository and perform a right mouse
click. In the following pop-window select the entry Team > Share project...
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3. Select the CVS repository type and click on the Next button.
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4. Select the team repository where your project should be shared and click on the Next button.
 



 | Function Point Modeler Workbench | 355

 

5. Select Use project name as module name or select Use specified module name and enter a name of your choice
and press the Next button.
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6. Select option Launch the commit wizard and press the Finish button.
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7. Enter a comment and press Finish .
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Your local project is now shared in a CVS Team Repository.
 

 

Checkout Projects from CVS

To checkout a Project from a CVS team repository, perform the following steps.
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1. Switch to the CVS Repository Exploring perspective. To do this, select Window > Open perspective >
Other ... > CVS Repository Exploring  from the menu bar.
 

 

2. Select the project you want to check out in the CVS Repositories view. If you perform a right mouse click on this
project, a pop-up menu appears. Select the menu item Check Out .
 

 

After the checkout operation is completed, you can find the the corresponding project in the Project Navigator . The
project has been transferred to your local workspace.
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Synchronize Projects with CVS

To synchronize your local version of a Project with a CVS team repository, perform the following steps.

1. Switch to the Functionpoint perspective. To do this, select Window > Open perspective > Other ... >
Functionpoint  from the menu bar.
 

 

2. Select the project you want to synchronize in the Project Navigator view. If you perform a right mouse click on
this project, a pop-up menu appears. Select the menu item Team > Synchronize with repository .
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3. If a dialog appears to open a different perspective, please choose Yes .
 

 

4. In the Synchronize view, select Update all Incoming Changes... to update changes from the repository in your
local workspace. Select Commit all Outgoing Changes... to commit all changes in your local workspace to the
repository.
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5. Enter a valid comment for a commit operation. This dialog will only be shown if you commit local workspace
changes to the repository. For update operations, no dialog will appear. Select Finish to start the commit
operation.
 

 

After the commit and update operations are completed, the content in the Synchronize view will disappear.
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Working with SVN Repositories
Share Projects in SVN

To share a Project in a SVN team repository, perform the following steps.

1. Switch to the Functionpoint perspective. To do this, select Window > Open perspective > Other ... >
Functionpoint  from the menu bar.
 

 

2. In the Project Navigator view, select the project you want to share in a team repository and perform a right mouse
click. In the following pop-window select the entry Team > Share project...
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3. Select the SVN repository type and click on the Next button.
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4. Select the team repository where your project should be shared and click on the Next button.
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5. Select Simple Mode and press the Next button.
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6. Enter a comment, select option Launch the Commit Dialog for the shared resources and press the Finish
button.
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7. Enter a comment and press OK .
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Your local project is now shared in a SVN Team Repository.
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Checkout Projects from SVN

To checkout a Project from a SVN team repository, perform the following steps.

1. Switch to the SVN Repository Exploring perspective. To do this, select Window > Open perspective >
Other ... > SVN Repository Exploring  from the menu bar.
 

 

2. Select the project you want to check out in the SVN Repositories view. If you perform a right mouse click on this
project, a pop-up menu appears. Select the menu item Check Out .
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After the checkout operation is completed, you can find the the corresponding project in the Project Navigator . The
project has been transferred to your local workspace.
 

 

Synchronize Projects with SVN

To synchronize your local version of a Project with a SVN team repository, perform the following steps.

1. Switch to the Functionpoint perspective. To do this, select Window > Open perspective > Other ... >
Functionpoint  from the menu bar.
 

 

2. Select the project you want to synchronize in the Project Navigator view. If you perform a right mouse click on
this project, a pop-up menu appears. Select the menu item Team > Synchronize with repository .
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3. If a dialog appears to open a different perspective, please choose Yes .
 

 

4. In the Synchronize view, select Update all Incoming Changes... to update changes from the repository in your
local workspace. Select Commit all Outgoing Changes... to commit all changes in your local workspace to the
repository.
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5. Enter a valid comment for a commit operation. This dialog will only be shown if you commit local workspace
changes to the repository. For update operations, no dialog will appear. Select OK to start the commit operation.
 

 

After the commit and update operations are completed, the content in the Synchronize view will disappear.
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Working with Standard Reports

Create a Count Overview Report

To create a overview report for a count in your workspace, perform the following steps.

1. Select a count in the Project Navigator

2. Right click on the selected element

3. Select entry Create reports > Count overview
 

 

4. In the dialog, enter a target file or browse for a specific location. The specified filename must end with .pdf .
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5. Select Open created file in viewer if you want to open the created file in the designated viewer, after the file was
created.

6. Perform OK

The following picture shows an open sample report.

 

 

Create a Count Structure Report

To create a structure report for a count in your workspace, perform the following steps.

1. Select a count in the Project Navigator

2. Right click on the selected element

3. Select entry Create reports > Count structure
 

 

4. In the dialog, enter a target file or browse for a specific location. The specified filename must end with .pdf .
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5. Select Open created file in viewer if you want to open the created file in the designated viewer, after the file was
created.

6. Perform OK

The following picture shows an open sample report.
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Create a Release Value Adjustment Factor Report

To create a release value adjustment factor report for a count in your workspace, perform the following steps.

1. Select a count in the Project Navigator

2. Right click on the selected element

3. Select entry Create reports > Release Value Adjustment Factor
 

 

4. In the dialog, enter a target file or browse for a specific location. The specified filename must end with .pdf .
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5. Select Open created file in viewer if you want to open the created file in the designated viewer, after the file was
created.

6. Perform OK

The following picture shows an open sample report.
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Importing

Import Count from XMI

 

 

To import a Count from a XMI file, perform the following steps.

1. Right click inside the Project Navigator view and select Import... > Function Point Modeler > Count from
XMI
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2. Press the Next button.

3. Enter a valid Project or browse for a project inside your workspace.
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4. Enter a valid FPM file name, e.g. TestCount .

5. Enter a valid XMI file source or browse for file inside your workspace.
 

 

6. Select the Source Model Typ you wish to import and press Next .

7. For Use Case Model import, it's required to select Application Systems, Subsystems and Use Cases. For Class
Model import, it's required to select Application Systems, Subsystems, Boundary Classes, Entity Classes and
Operations.
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8. Select the Next when you're finished with your selection.

9. For Use Case Model import, it's required to select EI, EO and EQ. For Class Model import, it's required to select
EI, EO, EQ, ILF and EIF.
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10. Select the Finish when you're finished with your selection.

A new Count will be added to your workspace.
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Import Projects from ISBSG Data

 

 

Function Point Modeler now offers you the opportunity to import ISBSG data into the FPM in order to calibrate
COCOMO based on the ISBSG data.

The ISBSG delivers a database of software project history data that is used for estimation, benchmarking and project
management. The ISBSG database has data on over 5000 projects from a wide variety of software domains where the
functional size was measured using the IFPUG method. ISBSG database is delivered in an Excel spreadsheet.
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To import a ISBSG , perform the following steps.

1. Select Import from the pop menu.
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2. Select Function Point Modeler > ISBSG database from the tree.
 

 

3. Select Function Point Modeler > ISBSG database from the tree and click the button Next .
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4. Click on the Browse button … and click the associated Browse to locate the directory or file containing the
ISBSG excel file. Before you click on the Browse... button you have to select the excel spreadsheet row
containing the header. The whole ISBSG data is now shown in the wizard. You can now specify in the wizard the
ISBSG data that you want to import into the Function Point Modeler . You can see a lot of project metrics like
function points and actual effort. It is recommended to deselect all projects that don’t have function points and
actual effort.
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5. After you have specified the ISBSG data to be imported you have to map the Function Point Modeler data
model with the ISBSG data model. In the tree on right side you see the Function Point Modeler data model. The
tree items with red icon are obligatory to map and with yellow icon are optional to map. Click the desired tree
item on the tree and drag the item from a tree to the desired row in the ISBSG table on left side. The font of the
mapped tree items and rows are in Bold typeface. To delete mapping, right click on the desired tree item. If you
have mapped all obligatory items in the tree, you can click on the Next> button.
 



 | Function Point Modeler Workbench | 391

 

6. This is the last wizard to map the content of some rows of the ISBSG data to the content of Function Point
Modeler data model. In this wizard you see on the left side the tree of Function Point Modeler data model and
on right side the content of the specified row of the ISBSG database. Click the desired table item on the table an
drag it from a table to the desired tree item in the tree on left side. The fond of the mapped table items are Bold
. To delete mapping, click on the desired tree item in the tree. After mapping all table items click on the Finish
button.
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Now you can see the in the Function Point Modeler the imported ISBSG project and function point size in the
Function Point Modeler Workspace. All the metrics you have selected and mapped are imported in the Function
Point Modeler . You can open Function Point Modeler Count or Project Editor to show the information.

You will see the imported projects following:
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Import Projects from Project Interchange

To import Projects from Project Interchange format, perform the following steps.

1. Right click inside the Project Navigator view and select Import... > Function Point Modeler > Project
Interchange
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2. Press the Next button.

3. Enter a valid Project Interchange file or browse for a location inside your workspace.
 

 

4. Select the projects you want to import. It's also possible to select or de-select all projects.
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5. Select the Finish when you're finished with your selection.

The selected projects will be added to your workspace.

 

 

Exporting

Export Count to MS Excel

 

 

To export a Count to an MS Excel file, perform the following steps.

1. Right click inside the Project Navigator view and select Export... > Function Point Modeler > Count to MS
Excel
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2. Press the Next button.

3. Select the Count you want to export from the list of available Counts.
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4. Enter a valid target file e.g. C:\Temp\Test.xls or browse for a file location.

5. Switch to the Options Tab if you want to change your target file version.

6. Select option Open exported count in viewer if you want to automatically open the new created file in the
designated viewer.

7. Press the Finish button

A new MS Excel file will be created.
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Export Count to XMI

 

 

To export a Count to an XMI file, perform the following steps.

1. Right click inside the Project Navigator view and select Export... > Function Point Modeler > Count to XMI
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2. Press the Next button.

3. Select the Count you want to export from the list of available Counts.
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4. Enter a valid target file e.g. C:\Temp\Test.xmi or browse for a file location.

5. Switch to the Options Tab if you want to change the XMI version version.

6. Select Target Model Typ you wish to export.

7. Press the Finish button

A new XMI file will be created.
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Export Estimation to MS Excel

 

 

To export a Estimation to an MS Excel file, perform the following steps.

1. Right click inside the Project Navigator view and select Export... > Function Point Modeler > Estimation to
MS Excel
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2. Press the Next button.

3. Select the Estimation you want to export from the list of available Estimations.
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4. Enter a valid target file e.g. C:\Temp\Test.xls or browse for a file location.

5. Switch to the Options Tab if you want to change the Excel version.

6. Select Target Model Typ you wish to export.

7. Select option Open exported count in viewer if you want to automatically open the new created file in the
designated viewer.

8. Press the Finish button

A new MS Excel file will be created.
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Export Estimation to MS Project

 

 

To export a Estimation to an MS Project file, perform the following steps.

1. Right click inside the Project Navigator view and select Export... > Function Point Modeler > Estimation to
MS Project
 



 | Function Point Modeler Workbench | 405

 

2. Press the Next button.

3. Select the Estimation you want to export from the list of available Estimations.
 

 

4. Enter a valid target file e.g. C:\Temp\Test.xls or browse for a file location.

5. Switch to the Options Tab if you want to change the MS Project version.

6. Select the Target Model Typ you wish to export.

7. Press the Finish button
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A new MS Project file will be created.

 

 

Export Projects to Project Interchange

To export Projects to Project Interchange format, perform the following steps.

1. Right click inside the Project Navigator view and select Export... > Function Point Modeler > Project
Interchange
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2. Press the Next button.

3. Select the projects you want to export. It's also possible to select or de-select all projects.
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4. Enter a valid target file e.g. c:\Temp\Test.zip or browse for a file location.
 

 

5. Select the Finish when you're finished with your selection.

Export Projects to SLED

 

 

To export Projects to a SLED database, perform the following steps.

1. Right click inside the Project Navigator view and select Export... > Function Point Modeler > Project to
SLED
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2. Press the Next button.

3. Select an available SLED connection. Only activated connections are available for selection.
 

 

4. Select the Projects you want to export from the list of available Projects. It's also possible to select or de-select all
Projects at once.
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5. Enable checkbox Overwrite existing projects if you want to overwrite existing projects in SLED without
rückfrage.
 

 

6. Press the Finish button

The selected Projects will be exported to the SLED database.

 

 

Working with Cocomo Masterdata

 

 

Function Point Modeler provides you COCOMO Masterdata to customize all parameters of Function Point
Modeler Cocomo Tool

The default preferences customization is made according to the our advises. But of course each user can change it
in the appropriate way to optimize his Cocomo - actually this is the main goal of providing the user such rage of
customized preferences.
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Select from the menu Window >Preferences > Function point Modeler > COCOMO Master Data
 

 

The following dialog will be showed
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Change hours/person month

 

 

You may change the hours/person month specified for your company. The default value of hours/person month is 152
hours/month.

1. To change the hours/person month click the COCOMO Customizing Data leaf of the tree.
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2. Enter the hours/person month value.
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3. To apply the changes click the Apply or Ok button.

Create Cocomo Constants

 

 

You may create a new Cocomo Constant specified for your company.

To create a new Cocomo Constant , perform the following steps.

1. Select from the menu Window >Preferences > Function point Modeler > COCOMO Master Data
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2. Select the item Cocomo Constants in the tree and click the button Add
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The new added Cocomo Constant will be displayed in the tree of Cocomo Master Data .

 

 

Calibrate Cocomo Constants

 

 

You may create a new Cocomo Constant specified for your company. You may also calibrate a new Cocomo
Constant from the Software Life Cycle Experience Database (SLED) .

You may calibrate the Cocomo Constant both A and B .

To calibrate a Cocomo Constant A , you have to have at least 5 completed project for the spezified selection.

To calibrate the Cocomo Constants A and A , you have to have at least 10 completed project for the spezified
selection.

To calibrate a new Cocomo Constant , perform the following steps.

1. Select from the menu Window >Preferences > Function point Modeler > COCOMO Master Data
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2. Select the item Cocomo Constants in the tree and click the button Add .
 

 

3. Define the selection criterion for Language , Project Type , Project Class , Platform Type and , Architecture
Type
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4. Click the button Calibrate . The following dialog will be showed. Select the required project from the tree and
click the button Calibrate .
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The new calibrated Cocomo Constant will be displayed in the tree of Cocomo Master Data .
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Add Scale Factors

 

 

You may add a new Scale Factor specified for your company.

To add a new Scale Factor , perform the following steps.

1. Select from the menu Window >Preferences > Function point Modeler > COCOMO Master Data
 

 

2. Select the item Scale Factors in the tree and click the button Add
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The new added Scale Factor will be displayed in the tree of Cocomo Master Data .
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Add Cost Factors

 

 

You may add a new Cost Factor specified for your company.

To add a new Cost Factor , perform the following steps.

1. Select from the menu Window >Preferences > Function point Modeler > COCOMO Master Data
 

 

2. Select the item Cost Factors in the tree and click the button Add
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The new added Cost Factor will be displayed in the tree of Cocomo Master Data .
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Add Gearing Factors

 

 

You may add a new Gearing Factor specified for your company.

To add a new Gearing Factor , perform the following steps.

1. Select from the menu Window >Preferences > Function point Modeler > COCOMO Master Data
 

 

2. Select the item Gearing Factors in the tree and click the button Add
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The new added Gearing Factor will be displayed in the tree of Cocomo Master Data .

 

 

Add Architecture Types
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You may add a new Architecture Types specified for your company.

To add a new Architecture Types , perform the following steps.

1. Select from the menu Window >Preferences > Function point Modeler > COCOMO Master Data
 

 

2. Select the item Architecture Types in the tree and click the button Add
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The new added Architecture Types will be displayed in the tree of Cocomo Master Data .

 

 

Add Platform Types

 

 



 | Function Point Modeler Workbench | 428

You may add a new Platform Types specified for your company.

To add a new Platform Types , perform the following steps.

1. Select from the menu Window >Preferences > Function point Modeler > COCOMO Master Data
 

 

2. Select the item Platform Types in the tree and click the button Add
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The new added Platform Types will be displayed in the tree of Cocomo Master Data .

 

 

Add Project Types
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You may add a new Project Types specified for your company.

To add a new Project Types , perform the following steps.

1. Select from the menu Window >Preferences > Function point Modeler > COCOMO Master Data
 

 

2. Select the item Project Types in the tree and click the button Add
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The new added Project Types will be displayed in the tree of Cocomo Master Data .

 

 

Add Estimation Types
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You may add a new Estimation Types specified for your company.

To add a new Estimation Types , perform the following steps.

1. Select from the menu Window >Preferences > Function point Modeler > COCOMO Master Data
 

 

2. Select the item Estimation Types in the tree and click the button Add
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The new added Estimation Types will be displayed in the tree of Cocomo Master Data .

 

 

Add External Work Types
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You may add a new External Work Types specified for your company.

To add a new External Work Types , perform the following steps.

1. Select from the menu Window >Preferences > Function point Modeler > COCOMO Master Data
 

 

2. Select the item External Work Types in the tree and click the button Add
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The new added External Work Types will be displayed in the tree of Cocomo Master Data .

 

 

Add Unestimated Effort Reasons
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You may add a new Unestimated Effort Reasons specified for your company.

To add a new Unestimated Effort Reasons , perform the following steps.

1. Select from the menu Window >Preferences > Function point Modeler > COCOMO Master Data
 

 

2. Select the item Unestimated Effort Reasons in the tree and click the button Add
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The new added Unestimated Effort Reasons will be displayed in the tree of Cocomo Master Data .

 

 

Export Cocomo Masterdata
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You may export the customized COCOMO Masterdata either to xmi file or to a relational database management
system (RDBMS) to provide this setting your team member centralized.

1. Click the Export button to export COCOMO Masterdata
 

 

2. The following dialog will be showed.
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3. Click the Browse... button

4. Enter the filename myMasterData
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5. Click the Ok button
 

 

The following picture shows the content of the COCOMO Masterdata .
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Import Cocomo Masterdata

 

 

You may also import the customized COCOMO Masterdata either from xmi file or from a relational database
management system (RDBMS) .

1. Click the Import button to export COCOMO Masterdata
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2. The following dialog will be showed.
 

 

3. Click the Browse... button
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4. Select the file myMasterData
 

 

5. Click the Ok button
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The following picture shows the content of the COCOMO Masterdata .

 

 

Restore Defaults Cocomo Masterdata

 

 

You can restore the default COCOMO Masterdata at any time:

To restore the default COCOMO Masterdata click the Restore Defaults button.
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The following picture shows the content of the COCOMO Masterdata .
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Apply Cocomo Masterdata

 

 

Changes of COCOMO Masterdata take effect on editors only after you press Apply or OK.

To apply the changes click the Apply or Ok button.
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The following picture shows the content of the COCOMO Masterdata .
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Working with Development Processes

 

 

Create a new Development Process

 

 

To create a new Development Process, perform the following steps.

1. Select Window > Preferences > Function Point Modeler > Development processes in the menu bar.
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2. Select Iterative Processes or Non-iterativ Processes and click on the New processes... button.
 

 

3. Enter a valid name for your new Development Process and press the OK button.
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A new Development Process will be created. Your new Process contains a Process Version 1.0 by default, because
every Development Process must contain exactly one active Process Version.
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Create a new Process Version

 

 

To create a new Development Process Version, perform the following steps.

1. Select Window > Preferences > Function Point Modeler > Development processes in the menu bar.
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2. Select a Development Process Version in the subtree User-defined Processes. The selected version is used as a
copy basis for the new version to be created. Press the button New version ... .
 

 

3. Enter a valid name for your new Development Process Version and press the OK button.
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A new Development Process Version will be created.

 

 

Configure a Process Version

 

 

Configure Process Version Description
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To configure a Process Version Description, perform the following steps.

1. Select Window > Preferences > Function Point Modeler > Development processes in the menu bar.
 

 

2. Select a Development Process Version in the subtree User-defined Processes. Press the button Configure ... .
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3. Select the Common tab in the dialog and enter a valid Process Version Description. When finished, press the OK
button.
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The new Development Process Version description will be displayed.
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Configure Phases

 

 

To configure Process Version Phases, perform the following steps.

1. Select Window > Preferences > Function Point Modeler > Development processes in the menu bar.
 

 

2. Select a Development Process Version in the subtree User-defined Processes. Press the button Configure ... .
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3. Select the Common tab in the dialog.
 

 

4. Click on an existing phase to change the description.

5. Click on the Add button to add a new phase.

6. Click on the Remove button to delete the selected phase.

7. Click on the Up button to move the selected phase one position upwards.

8. Click on the Down button to move the selected phase one position downwards.

9. Click on the OK when finished.
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Configure Activities

 

 

To configure Process Version Activities, perform the following steps.

1. Select Window > Preferences > Function Point Modeler > Development processes in the menu bar.
 

 

2. Select a Development Process Version in the subtree User-defined Processes. Press the button Configure ... .
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3. Select the Common tab in the dialog.
 

 

4. Click on an existing activity to change the description.

5. Click on the Add button to add a new activity.

6. Click on the Remove button to delete the selected activity.

7. Click on the Up button to move the selected activity one position upwards.

8. Click on the Down button to move the selected activity one position downwards.
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9. Click on the OK when finished.

Configure Allocations

 

 

To configure Process Version Allocations, perform the following steps.

1. Select Window > Preferences > Function Point Modeler > Development processes in the menu bar.
 

 

2. Select a Development Process Version in the subtree User-defined Processes. Press the button Configure ... .
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3. Select the Allocations tab in the dialog.

4. Select the project size, which you want to configure. For iterativ processes only one process size is available. For
non-iterativ processes, a large number of sizes can be selected.
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5. Select the phase, which you want to configure. Select the checkbox Estimated if this phase is estimated by
COCOMO. Select the checkbox Calculaed if this phase should be considered for calculation statistics. Change
the Percentage value for this phase. Keep in mind, that the summary percentage for COCOMO phases must be
100 percent. Change the Schedule value for this phase. This value will be used to calculate adequat staffing. Keep
in mind, that the summary schedule for COCOMO phases must be 100 percent.
 

 

6. Select the activity, which you want to configure. Select the checkbox Estimated if this activity is estimated by
COCOMO. Select the checkbox Calculaed if this activity should be considered for calculation statistics. Change
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the Percentage value for this activity. Keep in mind, that the summary percentage for COCOMO activities must
be 100 percent.
 

 

7. Press the OK button when finished.

Activate a Process Version

 

 

To activate a Development Process Version, perform the following steps.

1. Select Window > Preferences > Function Point Modeler > Development processes in the menu bar.
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2. Select a Development Process Version in the subtree User-defined Processes. It's required to select a non-active
Version. Press the button Activate .
 

 

The selected Development Process Version will be activated.
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Delete a Development Process

 

 

To delete a Development Process, perform the following steps.

1. Select Window > Preferences > Function Point Modeler > Development processes in the menu bar.
 

 

2. Select a Development Process in the subtree User-defined Processes. Press the button Delete .
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The selected Development Process will be deleted.

 

 

Delete a Process Version

 

 

To delete a Development Process Version, perform the following steps.

1. Select Window > Preferences > Function Point Modeler > Development processes in the menu bar.
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2. Select a non-active Development Process Version in the subtree User-defined Processes. It's not possible to
delete a currently active Version. Press the button Delete .
 

 

The selected Development Process Version will be deleted.
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Export Development Processes

 

 

Export Development Processes to XMI

 

 

To export Development Processes to an XMI document, perform the following steps.

1. Select Window > Preferences > Function Point Modeler > Development processes in the menu bar.
 

 

2. Click the button Export... .
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3. Select the destination type XMI Document . Enter a valid filename, select a previous filename or browse for a
new location.
 

 

4. Click the button OK .

The current Development Processes of your workspaces were exported to the specified XMI document.
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Export Development Processes to SLED

 

 

To export Development Processes to a SLED database, perform the following steps.

1. Select Window > Preferences > Function Point Modeler > Development processes in the menu bar.
 

 

2. Click the button Export... .
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3. Select the destination type Database and select a connection profile. It's only possible to select a currently
connected profile.
 

 

4. Click the button OK .

The current Development Processes of your workspaces were exported to the specified SLED database.
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Import Development Processes

 

 

Import Development Processes from XMI

 

 

To import Development Processes from an XMI document, perform the following steps.

1. Select Window > Preferences > Function Point Modeler > Development processes in the menu bar.
 

 

2. Click the button Import... .

3. Select the destination type XMI Document . Enter a valid filename, select a previous filename or browse for an
existing location.
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4. Click the button OK .

The current Development Processes from the specified XMI document were imported to your workspace.

 

 

Import Development Processes from SLED

 

 

To import Development Processes from a SLED database, perform the following steps.
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1. Select Window > Preferences > Function Point Modeler > Development processes in the menu bar.
 

 

2. Click the button Import... .

3. Select the destination type Database and select a connection profile. It's only possible to select a currently
connected profile.
 

 

4. Click the button OK .

The current Development Processes from the specified SLED database were imported to your workspace.
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Working with Diagram Settings

Change global settings

To change Global Diagram Settings, perform the following steps.

1. Select Window > Preferences from the menu bar.

2. Select Function Point Modeler > Diagram on the left side of the dialog window.
 

 

3. Select or un-select the possible options in the dialog window.
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4. When finished, press the Apply or OK button.

Change diagram appearance

To change the Diagram Appearance, perform the following steps.

1. Select Window > Preferences from the menu bar.

2. Select Function Point Modeler > Diagram > Appearance on the left side of the dialog window.
 

 

3. Change the available color and font settings in the dialog window.
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4. When finished, press the Apply or OK button.

Set connection styles

To change the Diagram Connection Styles, perform the following steps.

1. Select Window > Preferences from the menu bar.

2. Select Function Point Modeler > Diagram > Connections on the left side of the dialog window.
 

 

3. Change the available connection style settings in the dialog window.
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4. When finished, press the Apply or OK button.

Set Copy/Paste behaviour

To change the Diagram Copy/Paste Behaviour, perform the following steps.

1. Select Window > Preferences from the menu bar.

2. Select Function Point Modeler > Diagram > Copy/Paste on the left side of the dialog window.
 

 

3. Enable the option, if you want to rename diagram elements after copy/paste operation. Also specify a valid prefix,
if this option is enabled.
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4. When finished, press the Apply or OK button.

Set diagram layout style

To change the Diagram Layout Style, perform the following steps.

1. Select Window > Preferences from the menu bar.

2. Select Function Point Modeler > Diagram > Layout on the left side of the dialog window.
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3. Change the available diagram layout style settings in the dialog window.
 

 

4. When finished, press the Apply or OK button.

Change diagram pathmaps

To change the Diagram Pathmaps, perform the following steps.

1. Select Window > Preferences from the menu bar.

2. Select Function Point Modeler > Diagram > Pathmaps on the left side of the dialog window.
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3. Create a new, edit or remove an existing diagram pathmap.
 

 

4. When finished, press the Apply or OK button.

Setup diagram printing options

To setup the Diagram Printing Options, perform the following steps.

1. Select Window > Preferences from the menu bar.

2. Select Function Point Modeler > Diagram > Printing on the left side of the dialog window.
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3. Adjust the available printing settings.
 

 

4. When finished, press the Apply or OK button.

Change rulers and grid settings

To change the Diagram Rulers and Grid Settings, perform the following steps.

1. Select Window > Preferences from the menu bar.

2. Select Function Point Modeler > Diagram > Rulers And Grid on the left side of the dialog window.
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3. Adjust the available rulers and grid options.
 

 

4. When finished, press the Apply or OK button.

Working with the Product license
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Register your Product Version

 

 

Depending on registration you will receive a license key, which is valid for a certain number of installations. The
use of the license key is not hardware dependent, but a license key can only be used for the predetermined number of
installations. For this reason, it is possible to activate a license.

To register (activate) your product version, perform the following steps.

1. Select Windows > Preferences from the menu bar.

2. Select Function Point Modeler > License on the left side of the dialog.
 

 

3. Enter your registration key in the provided location.
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4. Press the Discard button to discard your changes.

5. Press the Save button to save your changes.

6. To activate your product version, press the Activate button.

7. When finished, select the OK button.

De-register your Product Version

 

 

Depending on registration you will receive a license key, which is valid for a certain number of installations. The
use of the license key is not hardware dependent, but a license key can only be used for the predetermined number of
installations. For this reason, it is possible to deactivate a license.

To de-register (deactivate) your product version, perform the following steps.

1. Select Windows > Preferences from the menu bar.

2. Select Function Point Modeler > License on the left side of the dialog.
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3. Press the Deactivate button to de-register your product version.
 

 

4. When finished, select the OK button.

Working with Project Logging

View Log Messages

To view Application Log Messages, perform the following steps.

1. Select Window > Show View > Other... > Function Point Modeler > Logging Messages from the menu bar.
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2. Click on the table headers to select sorting sequence and order.
 

 

Change Log-Level

To change Application Log Level, perform the following steps.

1. Select Window > Preferences from the menu bar.

2. Select Function Point Modeler > Logging on the left side of the dialog.
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3. Change the log level and other possible options as required.
 

 

4. When finished, click the Apply or OK button.

References

Preferences

Behaviour on close

The following preferences can be changed on the Behaviour on close preference page.
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Option Description

Exit application on close If this option is selected, the application will close on exit.

Minimize to system tray on
close

If this option is selected, the application will be minimized to system tray on exit.

Here is what the Behaviour on close preference page looks like:

COCOMO Master Data

 

 

The following preferences can be changed on the COCOMO Master Data preference page.

Option Description

Hours Per Person Month Sets the average working time of a project member within one month.

Cocomo Constants Additional Cocomo constants can be defined (calibrated) here or deleted.
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Option Description

Scale Factors This makes it possible to modify existing Scale Factors, create new Factors or to delete
existing Factors.

Cost Factors This makes it possible to modify existing Cost Factors, create new Factors or to delete
existing Factors.

Gearing Factors This makes it possible to modify existing Gearing Factors, create new Factors or to delete
existing Factors.

Architecture Types This makes it possible to modify existing Architecture Types, create new Types or to delete
existing Types.

Platform Types This makes it possible to modify existing Platform Types, create new Types or to delete
existing Types.

Project Types This makes it possible to modify existing Project Types, create new Types or to delete
existing Types.

Estimation Types This makes it possible to modify existing Estimation Types, create new Types or to delete
existing Types.

External Work Types This makes it possible to modify existing External Work Types, create new Types or to
delete existing Types.

Unestimated Effort Reasons This makes it possible to modify existing Unestimated Effort Reasons, create new Reasons
or to delete existing Reasons.

Here is what the COCOMO Master Data preference page looks like:
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With the help of this preference dialog, you can also export the current Cocomo Settings and in the opposite case you
can import this settings as well.

Calculator

The following preferences can be changed on the Calculator preference page.

Option Description

Set numeric precision for
displayed numbers

Determines the display accuracy of numerical values. Valid values are between 0 and 99.
The accuracy of the display does not affect the accuracy of a calculation.

Set internal number precision Determines the calculation accuracy of numerical values. Valid values are between 0 and
999. The accuracy of the display does not affect the accuracy of the display.

Use exponential (1.0E6)
output

If this option is selected, floating point numbers are printed in exponential notation.

Here is what the Calculator preference page looks like:
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Decorators

The following preferences can be changed on the Decorator preference page.

Option Description

Show decorator for Count
Typ

If this option is selected, a Count entry in the Project Navigator is decorated with the
corresponding Count Typ.

Show decorator for Count
Date

If this option is selected, a Count entry in the Project Navigator is decorated with the
corresponding Count Date.

Show decorator for Function
Points

If this option is selected, a Count entry in the Project Navigator is decorated with the
corresponding Function Points.

Here is what the Decorator preference page looks like:
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Development Processes

 

 

The following preferences can be changed on the Development Processes preference page.

Option Description

New Process... Define a new iterativ or non-iterativ development process.

New Version... Define a new process version.

Configure Configures an existing process version.

Activate Activates the selected process version. Only one version of a development process can be
active.

Delete Deletes the selected process or process version. An active process version can not be
deleted.

Export... Exports the current settings for development processes to an XMI file or to a SLED.

Import... Imports settings for development processes from an XMI file or from a SLED.
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Here is what the Development Processes preference page looks like:

The table placed in group Used in projects displays workspace projects, where the current selected process version is
in use.

Diagram

The following preferences can be changed on the Diagram preference page.

Option Description

Show connector handles If selected, connector handles will be visible.

Show popup bars If selected, a popup bar is shown in the diagram editors when the mouse is positioned at a
special location. The popup bar will contain all diagram elements, which are valid for the
given cursor position. When the user clicks on one of this elements, a new diagram element
for the given type will be created.

Enable animated layout If this option is selected, a new layout request of a diagram will be animated. If this option
is not selected, the layout request will be performed in a simple way.

Enable animated zoom If this option is selected, diagram zooming will be animated. If this option is not selected,
zooming will be performed in a simple way.

Enable anti-aliasing If selected, anti-aliasing will be enabled in diagram files.
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Option Description

Show status line If selected, status line content will be enabled.

Here is what the Diagram preference page looks like:

Appearance

The following preferences can be changed on the Appearance preference page.

Option Description

Default font Sets the default font set in the diagram editors, which is used for displaying text.

Font color Sets the default font color in the diagram editors, which is used for displaying text.

Fill color Specifies the end color for the gradient representation of diagram elements. An adjustment
of this setting affects only new elements. The color of existing elements will not be
changed.

Line color (Application
System)

Specifies the start color for the gradient representation of application system diagram
elements. An adjustment of this setting affects only new elements. The color of existing
elements will not be changed.
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Option Description

Line color (Subsystem) Specifies the start color for the gradient representation of subsystem diagram elements. An
adjustment of this setting affects only new elements. The color of existing elements will
not be changed.

Line color (Transactional
Function)

Specifies the start color for the gradient representation of transactional function diagram
elements. An adjustment of this setting affects only new elements. The color of existing
elements will not be changed.

Line color (Data Function) Specifies the start color for the gradient representation of data function diagram elements.
An adjustment of this setting affects only new elements. The color of existing elements will
not be changed.

Note fill color Specifies the fill color for a diagram note.

Not line color Specifies the line color for a diagram note.

Here is what the Appearance preference page looks like:

Connections

The following preferences can be changed on the Connections preference page.
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Option Description

Line style Specifies the line style for relations in the diagram editior. You can choose between
Oblique and Rectlinear .

Here is what the Connections preference page looks like:

Copy/Paste

The following preferences can be changed on the Copy/Paste preference page.

Option Description

Rename diagram elements
after copy/paste

If this option is enabled, copied elements in a diagram editor will be automatically
renamed.

Prefix If option above is enabled, this option specifies the prefix for the rename opration. E.g. if
prefix is set to Copy of , a diagram element called MyElement will be renamed to Copy of
MyElement . If the option above is disabled, this option has no influence.

Here is what the Copy/Paste preference page looks like:
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Data and Transaction Functions Settings

The following preferences can be changed on the Data and Transaction Functions Settings preference page.

Option Description

Transaction Function This option specifies the default-settings like Transaction Function Type, Complexity
and Process Type of transaction functions.

Data Function This option specifies the default-settings like Data Function Type and Complexity of data
functions.

Here is what the Data and Transaction Functions Settings preference page looks like:
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Layout

The following preferences can be changed on the Layout preference page.

Option Description

Diagram Layout Specifies the diagram layout method for diagram editors. You can choose between
FreeForm layout where all diagram elements can be placed free in a diagram editor.
Another option is Grid layout . If this option is selected, the diagram elements are placed
in a defined grid style. You can not move diagram elements by hand. Please keep in mind,
a layout change will not affect already opened editors. It is necessary, to close and re-open
these editors, so the new layout style will take place.

Here is what the Layout preference page looks like:
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Pathmaps

The following preferences can be changed on the Pathmaps preference page.

Option Description

Path variables Use the checkboxes to select path variables to use in modelling artifacts. These are a subset
of the path variables in the Linked Resources preference page. Path variables specify a
location in the file system. The location of linked resources may be specified relative to
these path variables.

Here is what the Pathmaps preference page looks like:
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Printing

The following preferences can be changed on the Printing preference page.

Option Description

Orientation Choose between Portrait and Landscape printing layout.

Units Choose between Inches and Millimeters. This selection influences the following settings.

Size Choose the target format for printing, such as e.g. A4, A3 etc.

Width Choose the target format width for printing. Changes for this option will set the size setting
to User Defined .

Height Choose the target format height for printing. Changes for this option will set the size setting
to User Defined .

Margings Top Choose the target format margin top size for printing..

Margings Bottom Choose the target format margin bottom size for printing..

Margings Left Choose the target format margin left size for printing..

Margings Right Choose the target format margin right size for printing..
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Here is what the Printing preference page looks like:

Rulers And Grid

The following preferences can be changed on the Rules and Grid preference page.

Option Description

Show rulers for new diagram If selected, horizontal and vertical rulers will be shown in the diagram editors. Changing
this option did not affects already opened diagrams. It is required to close and re-open these
diagrams so that this selection takes effect.

Ruler units Sets the unit measurement for diagram rulers.

Show grid for new diagrams If selected, horizontal and vertical grids will be shown in the diagram editors. Changing
this option did not affects already opened diagrams. It is required to close and re-open these
diagrams so that this selection takes effect.

Snap to grid for new
diagrams

If selected, diagram elements will snap to grid in the diagram editors. Changing this option
did not affects already opened diagrams. It is required to close and re-open these diagrams
so that this selection takes effect.
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Option Description

Snap to shapes for new
diagrams

If selected, diagram elements will snap to shapes in the diagram editors. Changing this
option did not affects already opened diagrams. It is required to close and re-open these
diagrams so that this selection takes effect.

Grid spacing Specifies grid spacing in centimeters.

Here is what the Rulers and Grid preference page looks like:

License

 

 

The following preferences can be changed on the License preference page.

Option Description

Registration key Here you can enter your registration key for the Function Point Modeler Enterprise Edition.

Discard Discard your changes and set back your registration key to the last saved state.



 | Function Point Modeler Workbench | 505

Option Description

Save Save your changes.

Activate Activate your license.

Deactivate Deactivate your license.

Here is what the License preference page looks like:

If you're using the Standard Edition of Function Point Modeler, this preference dialog is disabled, because this edition
is free of charge.

Logging

The following preferences can be changed on the Logging preference page.

Option Description

Log level Specify the log levels, which will be shown in the Logging View.

Buffer size Specify the log buffer size. Log messages will be written to a buffer. This specification also
defines how many messages can be taken up.
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Option Description

Severe Foreground/
Background Color

Defines Foregroud and Background Color for messages of level Severe .

Warning Foreground/
Background Color

Defines Foregroud and Background Color for messages of level Warning .

Config Foreground/
Background Color

Defines Foregroud and Background Color for messages of level Config .

Info Foreground/Background
Color

Defines Foregroud and Background Color for messages of level Info .

Fine Foreground/
Background Color

Defines Foregroud and Background Color for messages of level Fine .

Finer Foreground/
Background Color

Defines Foregroud and Background Color for messages of level Finer .

Finest Foreground/
Background Color

Defines Foregroud and Background Color for messages of level Finest .

Here is what the Logging preference page looks like:

NESMA

The following preferences can be changed on the NESMA preference page.
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Option Description

Show NESMA
Functionpoints in PDF
Output

Select this option, if you want to display NESMA Functionpoints in PDF reports.

Here is what the NESMA preference page looks like:

NESMA Impact Factors

 

 

The following preferences can be changed on the NESMA Impact Factor preference page.

Option Description

Transactional Functions Calibrate Impact Factors for transactional functions.

Data Functions Calibrate Impact Factors for data functions.

Data Function Changes Calibrate Impact Factors for data function changes.

Deleted Functions Calibrate Impact Factors for deleted functions.

Cosmetic Changes Calibrate Impact Factors for cosmetic changes.

Export... Exports the current settings for NESMA Impcat Factors to an XMI file or to a SLED.

Import... Imports settings for NESMA Impact Factors from an XMI file or from a SLED.
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Here is what the NESMA Impact Factors preference page looks like:

eMail

The following preferences can be changed on the eMail preference page.

Option Description

eMail Address Enter here a valid eMail Address, such as your.name@gmail.com .

Smtp Server Name Enter here a valid Smtp Server Name, such as smtp.gmail.com .

Smtp Port Number Enter or select a valid SMTP port. The default port for the SMTP protocol is normally 25.

Username At this point you can enter your appropriate user name. Valid user names typically have the
form username@xyz.com.

Password Define here the valid password for your user name, specified above.

Connection security Select security settings for your eMail account.

Here is what the eMail preference page looks like:
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User interface information

Views and editors
Function Point Modeler Views
Calculator View

This view displays a scientific calculator with the following features:

• Integrated into the Function Point Modeler workbench
• Standard, scientific and trigonometric calculation
• Display of the calculation in base-n numbers (decimal, hexadecimal, binary)
• Uses arbitrary precision where applicable
• Memory function for a number and the last calculated result
• Enter arithmetic expressions naturally
• Copy and clear as customizable shortcut
• Use comma to enter decimal point (for German keypad i.e.)
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To add the Calculator View to the current perspective, click   Window > Show View > Other > Function Point
Modeler > Calculator .

Connections View

 

 

This view allows you to manage database connections. It is possible to establish new connections and change or
delete existing connections. It is also possible to connect to a database or to disconnect.
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To add the Connections View to the current perspective, click   Window > Show View > Other > Function Point
Modeler > Connections .

Toolbar

The toolbar of the Connections view includes the following buttons.

 Enable a connection to the selected SLED connection profile.

 Disable a connection from the selected SLED connection profile.

 Create a new SLED connection profile.

Menus

Click the icon at the left end of the view's title bar to open a menu of items generic to all views. Click the black
upside-down triangle icon to open a menu of items specific to the Connections view. Right-click inside the view to
open a context menu.

Logging Messages View

This view allows you to analyze log messages for the Application Function Point Modeler .

The Application itself creates messages at defined time points, which are classified with differentiated levels. With
the help of these messages it is e.g. possible to understand, how it came to a problem, at the time when an error
occurs.
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To add the Logging View to the current perspective, click   Window > Show View > Other > Function Point
Modeler > Logging Messages .

Toolbar

The toolbar of the Logging Messages view includes the following buttons.

 Shows the possible available stack trace of the selected table entry.

 Deletes the currently selected table entry.

 Updates the content of this view.

 Enables or disables table scroll lock in this view.

Menus

Click the icon at the left end of the view's title bar to open a menu of items generic to all views. Click the black
upside-down triangle icon to open a menu of items specific to the Logging Messages view. Right-click inside the
view to open a context menu.

Notes View

This view allows you to enter some notes.
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To add the Notes View to the current perspective, click   Window > Show View > Other > Function Point
Modeler > Notes .

The contents of a note is changed by simply overwriting the text area. You can customize the name of the note by
executing a double click on the tab at the bottom of a note.

Notes will be deleted by clicking on the little red cross on the tab at the bottom of the note. Please keep in mind that
the last note can not be deleted. So at least one note is always open.

Toolbar

The toolbar of the Note view includes the following buttons.

 Create a new empty note.

 Toggles word wrap modus in this view.

 Clears the content of the current open note.

Menus

Click the icon at the left end of the view's title bar to open a menu of items generic to all views. Click the black
upside-down triangle icon to open a menu of items specific to the Note view. Right-click inside the view to open a
context menu.

Project Navigator View

This view provides a hierarchical view of the resources in the Workbench.

Here is what the Project Navigator view looks like:
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To add the Project Navigator View to the current perspective, click   Window > Show View > Other > Function
Point Modeler > Project Navigator .

Toolbar

The toolbar of the Project Navigator view includes the following buttons.

 This command collapses the tree expansion state of all resources in the view.

 This command toggles whether the Project Navigator view selection is linked to the active editor. When this
option is selected, changing the active editor will automatically update the Project Navigator selection to the resource
being edited.

Menus

Click the icon at the left end of the view's title bar to open a menu of items generic to all views. Click the black
upside-down triangle icon to open a menu of items specific to the Project Navigator view. Right-click inside the view
to open a context menu.

Customize View

This command allows customization of view filters and content modules. The previous will allow you to supress the
display of certain types of files while the later will allow entirely new types of content to be shown in the view. Here
is what the Customize View dialog looks like:
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Link with Editor

See the toolbar item description above.

SLED Explorer View

 

 

The SLED Explorer view is the central navigation within the SLED perspective.

Using this view the contents of a SLED database can be analyzed and it is possible to delete individual database
content.
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To add the SLED Explorer View to the current perspective, click   Window > Show View > Other > Function
Point Modeler > SLED Explorer .

Toolbar

The toolbar of the SLED Explorer view includes the following buttons.

 This command collapses the tree expansion state of all resources in the view.

 This command deletes the selected element from the SLED database.

 Reloads the content of the connected SLED database. The predetermined filter is taken into account when
determining the results.

 Filters the results of the charging process. Only
entries in the database are determined whose name contains the specified filter criteria.

Function Point Modeler (Lifecycle) Views
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Application Systems View

This view lists all the currently available Application Systems within the workbench.

It is used mainly for navigation within the Lifecycle Perspective , but can also be used to gain an overview of
existing application systems.

To add the Application Systems View to the current perspective, click   Window > Show View > Other >
Function Point Modeler (Lifecycle) > Application Systems .

Toolbar

The toolbar of the Application Systems view includes the following buttons.

 Allows you to refresh the list of the existing application system.

 Allows you to filter the list of the existing application system.

 Clears the current filter settings.

Complexity View

This view is mainly used within the Lifecycle Perspective to represent the distribution of the complexity of an
application system within one measurement.

A distinction is made between the complexities Low , Average and High .

The view provides a graphical representation of the distribution of these complexities.
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To add the Complexity View to the current perspective, click   Window > Show View > Other > Function Point
Modeler (Lifecycle) > Complexity .

Enhancement Typ View

This view is mainly used within the Lifecycle Perspective to represent the distribution of the enhancement typ of an
application system within one measurement.

A distinction is made between the enhancements Added , Changed and Deleted .

The view provides a graphical representation of the distribution of these enhancements.

To add the Enhancement Typ View to the current perspective, click   Window > Show View > Other >
Function Point Modeler (Lifecycle) > Enhancement Typ .

Function Type View

This view is mainly used within the Lifecycle Perspective to represent the distribution of the function types of an
application system within one measurement.

A distinction is made between the function types EI , EO , EQ , ILF and EIF .

The view provides a graphical representation of the distribution of these function types.
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To add the Function Type View to the current perspective, click   Window > Show View > Other > Function
Point Modeler (Lifecycle) > Function Type .

Lifecycle Counts View

This view lists all the currently available Counts for a selected Application System within the workbench.

It is used mainly for navigation within the Lifecycle Perspective , but can also be used to gain an overview of
existing counts.

To add the Lifecycle Counts View to the current perspective, click   Window > Show View > Other > Function
Point Modeler (Lifecycle) > Lifecycle Counts .

Process Type View

This view is mainly used within the Lifecycle Perspective to represent the distribution of the process types of an
application system within one measurement.
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A distinction is made between the process types Interactive , Batch and Conversion .

The view provides a graphical representation of the distribution of these process types.

To add the Process Type View to the current perspective, click   Window > Show View > Other > Function
Point Modeler (Lifecycle) > Process Type .

System Lifecycle View

This view is mainly used within the Lifecycle Perspective to manage system lifecycles.

To add the Process Type View to the current perspective, click   Window > Show View > Other > Function
Point Modeler (Lifecycle) > System Lifecycle .

System Overview View

This view is mainly used within the Lifecycle Perspective to give you a detailed overview about an Application
System.
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Within this view, information about the selected application system within the selected count is processed. You can
switch between the view of the application system and the views of the respective subsystems.

To add the System Overview View to the current perspective, click   Window > Show View > Other > Function
Point Modeler (Lifecycle) > System Overview .

Function Point Modeler Editors
Diagram Editor

Function Point Modeler includes three diagram editors. The diagram editors allow you to edit each item (Count,
Application system and Subsystem ) separately.

The editors allow you to edit only the selected part of a complex count.

Application System Editor

This editor offers the possibility to carry out a count on top level. It contains all the Application Systems for a Count,
and also all child elements for this Application Systems.

For large measurements, this type of presentation is quickly confusing. This editor is therefore specified for small
measurements or for the initial launch of a large measurement.
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Subsystem Editor

This editor offers the possibility to carry out a count on medium level. It contains all the Subsystems for a Application
System, and also all child elements for this Subsystems.

For large measurements, this type of presentation is sometimes confusing. This editor is therefore specified for
medium measurements or for the medium work of a large measurement.
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Elementar Process Editor

This editor offers the possibility to carry out a count on lowest level. It contains all the Transactional Functions and
Data Functions for a Subsystem.

This editor is therefore specified for large measurements on a detailled level.
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Projectdata Editor

The Projectdata Editor allows viewing, editing and evaluation of project-related data. The editor is divided into pages
to ensure clarity.

In the Standard Edition of the Function Point Modeler only the Overview page is available.

In the Enterprise Edition of the Function Point Modeler, the editor also contains the pages Plandata and Cocomo .

Overview Page

The Overview page, part of the Plandata Editor, allows you to view or change project-related data. The page gives
your an overview about the project and additionally provides you with activities such as Create a new Project
Plandata .

For reasons of clarity and ease the page is divided into several sections. The following diagram shows a example
site view. In the Standard Edition of the Function Point Modeler not all visible sections are available, as only the
Enterprise Edition of Function Point Modeler includes the COCOMO II module.
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Plandata Page

 

 

The Plandata page, part of the Plandata Editor, allows you to manage project data.

Project data called ProjectPlanData includes all project relevant information. You can create more than one
ProjectPlanData for a Project. Each of this ProjectPlanData represents a project plan scenario for the project.

For example one of the project plan scenario would be for the Rational Unified Process (RUP) and other for Waterfall
or for the software development process specified for your company. A ProjectPlanData can include one or more
ProjectEstimation. Each ProjectEstimation represents an estimation scenario for the project. For example one of the
ProjectEstimation may be with an expert team and other with a mixed team. One of this ProjectEstimation has to be
set as default for the project, which means, that the default ProjectEstimation is the valid estimation for the project.

One of this ProjectPlanData also has to be set as default, which means, that the default ProjectPlanData is valid for
the project. Only the default ProjectPlanData of the completed projects in Software Life Cycle Experience Database
(SLED) are used for the calibration and other metrics reports.
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Cocomo Page

 

 

The Cocomo page, part of the Plandata Editor, allows you to manage COCOMO estimations for your projects.

The CO nstructive CO st MO del COCOMO cost estimation model is used by thousands of software project
managers, and is based on a study of hundreds of software projects. Unlike other cost estimation models, COCOMO
is an open model, so all of the details are published, including:

• The underlying cost estimation equations
• Every assumption made in the model (e.g. "the project will enjoy good management")
• Every definition (e.g. the precise definition of the Product Design phase of a project)
• The costs included in an estimate are explicitly stated (e.g. project managers are included, secretaries aren't)

COCOMO II is the latest major extension to the original COCOMO (COCOMO 81) model published in 1981.
COCOMO consists of three submodels, each one offering increased fidelity the further along one is in the project
planning and design process. Listed in increasing fidelity, these submodels are called the Applications Composition,
Early Design, and Post-architecture models.
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Wizards
Function Point Modeler
Count

This wizard helps you to create a new Count.
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Option Description Default

Project Select the workspace project, where the
Count will be created

The selected workspace project in the
Project Navigator if this wizard was
started with a valid project selection

Browse... Browse for a existing workspace project

Name Enter the name for the new count here

Type Select the count type for the new count Corresponding count type, if this wizard
was started with a valid selection

Phase Select the count phase for the new count Default count phase is inception

Base count The name of the base count, if you create
a Enhancement or Application Count and
a base count is selected

Browse Browse for a base count if you create
a Enhancement Count or Application
Count

Clear Clear the base count selection

Copy Count

This wizard helps you to create/copy a new Count.
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Option Description Default

New Count Name Enter the name for the new Count. Name from base copy extended by
CopyOf...

Create new System Select option, if you want to create new
Systems.

Functionpoint Project

This wizard helps you to create a new Functionpoint Project.
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Option Description Default

Project name Enter the project name here

Use default location Create the new project in the default
workspace location

Option is selected by default

Location Enter the project location outside the
workspace

Disabled by default. Enabled when
option above is deselected

Browse... Browse for a project location
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Option Description Default

Project Specify project type here. Options below
are disabled for project type Application
Project

Application Project

Name The new project name (read only)

Internal Project Id An optional internal project identifier

Begin The project begin date

End The project end date

Customer surename The project customer surename

Firstname The project customer firstname

Contractor surename The project contractor surename

Firstname The project contractor firstname

Manager surename The project manager surename

Firstname The project manager firstname

State The project state In the planning
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Option Description Default

Type The project type Application Project

Calculatable for SLED Select this option, if you want to enable
the project for SLED calculation

Option is selected by default

Update Count

This wizard helps you to update an existing Application Count.

Option Description Default

List of available counts Select a base count to perform the update
operation.

Wiki

 

 

Wiki File

 

 

This wizard helps you to create a new Wiki File.
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Option Description Default

Enter or select the parent folder Enter or select the parent folder where the
new wiki file will be created

File name Enter the new wiki file name here

Wikitype Specify the type of wiki file MediaWiki

Advanced>> Toggle advanced options

Link to file in the file system Select this option if you want to created a
linked resource

Browse Browse for a linked resource

Variables Created a linked resource by selecting a
variable definition
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Wiki Project

 

 

This wizard helps you to create a new Wiki Project.

Option Description Default

Project name Enter the project name here

Use default location Create the new project in the default
workspace location

Option is selected by default

Location Enter the project location outside the
workspace

Disabled by default. Enabled when
option above is deselected

Browse... Browse for a project location

Examples
Functionpoint Examples

This wizard helps you to create some Functionpoint Example Projects.



 | Function Point Modeler Workbench | 535

Option Description Default

Examples Select examples you want to import to
your workspace

All available examples are selected by
default

Overwrite existing projects inside
the workspace

Select this option, if you want to
overwrite the workspace files if they
already exist. If this option is not
selected, you will be prompted for each
file which already exists

Option is selected by default

Import
Count from XMI

 

 

This wizard helps you to import a Count from XMI format.
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Specify file attributes and import type

Option Description Default

Project Select the workspace project, where the
Count will be imported

Browse... Browse for a existing workspace project

FPM file name Specify the target name for the Count

XMI file source Specify the source file which should be
imported

Browse... Browse for a existing source file

Use Case Model Select this option, if you want to import a
XMI Use Case Model

If this option was selected with the last
export process

Class Model Select this option, if you want to import a
XMI Class Model

If this option was selected with the last
export process
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Specify import options for Use Case Model

Option Description Default

Application Systems Select this option if you want to import
the tree element as Application System

Sub Systems Select this option if you want to import
the tree element as Subsystem

Use Case Select this option if you want to import
the tree element as Use Case
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Specify import options for Class Model

Option Description Default

Application Systems Select this option if you want to import
the tree element as Application System

Sub Systems Select this option if you want to import
the tree element as Subsystem

Boundary class Select this option if you want to import
the tree element as Boundary Class

Entity class Select this option if you want to import
the tree element as Entity Class

Operation Select this option if you want to import
the tree element as Operation
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Specify import options for Use Case Model (Elementar Process)

Option Description Default

EI Select this option if you want to import
the tree element as EI

EO Select this option if you want to import
the tree element as EO

EQ Select this option if you want to import
the tree element as EQ
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Specify import options for Class Model (Elementar Process)

Option Description Default

EI Select this option if you want to import
the tree element as EI

EO Select this option if you want to import
the tree element as EO

EQ Select this option if you want to import
the tree element as EQ

ILF Select this option if you want to import
the tree element as ILF

EIF Select this option if you want to import
the tree element as EIF

ISBSG Database
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This wizard helps you to import ISBSG data.

Specify file attributes and import type

Option Description Default

Select as file Select the source ISBSG file for import

Browse... Browse for a existing ISBSG file

Use as header Specify the header row

File content preview and row
selection

Show preview of the import file and
select rows for import
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Map ISBSG model to FPM model

Option Description Default

File content preview Show preview of the import file for
mapping

FPM model elements Show FPM model elements for mapping
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Map ISBSG attributes to FPM attributes

Option Description Default

FPM model attributes Show FPM model attributes for mapping

File content preview Show preview of the import file for
mapping

Delete Deletes the current selected mapping
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Project interchange import

This wizard helps you to import Projects from a special interchange format. There is a corresponding export wizard to
export this format from the workspace.

Option Description Default

From Zip file Specify the source file or select a a
previous entry

Browse... Browse for a existing source file

Select projects to import Select the projects which are included in
the special interchange format file

Select all Selects all available interchange projects

Deselect all Deselects all available interchange
projects

Export
Count to MS Excel
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This wizard helps you to export a Count to MS Excel format.

Option Description Default

Available Counts Select the Count from the workspace
which will be exported

Target File Specify the target file or select a a
previous entry

Browse... Browse for a existing target file or
browse for a location

Excel 97-2007 Specify output format Excel 97-2007. If
this option is selected, the target file must
end with '.xls'

If this format was selected with the last
export process
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Option Description Default

Excel 2007+ Specify output format Excel 2007+. If
this option is selected, the target file must
end with '.xlsx'

If this format was selected with the last
export process

Open exported count in viewer Select this option, if you want to open
the created target file with a designated
viewer, after the export process has
finished

If this option was selected with the last
export process

Count to XMI

 

 

This wizard helps you to export a Count to XMI format.
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Option Description Default

Available Counts Select the Count from the workspace
which will be exported

Target File Specify the target file or select a a
previous entry

Browse... Browse for a existing target file or
browse for a location

XMI Version Specify XMI and UML version for export The last selected export version

Use Case Model Select this option, if you want to export
XMI Use Case Model

If this option was selected with the last
export process

Class Model Select this option, if you want to export
XMI Class Model

If this option was selected with the last
export process

Estimation to MS Excel

 

 

This wizard helps you to export a Estimation to MS Excel format.
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Option Description Default

Available Estimations Select the Estimation from the workspace
which will be exported

Target File Specify the target file or select a a
previous entry

Browse... Browse for a existing target file or
browse for a location

Excel 97-2007 Specify output format Excel 97-2007. If
this option is selected, the target file must
end with '.xls'

If this format was selected with the last
export process

Excel 2007+ Specify output format Excel 2007+. If
this option is selected, the target file must
end with '.xlsx'

If this format was selected with the last
export process

Open exported estimation in
viewer

Select this option, if you want to open
the created target file with a designated
viewer, after the export process has
finished

If this option was selected with the last
export process
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Estimation to MS Project

 

 

This wizard helps you to export a Estimation to MS Project format.

Option Description Default

Available Estimations Select the Estimation from the workspace
which will be exported

Target File Specify the target file or select a a
previous entry

Browse... Browse for a existing target file or
browse for a location

Project 97-2007 Specify output format Project 97-2007. If
this option is selected, the target file must
end with '.mpx'

If this format was selected with the last
export process
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Option Description Default

Project 2007+ Specify output format Project 2007+. If
this option is selected, the target file must
end with '.xml'

If this format was selected with the last
export process

Project interchange export

This wizard helps you to export Projects to a special interchange format. There is a corresponding import wizard to
import this format into the workspace.

Option Description Default

Select projects to export Select the workspace projects which will
be included in the special interchange
format file

Select all Selects all available workspace projects

Deselect all Deselects all available workspace
projects
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Option Description Default

Target File Specify the target file or select a a
previous entry

Browse... Browse for a existing target file or
browse for a location

Project to SLED

 

 

This wizard helps you to export Projects to a Software Lifcecycle Empirical Database (SLED).

Option Description Default

Connection profile Provides a list of available connected
profiles. Choose the connection which
will be used for export
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Option Description Default

Avalable projects Select the workspace projects which will
be exported to SLED

Select all Selects all available workspace projects

Deselect all Deselects all available workspace
projects

Overwrite existing projects Overwrite existing projects in SLED
without confirmation. If this option
is not checked and a selected project
already exists in SLED there will be a
user confirmation dialog.

Selected or deselected, based on the last
export process selection

Dialogs
Adapted Software Dialog

 

 

This dialog allows you to to adjust the Adaption Adjustment Factor based on some settings for relevant properties.

Software Understanding

Option Description

Software Structure Understanding increpements for structure

• Very low (very low cohesion, high coupling, spaghetti code)
• Low (moderately low cohesion, high coupling)
• Nominal (reasonably well structured, some weak areas)
• High (high cohesion, low coupling)
• Very High (strong modularity, information hiding in data/control structure)

Software Clarity Understanding increments for application clarity

• Very low (no match between program and application worldviews)
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Option Description

• Low (some correlation between program and application)
• Nominal (moderate correlation between program and application)
• High (good correlation between program and application)
• Very High (clear match between program and application worldviews)

Software Self-
Descriptiveness

Understanding increments for self-descriptiveness

• Very low (no match between program and application worldviews)
• Low (some correlation between program and application)
• Nominal (moderate correlation between program and application)
• High (good correlation between program and application)
• Very High (clear match between program and application worldviews)

Assessment and Assimilation Increment

Option Description

Rating Scala • None
• Basic module search and documentation
• Some module test and evaluation, documentation
• Considerable module test and evaluation, documentation
• Extensive module test and evaluation, documentation

Programmer Unfamiliarity

Option Description

Rating Scala • Completely familiar
• Most familiar
• Somewhat familiar
• Considerably familiar
• Mostly unfamiliar
• Completely unfamiliar

Adaption Adjustment Factor

Option Description

Percent Design
Modified

Percentage of modified application design

Percent Code
Modified

Percentage of modified application code

Percent of Integration
required for adaptable
software

Percent of Integration required for adaptable software

Application System Selection Dialog

This dialog allows you to select an existing Application System from the workspace.
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Option Description

Filter criteria Enter a Application System prefix or a pattern (*, ? or camel case). The list of Application
Systems will be refreshed, matching your input.

List of matching
Application Systems

Select an Application System from the list of available Systems.

OK Accepts the selected Application System.

Cancel Cancels the request.

Architecture Type Selection Dialog

This dialog allows you to select an existing Architecture Type from the workspace.
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Option Description

Filter criteria Enter a Architecture Type prefix or a pattern (*, ? or camel case). The list of Architecture
Types will be refreshed, matching your input.

List of matching
Architecture Types

Select an Architecture Type from the list of available Types.

OK Accepts the selected Architecture Type.

Cancel Cancels the request.

Bug and Enhancement Dialog

This dialog allows you to report a Bug or Enhancement Feature.
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Option Description

Report type The type of report (bug or enhancement feature).

Description The required description for the report.

eMail Optional eMail contact information.

Other Optional other contact information.

Send as attachment For a bug report, the current application log can send as eMail attachment.

Browse Browse the current application log before send as eMail attachment.

Send as eMail Send the report a an eMail.

Cancel Cancel the request.

Calibrate from SLED Dialog

 

 

This dialog allows you to calibrate a COCOMO constant from SLED.
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Option Description

Connection profile Select a connection profile for a SLED database. Only connected profiles will be listed.

Selection criterias A collection of selection criterias which work as filter for the visible SLED content. These
criterias are selected in the previous dialog.

Calculate B Enable this checkbox if you also want to calculate COCOMO Constant B.

Projects/Estimation A collection of projects and estimations matching the filter criterias. Selected estimations
in this list will define the base for COCOMO Constant calculation.

Calibrate Perform the COCOMO Constant calibration.

Cancel Cancel the request.

COCOMO Language Selection Dialog

 

 

This dialog allows you to select one or more programming languages for COCOMO.
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Option Description

List of available
programming languages.

Select one or more languages.

Select all Selects all available entries in the list.

Deselect all Deselects all available entries in the list.

OK Accepts the selected entries.

Cancel Cancels the request.

CPLX Cost Factor Dialog

 

 

This dialog allows you to fine granular define the CPLX Cost Factor.
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Option Description

Control operations • Very low (Straight-line code with a few non-nested structured programming operators:
DOs, CASEs, IFTHENELSEs. Simple module composition via procedure calls or
simple scripts.)

• Low (Straightforward nesting of structured programming operators. Mostly simple
predicates.)

• Nominal (Mostly simple nesting. Some intermodule control. Decision tables. Simple
callbacks or message passing, including middleware-supported distributed processing.)

• High (Highly nested structured programming operators with many compound
predicates. Queue and stack control. Homogeneous, distributed processing. Single
processor soft real-time control.)

• Very High (Reentrant and recursive coding. Fixed-priority interrupt handling. Task
synchronization, complex callbacks, heterogeneous distributed processing. Single-
processor hard real-time control.)

• Extra High (Multiple resource scheduling with dynamically changing priorities.
Microcode-level control. Distributed hard real-time control.)

Computational Operations • Very low (Evaluation of simple expressions: e.g., A=B+C*(D-E))
• Low (Evaluation of moderate-level expressions: e.g., D=SQRT(B**2-4.*A*C))
• Nominal (Use of standard math and statistical routines. Basic matrix/vector operations.)
• High (Basic numerical analysis: multivariate interpolation, ordinary differential

equations. Basic truncation, roundoff concerns.)
• Very High (Difficult but structured numerical analysis: near-singular matrix equations,

partial differential equations. Simple parallelization.)
• Extra High (Difficult and unstructured numerical analysis: highly accurate analysis of

noisy, stochastic data. Complex parallelization.)

Device Dependent
Operations

• Very low (Simple read, write statements with simple formats.)
• Low (No cognizance needed of particular processor or I/O device characteristics. I/O

done at GET/PUT level.)
• Nominal (I/O processing includes device selection, status checking and error

processing.)
• High (Operations at physical I/O level (physical storage address translations; seeks,

reads, etc.). Optimized I/O overlap.)
• Very High (Routines for interrupt diagnosis, servicing, masking. Communication line

handling. Performance-intensive embedded systems.)
• Extra High (Device timing-dependent coding, micro-programmed operations.

Performance-critical embedded systems.)

Data Management
Operations

• Very low (Simple arrays in main memory. Simple COTS-DB queries, updates.)
• Low (Single file subsetting with no data structure changes, no edits, no intermediate

files. Moderately complex COTS-DB queries, updates.)
• Nominal (Multi-file input and single file output. Simple structural changes, simple

edits. Complex COTS-DB queries, updates.)
• High (Simple triggers activated by data stream contents. Complex data restructuring.)
• Very High (Distributed database coordination. Complex triggers. Search optimization.)
• Extra High (Highly coupled, dynamic relational and object structures. Natural language

data management.)

UI Management Operations • Very low (Simple input forms, report generators.)
• Low (Use of simple graphic user interface (GUI) builders.)
• Nominal (Simple use of widget set.)
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Option Description

• High (Widget set development and extension. Simple voice I/O, multimedia.)
• Very High (Moderately complex 2D/3D, dynamic graphics, multimedia.)
• Extra High (Complex multimedia, virtual reality.)

Create Count Overview Dialog

This dialog allows you to create a PDF file for a Count Overview.

Option Description

Target file Specify the target file or select a previously selected location.

Browse Browse for a target file location.

Open created file in viewer If selected, the file will be automatically opened with the corresponding viewer after
creation.

Cancel Cancel the request.

Create Count Structure Dialog

This dialog allows you to create a PDF file for a Count Structure.
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Option Description

Target file Specify the target file or select a previously selected location.

Browse Browse for a target file location.

Open created file in viewer If selected, the file will be automatically opened with the corresponding viewer after
creation.

Cancel Cancel the request.

Create PDF Dialog

This dialog allows you to create a PDF file for a report designer file.

Option Description

Target file Specify the target file or select a previously selected location.

Browse Browse for a target file location.

Open created file in viewer If selected, the file will be automatically opened with the corresponding viewer after
creation.
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Option Description

Cancel Cancel the request.

Constant Selection Dialog

 

 

This dialog allows you to select a COCOMO constant as replacement for a previously selected constant.

Option Description

COCOMO Constants A collection of available COCOMO Constants.

OK Accepts the selected COCOMO Constant.

Cancel Cancels the request.

Count Selection Dialog

 

 

This dialog allows you to select an existing Count from the workspace.
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Option Description

List of available Counts Select one or more Counts from the list of available entries.

Select all Selects all available Counts.

Deselect all Deselects all available Counts.

OK Accepts the selected Counts.

Cancel Cancels the request.

Data Function Selection Dialog

This dialog allows you to select an exsisting Data Function from the workspace.



 | Function Point Modeler Workbench | 564

Option Description

Filter criteria Enter a Data Function prefix or a pattern (*, ? or camel case). The list of Data Functions
will be refreshed, matching your input.

List of matching Data
Functions

Select a Data Function from the list of available functions.

OK Accepts the selected Data Function.

Cancel Cancels the request.

Development Process Import Dialog

 

 

This dialog allows you to import Development Processes from an XMI File or a SLED location.
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Option Description

Destination type Select the destination type for import (XMI or SLED).

OK Perform the import process.

Cancel Cancels the request.

XMI Document

Option Description

Filename Specify the XMI file location or select a previously selected entry.

Browse Browse for a XMI file location.

Database

Option Description

Connection profile Select a connection profile. Only connected profiles are available for selection.

Development Process Export Dialog

 

 

This dialog allows you to export Development Processes to an XMI File or a SLED location.
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Option Description

Destination type Select the destination type for export (XMI or SLED).

OK Perform the export process.

Cancel Cancels the request.

XMI Document

Option Description

Filename Specify the XMI file location or select a previously selected entry.

Browse Browse for a XMI file location.

Database

Option Description

Connection profile Select a connection profile. Only connected profiles are available for selection.

Dialect Selection Dialog

 

 

This dialog allows you to specify a SQL dialect for a SLED operation.
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Option Description

Filter criteria Enter a SQL dialect prefix. The list of dialects will be refreshed, matching your input.

List of matching SQL
Dialects

Select a SQL dialect from the list of available dialects.

OK Accepts the selected dialect.

Cancel Cancels the request.

Elementar Process Adjustment Dialog

This dialog allows you to adjust elementar process properties.
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Option Description

Enhancement Typ Select the corresponding enhancement typ for this elementar process.

Function Typ Select the corresponding function typ for this elementar process.

Process Typ Select the corresponding process typ for this elementar process.

Complexity Specify the complexity in form of assessment, range or value and adjust settings for
enhanced functionpoints.

OK Accepts the selected values.

Cancel Cancels the request.

Error eMail Dialog

This dialog allows you to send an application error as eMail information.
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Option Description

Recipient Information about the eMail recipient.

Subject Information about the eMail subject.

eMail Text Information about the eMail text/content.

Send as eMail Sends this application error as eMail to the specified recipient.

Cancel Cancels the request.

General System Characteristics Dialog

This dialog allows you to adjust the general system characteristics for a count.
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Option Description

Data communications How many communication facilities are there to aid in the transfer or exchange of
information with the application or system?

Distributed data processing How are distributed data and processing functions handled?

Performance Was response time or throughput required by the user?

Heavily used configuration How heavily used is the current hardware platform where the application will be executed?

Transaction rate How frequently are transactions executed daily, weekly, monthly, etc.?

On-Line data entry What percentage of the information is entered On-Line?

End-user efficiency Was the application designed for end-user efficiency?

On-Line update How many ILF’s are updated by On-Line transaction?

Complex processing Does the application have extensive logical or mathematical processing?

Reusability Was the application developed to meet one or many user’s needs?

Installation ease How difficult is conversion and installation?

Operational ease How effective and/or automated are start-up, back-up, and recovery procedures?

Multiple sites Was the application specifically designed, developed, and supported to be installed at
multiple sites for multiple organizations?

Facilitate change Was the application specifically designed, developed, and supported to facilitate change?

OK Accepts the selected values.

Cancel Cancels the request.
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Language Selection Dialog

This dialog allows you to select an existing Language from the workspace.

Option Description

Filter criteria Enter a Language prefix or a pattern (*, ? or camel case). The list of Languages will be
refreshed, matching your input.

List of matching Languages Select a Language from the list of available Languages.

OK Accepts the selected Language.

Cancel Cancels the request.

License Warning Dialog

 

 

This dialog allows you to register your Application Version. This dialog will only pop-up in Enterprise Edition when
a predefined number of Functionpoints exceeds while counting a system.
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Option Description

Registration key Enter a valid registration key at this location.

OK Perform the registration process.

Cancel Cancels the request.

Logical File Adjustment Dialog

This dialog allows you to adjust logical file properties.
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Option Description

Enhancement Typ Select the corresponding enhancement typ for this logical file.

Function Typ Select the corresponding function typ for this logical file.

Complexity Specify the complexity in form of assessment, range or value and adjust settings for
enhanced functionpoints.

OK Accepts the selected values.

Cancel Cancels the request.

Maintenanced Software Dialog

 

 

This dialog allows you to to adjust the Maintenanced Adjustment Factor based on some settings for relevant
properties.

Software Understanding

Option Description

Software Structure Understanding increpements for structure

• Very low (very low cohesion, high coupling, spaghetti code)
• Low (moderately low cohesion, high coupling)
• Nominal (reasonably well structured, some weak areas)
• High (high cohesion, low coupling)
• Very High (strong modularity, information hiding in data/control structure)

Software Clarity Understanding increments for application clarity

• Very low (no match between program and application worldviews)
• Low (some correlation between program and application)
• Nominal (moderate correlation between program and application)
• High (good correlation between program and application)
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Option Description

• Very High (clear match between program and application worldviews)

Software Self-
Descriptiveness

Understanding increments for self-descriptiveness

• Very low (no match between program and application worldviews)
• Low (some correlation between program and application)
• Nominal (moderate correlation between program and application)
• High (good correlation between program and application)
• Very High (clear match between program and application worldviews)

Programmer Unfamiliarity

Option Description

Rating Scala • Completely familiar
• Most familiar
• Somewhat familiar
• Considerably familiar
• Mostly unfamiliar
• Completely unfamiliar

Adaption Adjustment Factor

Option Description

Percent Design
Modified

Percentage of modified application design

Percent Code
Modified

Percentage of modified application code

Percent of Integration
required for adaptable
software

Percent of Integration required for adaptable software

Masterdata Import Dialog

 

 

This dialog allows you to import COCOMO Masterdata from an XMI File or a SLED location.
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Option Description

Destination type Select the destination type for import (XMI or SLED).

OK Perform the import process.

Cancel Cancels the request.

XMI Document

Option Description

Filename Specify the XMI file location or select a previously selected entry.

Browse Browse for a XMI file location.

Database

Option Description

Connection profile Select a connection profile. Only connected profiles are available for selection.

Masterdata Export Dialog

 

 

This dialog allows you to export COCOMO Masterdata to an XMI File or a SLED location.
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Option Description

Destination type Select the destination type for export (XMI or SLED).

OK Perform the export process.

Cancel Cancels the request.

XMI Document

Option Description

Filename Specify the XMI file location or select a previously selected entry.

Browse Browse for a XMI file location.

Database

Option Description

Connection profile Select a connection profile. Only connected profiles are available for selection.

NESMA Impact Factor Export Dialog

 

 

This dialog allows you to export NESMA Impact Factors to an XMI File or a SLED location.
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Option Description

Destination type Select the destination type for export (XMI or SLED).

OK Perform the export process.

Cancel Cancels the request.

XMI Document

Option Description

Filename Specify the XMI file location or select a previously selected entry.

Browse Browse for a XMI file location.

Database

Option Description

Connection profile Select a connection profile. Only connected profiles are available for selection.

NESMA Impact Factor Import Dialog

 

 

This dialog allows you to import NESMA Impact Factors from an XMI File or a SLED location.
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Option Description

Destination type Select the destination type for import (XMI or SLED).

OK Perform the import process.

Cancel Cancels the request.

XMI Document

Option Description

Filename Specify the XMI file location or select a previously selected entry.

Browse Browse for a XMI file location.

Database

Option Description

Connection profile Select a connection profile. Only connected profiles are available for selection.

New Process Dialog

 

 

This dialog allows you to create a new Development Process
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Option Description

Process name Edit the name for the development process.

Based on Information about the base process for this new process.

OK Accepts the changes.

Cancel Cancels the request.

New Process Version Dialog

 

 

This dialog allows you to create a new Development Process Version

Option Description

Based name Information about the base process for this new process version.

Based version Information about the base process version for this new process version.

Process version Edit the name for the development process version.
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Option Description

OK Accepts the changes.

Cancel Cancels the request.

Phase Selection Dialog

This dialog allows you to select an existing Phase from the workspace.

Option Description

Filter criteria Enter a Phase prefix or a pattern (*, ? or camel case). The list of Phases will be refreshed,
matching your input.

List of matching Phases Select a Phase from the list of Phases.

OK Accepts the selected Phase.

Cancel Cancels the request.

PDF Estimation Dialog

 

 

This dialog allows you to create a PDF file for an estimation.
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Option Description

Target file Specify the target file or select a previously selected location.

Browse Browse for a target file location.

Open created file in viewer If selected, the file will be automatically opened with the corresponding viewer after
creation.

Cancel Cancel the request.

Platform Type Selection Dialog

This dialog allows you to select an existing Platform Type from the workspace.
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Option Description

Filter criteria Enter a Platform Type prefix or a pattern (*, ? or camel case). The list of Platform Types
will be refreshed, matching your input.

List of matching Platform
Types

Select a Platform Type from the list of available Types.

OK Accepts the selected Platform Type.

Cancel Cancels the request.

Release Value Adjustment Factor Dialog

This dialog allows you to create a PDF file for a Release Value Adjustment Factor.

Option Description

Target file Specify the target file or select a previously selected location.

Browse Browse for a target file location.

Open created file in viewer If selected, the file will be automatically opened with the corresponding viewer after
creation.

Cancel Cancel the request.

Reused Software Dialog

 

 

This dialog allows you to to adjust the Reused Adjustment Factor based on some settings for relevant properties.
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Assessment and Assimilation Increment

Option Description

Rating Scala • None
• Basic module search and documentation
• Some module test and evaluation, documentation
• Considerable module test and evaluation, documentation
• Extensive module test and evaluation, documentation

Adaption Adjustment Factor

Option Description

Percent of Integration
required for adaptable
software

Percent of Integration required for adaptable software

SITE Cost Factor Dialog

 

 

This dialog allows you to fine granular define the SITE Cost Factor.
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Option Description

Collocation Descriptors Multisite Development Collocation

• Very low (International)
• Low (Multi-city and Multi-company)
• Nominal (Multi-city or Multi-company)
• High (Same city or metro. area)
• Very High (Same building or complex)
• Extra High (Fully collocated)

Communication Descriptors Multisite Development Communication

• Very low (Some phone, mail)
• Low (Individual phone, FAX)
• Nominal (Narrowband email)
• High (Wideband electronic communication)
• Very High (Wideband elect. comm, occasional video conf)
• Extra High (Interactive multimedia)

Subsystem Selection Dialog

This dialog allows you to select an existing Subsystem from the workspace.
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Option Description

Filter criteria Enter a Subsystem prefix or a pattern (*, ? or camel case). The list of Subsystems will be
refreshed, matching your input.

List of matching Subsystems Select a Subsystem from the list of available Systems.

OK Accepts the selected Subsystem.

Cancel Cancels the request.

Update Process Dialog

 

 

This dialog allows you to update an existing Development Process.
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Option Description

Process name Change the name for the development process.

OK Accepts the changes.

Cancel Cancels the request.

Update Process Version Dialog

 

 

This dialog allows you to update an existing Development Process Version.

Common

Option Description

Process name Information about the name for the development process.

Process version Identification for the process version.

Phases Allows you to add, remove or change phases. It's also possible to re-arrange phases (move
up/down).

Activities Allows you to add, remove or change activities. It's also possible to re-arrange activities
(move up/down).
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Allocation

Option Description

Project size Change between the different project sizes within this version.

Phase Visualization for phases for the select project size (name, percentage and schedule).

Activity Visualization for activities for the select project size (name and percentage).

Estimate If selected, the phase/activity will be estimated for COCOMO.

Calculate If selected, the phase will be calculated for estimation.

Percentage Percentage part for the phase/activity.

Schedule Percentage part for the schedule.

Total estimated Information about total percentage for a estimated phase/activity. Sum for COCOMO
ingredients must be 100.

Total non-estimated Information about total percentage for a non-estimated phase/activity.

Summary Some of total estimated and non-estimated for a phase/activity.

Common

Option Description

OK Accepts the changes.

Cancel Cancels the request.

Workbench menus
File menu

The File menu enables you to create, save, close, print, import, and export Workbench resources and to exit the
Workbench.

New (Shift+Alt+N) Enables you to create new resources. Before you can
create a new file, you must create a project in which to
store the file.

Open File Enables you to open a file for editing - including files
that do not reside in the Workspace.

Close (Ctrl+W) Closes the active editor. You are prompted to save
changes before the file closes.

Close All (Shift+Ctrl+W) Closes all open editors. You are prompted to save
changes before the files close.

Save (Ctrl+S) Saves the contents of the active editor.

Save As Enables you to save the contents of the active editor
under another file name or location.

Save All (Shift+Ctrl+S) Saves the contents of all open editors.

Revert Replaces the contents of the active editor with the
previously saved contents.

Rename (F2) Enables you to change the name of the currently selected
resource.

Refresh (F5) Refreshes the resource with the contents in the file
system.
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Convert Line Delimiters To Alters the line delimiters for the selected files. Changes
are immediate and persist until you change the delimiter
again - you do not need to save the file.

Print (Ctrl+P) Prints the contents of the active editor.

Page Setup Enables page setup of the print output.

Print Preview Performs print preview of the content of the active editor.

Switch Workspace Opens the Workspace Launcher, from which you
can switch to a different workspace. This restarts the
Workbench.

Import Launches the Import wizard, which enables you to add
resources to the Workbench.

Export Launches the Export wizard, which enables you to export
resources from the Workbench.

Properties (Alt+Enter) Opens the Properties dialog for the currently selected
resource.

Recent file list Contains a list of the most recently accessed files in the
Workbench. You can open any of these files from the
File menu by simply clicking the file name. You can
control the number of files in this list from the Editors
preference page.

Exit Closes and exits the Workbench.

Edit menu

This menu helps you manipulate resources in the editor area.

Undo This command reverses your most recent editing action.

Redo This command re-applies the editing action that has most
recently been reversed by the Undo action.

Cut This command removes the selection and places it on the
clipboard.

Copy This command places a copy of the selection on the
clipboard.

Paste This command places the text or object on the clipboard
at the current cursor location in the currently active view
or editor.

Delete This command removes the current selection.

Select All This command selects all text or objects in the currently
active view or editor.

Add Bookmark This command adds a bookmark in the active file on the
line where the cursor is currently displayed.

Add Task This command adds a task in the active file on the line
where the cursor is currently displayed.

Project menu

The Project menu allows you to perform actions on projects in the Workbench.
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Open Project This command opens the currently selected project or
projects. The selected projects must currently be closed
for this command to be available.

Close Project This command closes the currently selected project or
projects. The selected projects must be currently open
for this command to be available. Closing a project will
remove all of that project's state from memory, but the
contents on disk are left untouched.

Open projectdata editor This command open the projectdata editor for the
selected workspace project. This command is only
available for Development Projects or Enhancement
Projects.

Properties This command opens a dialog showing the properties
of the selected project or of the project that contains the
selected resource.

Window menu

This menu allows you to display, hide, and otherwise manipulate the various views, perspectives, and actions in the
Workbench.

New Window This command opens a new Workbench window with the
same perspective as the current perspective.

New Editor This command opens an editor based on the currently
active editor. It will have the same editor type and input
as the original.

Open Perspective This command opens a new perspective in this
Workbench window. This preference can be changed on
the General > Perspectives preference page. All of the
perspectives that are open within the Workbench window
are shown on the shortcut bar. The perspectives you will
likely want to open are listed first. This list is dependent
on the current perspective. From the Other... submenu
you can open any perspective.

Show View This command displays the selected view in the current
perspective. You can configure how views are opened
on the General > Perspectives preference page. Views
you are likely to want to open are listed first. This list is
dependent on the current perspective. From the Other...
submenu you can open any view. The views are sorted
into categories in the Show View dialog.

Customize Perspective Each perspective includes a predefined set of actions
that are accessible from the menu bar and Workbench
toolbar.

Save Perspective As This command allows you to save the current
perspective, creating your own custom perspective.
You can open more perspectives of this type using the
Window > Open Perspective > Other menu item once
you have saved a perspective.

Reset Perspective This command changes the layout of the current
perspective to its original configuration.

Close Perspective This command closes the active perspective.
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Close All Perspectives This command closes all open perspectives in the
Workbench window.

Navigation This submenu contains shortcut keys for navigating
between the views, perspectives, and editors in the
Workbench window.

Preferences This command allows you to indicate your preferences
for using the Workbench. There are a wide variety
of preferences for configuring the appearance of the
Workbench and its views, and for customizing the
behavior of all tools that are installed in the Workbench.

Help menu

This menu provides help on using the Workbench.

Welcome This command will open the welcome content.

Help Contents This command displays the help contents in a help
window or external browser. The help contents contains
help books, topics, and information related to the
Workbench and installed features.

Search This command displays the help view opened on the
Search page.

Dynamic Help This command displays the help view opened to Related
Topics page.

Key Assist ... This command will display a list of key bindings.

Cheat Sheets ... This command will open the cheat sheet selection dialog.

Report a bug or enhancement ... This command will open a dialog which enables you to
report a bug or enhancement feature.

About Function Point Modeler This command displays information about the product,
installed features, and available plug-ins.

Icons and buttons
Project Navigator view icons

The following icons can appear in the Project Navigator view:

Icon Description

Container for all Application Projects in the Workbench

Container for all Development Projects in the Workbench

Container for all Development Projects in the Workbench

Container for all Other Projects in the Workbench

Represents a Workbench Project

Represents a Functionpoint Count
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Toolbar buttons

The following buttons may appear in the Workbench toolbar, toolbars for views, and the shortcut bar:

Icon Description Icon Description

Open a new perspective Save the active editor contents

Save the contents of all editors Save the active editor contents

Print editor contents Open a resource creation wizard

Open a file creation wizard Open a folder creation wizard

Open a project creation wizard Open the import wizard

Open the export wizard Cut selection to clipboard

Copy selection to clipboard Paste selection from clipboard

Undo most recent edit Redo most recent undone edit

Navigate to next item in a list Navigate to previous item in a list

Navigate forwards Navigate backwards

Navigate up one level Add bookmark or task

Open a views drop down menu Close view or editor

Pin editor to prevent automatic reuse Filter tasks or properties

Go to a task, problem, or bookmark in the
editor

Restore default properties

Show items as a tree Refresh view contents

Sort list in alphabetical order Cancel a long running operation

Delete selected item or content Last edit location

Samples
The examples illustrate the usage of the key features oft Function Point Modeler . It demonstrates how to create an
application system from scratch. You will start with Development Project Count and create an application system
called Application Count from the previous Development Project Count.

Once you have created Application Count for your application system, you can create an Enhancement Project
Count for this current application system. During the Enhancement Project Count you may change/add/delete the
Transactional Functions and Data Functions. You may also create an estimation for your enhancement project and
gather some Project Actual Data for the project.
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Once you have completed your project, you update your original Application Count for your application system. You
will see how to manage such typical life cycle of a software with Function Point Modeler.

Among the Function Point Analysis counting example there are two other examples. One of them is Report
Examples for Function Point Modeler Report Designer and other is Wiki Project example.

If you have not already done so, create the example:

1. From the main menu bar, select   File >New > Example...

 

 
2. Click the button Next>
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3. And click the button Finish>

One you have clicked on the button Finish> you will see the following examples on your Function Point
Modeler workbench.
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Development Project Count Example

This example illustrate  Development Project Count  . During a development project you create a new application
system.

A  Development Project Count  can contain Elementar Processes with the Process Type conversion . If you create an
Application Count  from  Development Project Count  , the new  Application Count  does not contain the Elementar
Processes with the Process Type conversion .

 

ditafiles	asks	sk-34.html
ditafiles	asks	sk-34.html
ditafiles	asks	sk-37.html
ditafiles	asks	sk-34.html
ditafiles	asks	sk-37.html
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Development Project Function Point Calculation

The development project function point is used for the new development projects. The development project function
point calculation consists of three components of functionality:

1. Application functionality included in the user requirements for the project.
2. Conversion functionality included in the user requirements for the project .
3. Application value adjustment factor.

Function Point Formula:

Use the following formula to calculate the development project function point count.

DFP = (UFP + CFP) * VAF

Where:

DFP is the development project function point count

UFP is the unadjusted function point count for the functions that will be available after installation

CFP is the unadjusted function points added by the conversion unadjusted function point count

VAF is the value adjustment factor

Note: After software installation, the  Application Count  is calculated using components of the  Development
Project Count  .

Refer to IFPUG document Function Point Counting Practices Manual for additional information about the
function point analysis, or see at:  IFPUG  for additional information.

Application Count Example

This example illustrate  Application Count  calculated from  Development Project Count  . The  Application Count 
measures the functions provided to the users with the first installation of the software delivered when the development
project is complete.

ditafiles	asks	sk-37.html
ditafiles	asks	sk-34.html
ditafiles	asks	sk-34.html
http://www.ifpug.org
ditafiles	asks	sk-37.html
ditafiles	asks	sk-34.html
ditafiles	asks	sk-37.html
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A  Development Project Count  can contain Elementar Processes with the Process Type conversion . Once you have
created an  Application Count  from  Development Project Count  , the new  Application Count  does not contain the
Elementar Processes with the Process Type conversion .

 

 

Application Function Point Calculation

This section provides the formulas to calculate the  Application Count  . There are two variations of this formula:

1. Formula to establish the initial function point count for an application.
2. Formula to re-establish the function point count for an application after an enhancement project has changed the

application functionality.

Formula to Establish the Initial Count:

Use the formula in this section to establish the initial function point count for an application. Initially, the user
is receiving new functionality. There are no changes to the existing functionality or deletions of obsolete or
unneeded functionality. The  Application Count  does not include conversion requirements.

AFP = ADD * VAF

Where:

AFP is the initial application function point count.

ADD is the unadjusted function point count of those functions that were installed by the development project.

VAF is the value adjustment factor of the application.

Formula to Reflect Enhancement Projects

When an enhancement project is installed, the existing application function point count must be updated to reflect
modifications to the application. The functionality for the application can be altered in one or more ways:

a. Added (new) functionality increases the size of the application
b. Changed functionality increases, decreases, or has no effect on the size of the application
c. Deleted functionality decreases the application size

ditafiles	asks	sk-34.html
ditafiles	asks	sk-37.html
ditafiles	asks	sk-34.html
ditafiles	asks	sk-37.html
ditafiles	asks	sk-37.html
ditafiles	asks	sk-37.html
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d. Changes to the value adjustment factor increase or decrease the application size

Note: Because conversion functionality does not affect the application function point count, any conversion
functionality associated with an enhancement project is omitted entirely from the application function point
calculation. Use the following formula to calculate the application function point count after an enhancement
project:

Use the following formula to calculate the application function point count after an enhancement project:

AFP = [(UFPB + ADD + CHGA) - (CHGB + DEL)] * VAFA

Where:

AFP is the application's adjusted function point count.

UFPB is the application's unadjusted function point count before the enhancement project begins.

Note: If this count is unavailable, it can be calculated using the formula UFBP = AFPB/VAFB ; where AFPB is
the adjusted application function point count before the enhancement project. VAFB is the value adjustment factor
of the application before the enhancement project.

ADD is the unadjusted function point count of those functions that were added by the enhancement project.

CHGA is the unadjusted function point count of those functions that were changed by the enhancement project.
This number reflects the size of the functions after the changes.

CHGB is the unadjusted function point count of those functions that were changed by the enhancement project.
This number reflects the size of the functions before the changes were made.

DEL is the unadjusted function point count of those functions that were deleted by the enhancement project.

VAFA is the value adjustment factor of the application after the enhancement project is complete.

Refer to IFPUG document Function Point Counting Practices Manual for additional information about the
function point analysis, or see at:  IFPUG  for additional information.

Enhancement Project Count Example

This example illustrate  Enhancement Project Count  calculated from  Application Count  .

At the begin all elementary processes have the Enhancement Type NOT CHANGED . The Enhancement Type of
NOT CHANGED means that this elementary process has not been changed in this current  Enhancement Project
Count  . If you change the state from NOT CHANGED to CHANGED or DELETED , they will be counted.

 

http://www.ifpug.org
ditafiles	asks	sk-39.html
ditafiles	asks	sk-37.html
ditafiles	asks	sk-39.html
ditafiles	asks	sk-39.html
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Enhancement Project Function Point Calculation

The enhancement project function point calculation consists of three components of functionality:

1. Application functionality included in the user requirements for the project.
2. Conversion functionality included in the user requirements for the project.
3. Application value adjustment factor.

Application Functionality

Application functionality consists of:

a. Added (new) functionality increases the size of the application
b. Function points identified from the functionality that is added by the enhancements
c. Function points counted because existing functionality is changed during the enhancement project
d. Function points counted for functionality deleted during the enhancement project

Function Point Formula

Use the following formula to calculate the enhancement project function point count.

Note: Data conversion requirements are included in this count.

EFP = [(ADD + CHGA + CFP) * VAFA] + (DEL* VAFB)

Where:

FEFP is the enhancement project function point count.

ADD is the unadjusted function point count of those functions that were or will be added by the enhancement
project.

CHGA is the unadjusted function point count of those functions that were or will be modified by the enhancement
project. This number reflects the size of the functions after the modifications.

CFP is the function point count of those functions added by the conversion.
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VAFA is the value adjustment factor of the application after the enhancement project is complete.

DEL is the unadjusted function point count of those functions that were or will be deleted by the enhancement
project.

VAFB is the value adjustment factor of the application before the enhancement project begins.

Refer to IFPUG document Function Point Counting Practices Manual for additional information about the
function point analysis, or see at:  IFPUG  for additional information.

FPTracker Example

This example illustrate  Application Count  for the application FPTracker starting from scratch. You can also create
an  Application Count  without any project count.

You may have such cases if you need an  Application Count  for an existing application system in your company.

It is recommended that all application system have to have an  Application Count  , so that you can track the
life cycle of the application system from an enhancement project to other enhancement project. All following 
Enhancement Project Count  are to created from the current  Application Count  .

 

 

Report Examples

 

 

Function Point Modeler includes a powerful Report Designer . It enables you to create powerful reports from the
Software Lifecycle Empirical / Experience Database  SLED  for the management.

You can also use the Function point Report Report Designer for any other relational database management system
(RDBMS) .

Function Point Modeler is released with some report examples.

http://www.ifpug.org
ditafiles	asks	sk-37.html
ditafiles	asks	sk-37.html
ditafiles	asks	sk-37.html
ditafiles	asks	sk-37.html
ditafiles	asks	sk-39.html
ditafiles	asks	sk-39.html
ditafiles	asks	sk-37.html
ditafilesconceptscc-84.html
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Wiki Project Examples

 

 

WikiText is a set of plug-ins for Eclipse that provide lightweight markup (wiki) parsing, editing and display
capabilities to the Eclipse platform and Mylyn. WikiText provides a parser for wiki markup and converts the markup
to HTML , Docbook , DITA , or Eclipse Help format, either via the API or by using Ant tasks. WikiText also
provides UI components (such as an editor) integrating with Eclipse and the Mylyn task editor.

Function Point Modeler includes WikiText . It enables you to create powerful documents such PDF or Eclipse help.

WikiText enables you to document some some sizing (e.g Function Point Counting rules for your company) or
estimation documents centralized. You estimation and sizing team can access this this centralized documents over
Function Point Modeler . your

Function Point Modeler is released with some WikiText examples to show key features of the WikiText.
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Installation

Installation on Windows

Installation on Windows is a simple process. Just perform the following steps.

Start the setup process by running the file Setup.exe .

Select your preferred language setting and press the OK button.
 

 

Confirm the following question by pressing the button Yes .
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Press button Next .
 

 

Accept the license agreement and press the Next button.
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Select a destination folder for the installation and press the Next button.
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Press the Next button.
 

 

The installation of the application is running in the selected destination folder.
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After the installation is completed, you can select whether you want to

• start the application after a successful installation
• want to create a desktop icon
• want to create a icon in the quick start bar

Press the Finish button subsequently.
 

 

To start the application, perform a double click on the newly created desktop icon, or select the appropriate entry in
the start menu.

Installation on Linux

Installation on Linux is a simple process. Just perform the following steps.

Create a folder at a location of your choice and copy the tar file to this location. In our example we create a folder
called fpm and the enterprise edition file was copied to this folder.
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Use the command tar -xvf FILENAME.tar to extract this file.
 

 

After the command is executed, the contents of your folder should look like this.
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To start the application, simply type the command ./fpm .
 

 

What's new
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New and Noteworthy with Function Point Modeler 5.3

Adaption to
Eclipse_x86_64 4.14.0

The application is now based on the latest version of the Eclipse x86_64 framework.

Support for Java 1.8 The application is now based on the newest Java VM version 1.8.
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Configuration
of Data and
Transaction
Functions Settings

Transaction Function Type , Complexity and Process Type of Transaction Functions and
Data Function Type Complexity of Data Functions can be configured preference page.
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Export estimation to
spreadsheet

With  Function Point Modeler 4.2  you now can export your project estimation to MS Excel or
Open Office Calc as a work breakdown structure.
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Import/Export
development
processes

You are now able to import/export development processes optional to a XML file or to your
SLED database. With the help of the SLED database, it is easier than ever, to exchange
development processes with your colleagues or associates.

Name suggestion Function Point Modeler now offers you a simple name suggestion. When you add a new
element to your diagramm, the workbench suggests a element name based on the element type.

New and Noteworthy with Function Point Modeler 5.2

Adaption to Eclipse
4.2.1

The application is now based on the very latest version of the Eclipse framework.
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Support for Java 1.7 The application is now based on the newest Java VM version 1.7.

Simplified
assignment
for COCOMO
estimations

Within the COCOMO editor, assignment of Subsystems to Subestimations has been simplified. It
is now possible to assign all underlying Subsystems to a Subestimation in one step, by a selection
of the corresponding Count or ApplicationSystem. However, once at least one subsystem to
assigned to another Subestimation, the selection of Subsystems has to be done individually.
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Support for NESMA
Function Size
Method

The application now supports calculation of NESMA Functionpoints for Enhancement Counts.

Report Integration
of NESMA Function
Size Method

NESMA Function Size Method attributes are now included in reports for Enhancement Counts.
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Optional Integration
for NESMA
Information

NESMA Function Size Method attributes for Enhancement Counts are optional for reports. The
representation of attributes for Enhancement Counts within the reports, can be turned on or of
with the help of properties.
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Configuration of
NESMA Impact
Factors

Calculation of NESMA Function Size Method for Enhancement Counts is adaptable. NESMA
Impact Factors can be changed with the help of properties.
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Simplified Navigation
in Diagrams

Navigation through graphical charts has been greatly simplified. In addition to the previous
graphical representation within the Outline View, a tree view has been created, which represents
the current state of the graphical diagram. By electing an element in the tree, direct navigation
to the graphical representation in the diagram is possible. The structural view of the diagram is
preset as the default, but at any time you can switch back to the graphical representation of the
Outline View. In addition, when selecting an item in the tree view, Properties View is updated
automatically. Thus, it is now possible to make fast adjustments of the selected element.
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Visualize Relations
between Subsystems
in Count Structure
Report

A relation between Subsystems is now visualized within the report Count Structure by
indentation the tree structure.
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New and Noteworthy with Function Point Modeler 5.1

New attribute
Internal Project ID

A new attribute Internal Project ID was introduced. You can use this attribute to map a reference
to your company's internal project numbers.

New classification for
estimations

A new classification attribute Estimation Typ was introduced for estimations. You can use this
attribute to classify an estimation.
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Several new
attributes for
ProjectPlandata

Several new attributes for ProjectPlandata were introduced. Using these attributes, it is possible
to capture data from plandatas for projects in more detail.

Several new
attributes for
ProjectActualData/
ProjectPhaseActualData

Several new attributes for ProjectActualData and ProjectPhaseActualData were introduced.
Using these attributes, it is possible to capture actual datas from projects in more detail.
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Splitting names
for managers,
contractors and
customers

The names for the project roles manager, contractor and customer have been split into first and
last name. It is now possible to record these names more accurately and consistently.

New entity Project
Interruption
introduced

A new entity Project Interruption was introduced. You can use this entity in the planning data of
a project to collect and document project interruptions.
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New entity
Unestimated Effort
introduced

A new entity Unestimated Effort was introduced. You can use this entity in the planning data of a
project to collect and document unestimated project efforts.

Redesign for
overview page in
projectdata editor

The overview page of the projectdata editor has been completely redesigned. It is now possible,
among other things, to run activities for projects directly from this page.
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Redesign for
plandata page in
projectdata editor

The plandata page of the projectdata editor has been completely redesigned. The creation and
deletion of structural elements is now supported with the help of buttons in the section heading.

Redesign for cocomo
page in projectdata
editor

The cocomo page of the projectdata editor has been completely redesigned. The creation and
deletion of structural elements is now supported with the help of buttons in the section heading.
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Talking and readable
editor titles

The titles of the graphical editors for ApplicationSystems, Subsystems and ElementarProcesses
are now more meaningful.

Staffing in
COCOMO
calculation

In connection with the calculation of COCOMO efforts for projects, now also the optimal
staffings will be calculated. The underlying calculation formulas can be defined as required in the
development processes.
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Synchronization
option in the
projectdata editor

If counts were changed after they are already included in the project data, now a warning message
appears in the project editor. By selecting this message, the correction of count data within the
project data will be carried out fully automatically.

Extension of Cocomo
Master Data

There were several new user-defined types included within Cocomo Master Data. Thes types
already contain fundamental characteristics, but may be extended.
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Extension of SLED
Export

Exports to SLED has been thoroughly revised and expanded. All new attributes and entities have
been taken into account. Now all elementary functions, phases and activities will be exported.
Also now all Counts and Estimations for a project will be exported to SLED, regardless of
whether they are used within the project or active/inactive.

Revision for SLED
explorer

The SLED Explorer view has been completely redesigned and equipped with new features. It is
now much easier to check or verfy the contents of a SLED database.
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Complete redesign of
application help

The application help was written in this version from scratch. It is now also available in PDF
form and includes a total of more than 650 pages.

Adaption to Eclipse
3.7.2

The application is now based on the very latest version of the Eclipse framework.
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New Splash Screen A new Splash Screen was added to the current product version.

New Output Formats
for Report Designer

Reports, that are created using the Report Designer can now be exported to PDF, ODT or PPT.

Renaming diagram
elements after copy/
paste

Diagram elements can now automatically renamed after copy/paste actions. The guidelines for
the renaming can be defined in the application properties.
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Extension of the
selection dialog for
existing application
systems

The selection dialog for existing application systems have been extended to the respective project
name, where the system is located. In the original version, systems of the same name but different
projects can not be distinguished.

New prompt dialog
during drag/drop in
the project navigator

When drag/drop files into the project navigator, a dialog will be offered, which allows the
requested action to be more specific.
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eMail by SSL The application configuration now supports sending of SSL emails. The supported protocols are
STARTTLS and SSL/TLS .

Decorators added to
different wizards

Decorators for projects and counts were added to the following wizards:

• Example Wizard
• Export to SLED Wizard
• Import Project Interchange Wizard
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Display of the
memory monitor

The memory monitor is now automatically displayed in the status bar for the first time the
application was started. The behavior and appearance of the monitor can be defined in the
settings of the application.

New report examples
included

Some new report designs are included in the project examples.
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Presentation factory
introduced

A simple presentation factory was introduced in this version. This is disabled by default, but can
be activated within the properties of the application.

Cheat Sheets Several new and existing Cheat Sheets were established. They were also grouped into categories
to improve the clarity in the selection.

Refresh list of
application systems

A button was added to the toolbar of the Application System view, which allows you to refresh
the list of available application systems from the current workspace.
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New and Noteworthy with Function Point Modeler 5.0

Elementar Process
properties

A new, completely redesigned dialog for editing properties of an elementary process was
introduced. With this dialog it is now possible, to select the complexity of an elementary process
either with the help of three different ways.

• Assessment - The complexity is explicitly selected
• Range - The complexity is determined by selecting an area
• Value - The complexity is determined by specifying a precise value

Logical File
properties

A new, completely redesigned dialog for editing properties of a logical file was introduced. With
this dialog it is now possible, to select the complexity of a logical file either with the help of three
different ways.

• Assessment - The complexity is explicitly selected
• Range - The complexity is determined by selecting an area
• Value - The complexity is determined by specifying a precise value
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Create and/or
Customize the Cost,
Scala, Factors,
Language, Platform,
etc.

It is now possible to create or customize your own Scala Factors, Cost Factors, Architecture
Types, Platform Types etc. Simply create a new element of your own, change the settings and use
it in your measurements and estimations.
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Redesign of Cost/
Scala Factors
visualization

The visualization of Cost Factors and Scala Factors in the Cocomo editor has been redesigned
and unified.

New color schema
introduced

A new color scheme was introduced. All plots within the application are now in a uniform blue
color schema shown.
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VAF in Count
Overview

The VAF was added to the report Count Overview .

New Count Structure
Report

A new report showing the structure of a measurement was integrated. To call the report just use
the menu Create reports > Count structure .
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The report represents the structure of a measurement in a simple tree structure, and gives a quick
overview of the state the measurement.

New Release VAF
Report

A new report showing the release VAF of a measurement was integrated. To call the report just
use the menu Create reports > Release Value Adjustment Factor .

The report represents the current state of the Value Adjustment Factors of a measurement.
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Based on Eclipse
3.7.1

Function Point Modeler 5.0  is now based on Eclipse 3.7.1. (Indigo)

Simplified SLED
Model

The SLED database model has been completely revised and simplified. Now you can find all
needed information for evaluation purposes and statistics in a compact and clear presentation.
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Team integration With version 5.0, the team integration has completely changed. In earlier versions of Function
Point Modeler cross-team sharing of measurements was performed using the SLED database.
This process brought some disadvantages. For this reason, the methodology for the exchange
of measurements has completely revised. It is now possible with the help of popular source
management systems, to share and synchronize the work between different teams. Function
Point Modeler already provides two possible team provider for this purpose. Out of the box CVS
and Subversion are supported. Due to the plugin technology Function Point Modeler however is
able to integrate the source control system of your choice. Prerequisite for this is that your Source
Management System delivers a common connection to Eclipse in form of a plug-in.
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Create and manage
connections

Database connections are now created and managed centrally in one postion. Function Point
Modeler provides a new view for this. To open this view, select in the menu bar  Window >
Show View > Other > Function Point Modeler > Connections . This view offers a variety of
possibilities, to create new connection profiles, modify, or delete them. With one mouse click,
it is now possible to establish a connection or to disconnect. At any point within the application
where a database connection is required (e.g. Export SLED) you can now simply select an
already created connection profile which is already connected to the underlying database.
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New Splash Screen Function Point Modeler 5.0  has a completely redesigned Splash Screen.

New and Noteworthy with Function Point Modeler 4.4

ISBSG Import
Interface

Function Point Modeler 4.4 Enterprise Edition now offers you the opportunity to import
International Software Benchmarking Standard Group ISBSG data into the  Function Point
Modeler  in order to calibrate COCOMO based on the ISBSG data. This allows you to select
from the ISBSG database, projects that are similar to the project that you wish to estimate.
You can then import these projects into the SLED and use them to calibrate the cost factors in
COCOMO to provide you with a reliable estimate.

Project Actual Data
Detail Editor

Function Point Modeler 4.4 Enterprise includes a new detail editor for project actual data.
It enables you to gather more detail project actual data based on activities for each phase and
defects.
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New Properties
Editor

The new properties editor is included in the  Function Point Modeler 4.4  . All properties of the
selected items are also managed in this new editor.

Based on Eclipse
3.6.2

Function Point Modeler 4.4  is now based on Eclipse 3.6.2. (Helios)

Project Navigator Function Point Modeler 4.4 now offers you a brand new project navigator. Projects are now
arranged and categorized. It is now much easier for users to get an overview of the actual content
of his workspace.
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Name suggestion Function Point Modeler 4.4 now offers you a simple name suggestion. When you add a new
element to your diagramm, the workbench suggests a element name based on the element type.
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Web Browser
Integration

Function Point Modeler 4.4 Enterprise Edition now offers you a integrated web browser.
Surf the internet and visit your favorite sites without having to leave the familiar Function Point
Modeler workbench.

New and Noteworthy with Function Point Modeler 4.3

Reduction to two
Editions

Function Point Modeler 4.3  is now available in two editions. First of all the Standard Edition
which is totally free for personal, educational or commercial use. Sencond, the Enterprise Edition
the only product on the market today that not only sizes software with Function Point Analysis or
estimates software with COCOMO, but also manages all of the IT-Metrics (Project, Product and
Process Metrics) of your company in a Software Life Cycle Experience Database (SLED). It is
the best Application Lifecycle Management (ALM) tool based on Function Point Analysis

New Splash Screen Function Point Modeler 4.3  has a completely redesigned Splash Screen.
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Product version in
title bar

Function Point Modeler 4.3  now shows the current product version in it's title bar.

Calibrate COCOMO
constants

Function Point Modeler 4.3  now offers the possibility to calibrate COCOMO constants on the
basis of projects in the SLED database. You are now able to calibrate your constants on the basis
of empirical informations.

Seal count It is now possible to seal a count. Sealed counts can no longer be edited by the user. Of course
you can unseal a count whenever you want.
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New Shortcut for
project editor

To view or edit the project editor you are able now to use an even faster shortcut. Just select a
development or enhancement project and press the key combination ALT + P.
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New diagram layout You can now select between the well known free-form layout or a new grid layout to display
your diagrams. With the free-form layout your diagram elements will be positioned by yourself.
With the new grid layout all diagram elements are arranged automatically by a predefined grid.
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Import/Export
development
processes

You are now able to import/export development processes optional to a XML file or to your
SLED database. With the help of the SLED database, it is easier than ever, to exchange
development processes with your colleagues or associates.

Import/Export
COCOMO
masterdata

You are now able to import/export COCOMO masterdata optional to a XML file or to your
SLED database. With the help of the SLED database, it is easier than ever, to exchange
COCOMO masterdata with your colleagues or associates.
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Revision of license
information

In the Edition Edition the dialog to display license advice has been revised. The required serial
number to unlock the Enterprise Edition can now be entered directly in this dialog.
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Example projects
enhanced

The sample projects of Function Point Modeler has been enhanced by examples of document
fragments. A new example to demonstrate the versatility of the tool was added. This example is
the implementation of the Help chapter Function Point Analysis .

New and Noteworthy with Function Point Modeler 4.2

New operating
system support

Function Point Modeler 4.2  now runs on Windows XP, Windows Vista, Windows 7 or Linux
GTK (32- or 64-bit)..

Run in system tray Function Point Modeler 4.2  now provides the possibility to minimize the application to the
system tray on program exit.
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Export estimation to
spreadsheet

With  Function Point Modeler 4.2  you now can export your project estimation to MS Excel or
Open Office Calc as a work breakdown structure.

New estimation
printing option

Function Point Modeler 4.2  provides extended printing capability for estimations. The new
cooperate design for estimations is now also part of the count printing option.
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Legal info Function Point Modeler 4.2  now shows legal informations in the about dialog for all referenced
plugins.
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New date chooser
widget

Function Point Modeler 4.2  comes with a new date chooser widget to provide comfortable date
selection to the user.

New intro theme By default  Function Point Modeler 4.2  comes with a new intro theme called Slate.
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Complete Wiki
feature

Function Point Modeler 4.2  includes a complete set of Wiki feature with editors and wizards to
create your own wiki with MediaWiki, Textile, Confluence, TracWiki and TWiki markup.

Extended installation
information

Function Point Modeler 4.2  provides an extended installation information in the about dialog..
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New and Noteworthy with Function Point Modeler 4.1

Simple but powerful
calculator

Function Point Modeler 4.1 includes a simple but powerful calculator who works in HEX, DEC
or BIN modus.
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Based on Eclipse
3.5.2

Function Point Modeler 4.1  is now based on Eclipse 3.5.2.

New and Noteworthy with Function Point Modeler 4.0

Manage your
software
development process

Function Point Modeler 4.0  allows you to manage the software development process in your
company.
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You can add, remove and change the software development process phase and activities as they
are defined in your company.
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You can also change the estimation distribution for each phase or activity.
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You can use now the new defined software development process for your estimations. It appears
in development process ComboBox .
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Your estimation is now distributed based on the new defined software development process.

New editors for
Counts, Application
Systems and Sub
Systems

Function Point Modeler 4.0  includes now 3  diagram editors. The new diagram editors allow
you to edit each item ( count, application system und sub system ) separately. In the count
diagram editor, double click the application system to edit the selected application separately.

The editors allow you to edit only the selected part of a complex count.
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New Exports Function Point Modeler 4.0  includes two export functions.

You can export counts as excel sheet.
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You can also export estimations to any project managment tool e.g. MS project as project plan

Additional Views Function Point Modeler 4.0  includes now more than 30 views.
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New Logging
Message View

The new  customizable logging message view allows you to take look at the inside of  Function
Point Modeler.
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Notes Editor You can take take notes in your count or projects

More Prefernces Function Point Modeler 4.0  includes much more preference setting to customize your
Function Point Modeler
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New and Noteworthy with Function Point Modeler 3.x

Life Cycle 
Perspective

You can now view the life cycle of application systems in your company. The Life Cycle
Perspective shows you each function point analysis detail from the first development of the
application system till current application system count . The Life Cycle Perspective  includes a
lot of views for the counts and sub system of an application system.

Quick Life Cycle The  Quick Life Cycle  give you historical overview of the selected count ( development project
count > application count > enhancement project, etc. ). You can start the  Quick Life Cycle
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Ctrl+L. You can start Quick Life Cycle  from the context menu.   You can also use the keyboard
shortcut Ctrl+L .

You can also select a count from Quick Life Cycle View to open it in diagram editor.

Transactional
Function and Data
Function Filter

Function Point Modeler 3.1 now allows you to show or hide the  transactional functions and data
functions in a count.



 | Function Point Modeler Workbench | 666

The  transactional functions of a count are hided in the following screen shot.

Defining your
favorite Line Color
and Fill Color in the
Editor

The Window > Preference > Connections > Function Point Modeler > Diagram
>Appearance  page allows you to specify the line colour of each item separately.
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Defining your setting The Window > Preference > Connections > Function Point Modeler > Diagram > Printing 
page allows you to specify you print setting.

Print your Function
Point Modeler
diagram

Standard printing features are now available for printing Function Point Modeler  diagrams.
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You can also specify which diagrams you want to print and how to scale them to fit on the paper.

Linking the
Navigator view to the
active editor

When you have multiple files open for editing, you can configure one of the navigation views to
automatically bring an open file to the foreground (make its editor session the active editor) every
time you select that open file in one of the navigation views.
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Collapsing
compartments

You can collapse a compartment in a data diagram to a minimal size to allow more space for the
other compartments in a shape.

After the Transactional Functions compartment is collapsed.
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Calibrate or set new
vale of COCOMO
constants .

Function Point Modeler Advanced Enterprise 3.1 Cocomo II tool now allows you to calibrate
or set the new value of COCOMO constants.

You can use the for your company calibrated constants in your estimation.

Project estimation
calculated based on
the RUP

Function Point Modeler Advanced Enterprise 3.1Cocomo II tool supports Rational Unified
Software Development Process.
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Database support
extended

Function Point Modeler Advanced Enterprise 3.1 now supports all well-known database
vendors for your SLED.

XMI 2.1 for UML
2.1.1 for example
IBM RSA

Function Point Modeler Advanced Enterprise 3.1 now supports XMI 2.1 and UML 2.1.1
export/import.
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You can also export your Function Point Model as Business Object Model to any UML tool.
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Project Interchange
to export & import
projects

Sharing projects using Project Interchange. If you are not using SLED database you can use the
Project Interchange feature to share your project in the Function point Modeler

You export projects into ZIP files, which can be imported.



 | Function Point Modeler Workbench | 674

Cheat Sheets Function Point Modeler 3.1 provides cheat sheets to guide you through some of its function
point counting and report designer processes. Each cheat sheet is designed to help you complete
some task, and it lists the sequence of steps required to help you achieve that goal.
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As you progress from one step to the next, the cheat sheet will automatically launch the required
tools for you. If there is a manual step in the process, the step will tell you to perform the task and
click a button in the cheat sheet to move on to the next step.
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More Views Function Point Modeler 3.1 includes a lot of useful views
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Key Assist This command will display a list of key bindings
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FPM Report
Designer and mor
useful features

Function Point Modeler Advanced Enterprise 3.1 Report Designer  is now more powerful
than ever.

You can now create more complex reports using the FPM Report Designer Chart Wizard.

Legal
The material in this guide is Copyright (c) Function Point Modeler Inc. and others 2005, 2012.
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